No video in Kaffeine

For the last two days or so I have been having a problem with Kaffeine. When I want to watch a film or tv show I have downloaded I am able to get the audio but there is no video at all. I haven’t carried out any software installations in the last few days, hardware or software, so I can’t explain why this is happening. I tried to deinstall then reinstalled Kaffeine but it didn’t work, audio yeas, video no.

Anyone have any ideas?


I don’t think its a Kaffeine problem. You can try reinstalling the restricted format Codecs.

What kaffeine package do you have installed?

Mine for reference (needs to be Packman version):

linux:/home/dean # rpm -q kaffeine

The libxine1 package as well:

linux:/home/dean # rpm -q libxine1

Please provide more details about your graphics hardware, desktop environment, and whether you have Compiz_Fusion enabled. This may yield some clues as to what is going on.

Also use the Kaffeine context menus & setup the xine engine to point to /dev/sr0 (or whatever your’s is) vice /dev/dvdrom (or whatever).

I just stuck a DVD in and it worked fine.

I am using version

Where do I find the restricted format codecs?

snakedriver, how/where exactly do I access and change those settings?

I installed a new graphics card about a week ago. A gforce 9800GTX+ with 512MB DDR3.

The libxine1 is the same as yours.

I am using opensise 10.3. I have been waiting for 11.0 to “mature” a little before installing it. I am using KDE3.x as my desktop. I am not a big fan of Gnome. As such, I believe Compiz is used for Gnome, so I know Compiz is not enabled. At least I did not, at any point enable it.

You can find the restricted format codecs in this link. But you have libxine1 installed, so may be they are already installed!

BTW for me openSUSE 11.0 is more than mature!

Restricted Formats - openSUSE-Community

Kmenu > Multimedia > Video Player > Kaffeine > Settings > Xine Engine Parameters & check each item

Its possible you performed an update and installed rpms that are incompatible with each other. For openSUSE multimedia, IMHO it is important that you do NOT mix videolan rpms with packman packaged rpms. I recommend you remove videolan from your repository list and only keep OSS, NON-OSS, Update and Packman. No others. None! If you MUST do an update from others, do so on an adhoc, only as required basis, and remove the other repository immediately after the update.

To check your rpms, please type:
rpm -q kaffeine libxine1 libffmpeg0 w32codec-all xvid libquicktime0
They all should have a “.pm” in their name, indicating they are from Packman. If any of them do not, then you are mixing your rpm sources.

Also, enabling “special desktop effects” can cause the symptom you are experiencing. If you have “special desktop effects” enabled (ie 3D graphics/the-cube) Go to your setup in your video player and change your output video module to “x11” and try again to play your videos.

thanks for this; I looked up the opensuse restricted formats page; and of curiosity, clicked on the Gnome install button: YaST pointed out it would activate both videolan and packman sources; but very usefully YaST detailed what it would install; it allowed me to check what I already had installed; I cancelled the one-click install; (in fact, we did have all that the one-click woudld have offered;)

Going backwards: I don’t have any special effects enabled since the graphics card I had before, might have been able to handle it but I didn’t want to risk it; I tried it under 10.2 and the PC hung up on me.

I checked the rpms just as you had them listed, copied and pasted the line, almost all are installed and have “.pm” in the name; the only one not installed is the last one you have in the list “libquicktime0”, which I am going to install now.

It didn’t seem to make any difference. I did have to deinstall libquicktime1 in order to install libquicktime0.

Go to your setup in your video player and change your output video module to “x11” and try again to play your videos

Where would I find the output video module. Is it the same place that snakedriver mentioned in the earlier post - “Kmenu > Multimedia > Video Player > Kaffeine > Settings > Xine Engine Parameters” or is it somewhere else?

Its under:
Kaffeine > Settings > Xine Engine Parameters"
but if you have not enabled special desktop effects then this is not the problem.

Rather than force us to continue to speculate with many trial and error suggestions, how about giving us some more concrete information to go on?

Please state the EXACT video and audio codec in the video you are trying to play ? One way to do this, is open a konsole, navigate to the video file location (lets say, for example, the files is called “silksfile.avi” ) and type:
file silksfile.avi
and post the output here

I downloaded a episode of the TV series called flashpoint. here is the exact output

TV-Series> file flashpoint.s01e07.hdtv.xvid-0tv.avi
flashpoint.s01e07.hdtv.xvid-0tv.avi: RIFF (little-endian) data, AVI, 624 x 352, 23.98 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)

The episodes I have downloaded of tv-series’ and movies work fine with SMPlayer but not with Kaffeine. I played a DVD last night using Kaffeine without a problem. I am a little confused as to why one would work and the other won’t. DVD - Yes, AVI - No.

MPlayer obtains its codecs from a different source.

The video codec is XviD.

Do you have xvid installed?
PackMan :: Informationen zum Paket xvid

Yes, xvid is installed.

Did you try:
Kaffeine > Settings > Xine Engine Parameters
… check if x11, xv, or xshm (or some other parameter) works with your xvid video.

I saw that x11 was not available in the list.

xv and xshm were. I selected them, one after the other, and restarted Kaffeine. No joy. I did try the other options but could not get them to work. I kept getting an error message - Can’t init new Video Driver opengl - using auto! This error message was repeated everytime except when I used xv and xshm.

I can play xvid with no problem using xine and hence also with kaffeine.

You have confirmed your kaffeine is using the xine engine? (and not gstreamer)?

Please, to remove the possibility of finger trouble, could you POST here the output of:
rpm -q libxine1 kaffeine w32codec-all libffmpeg0 xvid MPlayer

I’m particularly curious about your libffmpeg0 version, as that is typically where xine gets its xvid codec from.

I just tried xine and one of the episodes I downloaded. Audio was perfect, but no video.

Here is the output you wanted to see:

> rpm -q libxine1 kaffeine w32codec-all libffmpeg0 xvid MPlayer

Just tried the tv episode in Codeine and Totem, audio great in Codeine but no video. Totem didn’t work at all.

Double checked SMPlayer and MPlayer. Both work fine.