No video from Logitech Quickcam E3500

Hello everyone,

I have a Logitech Quickcam 3500 attached to my system. The camera is brand new and worked up to a few days ago. Now, when I want to use it, I get either a totally black image or a bunch of scanlines. Also, the activity light on the camera fails to come on when checked in Kopete for instance.
The system is running openSUSE 11 with both KDE 3.5 and KDE 4, fully up to date.

The device is seen by the system, as proven by lsusb:

Bus 005 Device 005: ID 046d:09a4 Logitech, Inc.

The uvcvideo module is loaded for this camera, and I believe that to be correct.

# lsmod | grep uvc
uvcvideo * * * * * * * 73864 *3
compat_ioctl32 * * * * 17664 *1 uvcvideo
videodev * * * * * * * 48000 *4 uvcvideo
v4l1_compat * * * * * *29572 *2 uvcvideo,videodev
usbcore * * * * * * * 164812 *8 

*Dmesg tells me this:

# dmesg | grep uvc
uvcvideo: Found UVC 1.00 device <unnamed> (046d:09a4)
uvcvideo: Failed to query (135) UVC control 1 (unit 0) : -110 (exp. 26).
usbcore: registered new interface driver uvcvideo 

I then tried a program called luvcview. That gives me this:

# luvcview
luvcview 0.2.4

SDL information:
* Video driver: x11
* A window manager is available
Device information:
* Device path: */dev/video0
Stream settings:
* Frame format: MJPG
Unable to set format: Device or resource busy
*Init v4L2 failed !! exit fatal

Googling for this issue hasn’t produced much in the way of additional troubleshooting steps. I have tested the camera by hooking it up to a Wintendo box and that does produce an image, so I know the camera is not broken, it is a Linux problem. Is there anything else I can do?



I have the same problem with the same camera on opensuse 11.1

It works after I start my Computer. I can see video in skype. but when I try to see the video in kopete or webkam it doesn’t work. after I try this it doesn’t work in skype anymore.


I don’t use Skype myself, but perhaps I should reboot and just try luvcview before trying Kopete or so. Maybe that will produce an image then.

Also the “device or resource busy” message tells me something is fishy. Why would the camera be busy, since it is obviously not used?

If anyone has any more ideas, please let me know!

Investigating further reveals that the problem is mainly with Kopete (KDE4). When I close Kopete4 and then try to run luvcview, I get great looking video in luvcview, much better than in Kopete4.
If I close luvcview and then open Kopete3, I do get video! However, the picture quality is very poor, with distorted colors and much smaller than I get in luvcview.

How could that be? And why doesn’t Kopete4 work properly?