No video after the xorg-x11-Xvnc- update

Guys. A few minutes ago I have applied the last openSUSE 11.3 patch about a xorg-x11-Xvnc-xxx package (recommended). After the reboot video is not working anymore at any session.
I tried the failsafe with no success.
I also removed the xorg file again through terminal but KDE is not showing me video. There’s only a black screen.
By the way I can hear some apps loading so the system is working well, it’s only video issues.

ATI Radeon HD2400 with catalyst 10.8

Thanks in advance!

Its unlikely the update to xorg-x11-Xvnc-xxx broke your graphics. HOWEVER there is also an xorg-x11-server update available, and that has a HIGH PROBABILIY of breaking a proprietary driver.

If you installed the Catalyst driver from the .run file ‘the hardway’ then simply remove the fglrx rpm you installed, then rebuild the driver ‘the hardway’ and it should work.

It is VERY common for kernel updates and selected x11-xorg updates to break the proprietary graphic driver.

Thanks oldcpu! The rebuild in ‘the hard way’ works for the proprietary drivers.
The thread should be edited now as Solved.

By the way how can I avoid xorg related updates in the future??? I mean I would like to keep updating through “patch”.


Typically SuSE-GmbH ONLY release xorg updates for good reasons (ie important security fixes). Hence it typically is best to judiciously apply such updates.

In my case, I never apply an update, without first checking to see what it is. For example, I am now ‘sitting’ on 3-weeks of updates that I have NOT applied to my openSUSE-11.2 PC, because I was in the middle of a video project (that I finished last night :slight_smile: ) and I did NOT want to risk any breakage.

But now that I have finished that activity, I’ll likely apply my updates tonight (of which there are many) AFTER first checking to see what each one is.

I’m not sure what any of this means, but I have the same problem. I was running the ATI proprietary driver, installed according to their directions (run their installer, then reboot) and this has worked just fine for a very long time. Not anymore; although I was able to get video back, the resolution and response time is horrible.

Can you direct me to more detailed instructions? I have no idea what you are talking about here.


You should at first remove your installed catalyst drivers depending on how did you install them. In my case I had to remove them running the uninstaller (/usr/share/ati/ to rebuild then again with the installation script.