No video after boot with IBM x3650 and embedded ES1000 display adapter.

Hi folks,

I was wondering if anyone else ran into and issue with 11.3 with an IBM x3650 server using the embedded graphics card. As a reference this exact machine was working under 11.2. I am aware that there were significant changed in how video works in 11.3.

While installing and during the initial start of the operating system I can see graphical output, OPEN SUSE logo and such.

During the boot process the screen goes blank. The server is still running and I am able to ssh to the machine, but there is no access to the console.

Below is a segment of the /var/log/boot.msg that shows some errors. I can provide more logs if that would assist in tracking this down.

I did a quick google search on ES1000 and i2c and saw the same errors reported with Ubuntu version but nothing for OPENSUSE. There seemed to be a bug that was fixed in that kernel.

<6> 2.277737] [drm] radeon: cp idle (0x00008080)
<6> 2.277767] [drm] Loading R100 Microcode
<6> 2.277770] platform radeon_cp.0: firmware: requesting radeon/R100_cp.bin
<6> 2.279454] [drm] radeon: ring at 0x00000000B0000000
<6> 2.279476] [drm] ring test succeeded in 1 usecs
<6> 2.279554] [drm] radeon: ib pool ready.
<6> 2.306294] input: Dell Dell USB Keyboard as /devices/pci0000:00/0000:00:1d.0/usb2/2-2/2-2:1.0/input/input1
<6> 2.306369] generic-usb 0003:413C:2003.0002: input,hidraw1: USB HID v1.10 Keyboard [Dell Dell USB Keyboard] on usb-0000:00:1d.0-2/input0
<6> 4.279080] [drm] ib test succeeded in 0 usecs
<6> 4.279189] [drm] No valid Ext TMDS info found in BIOS
<6> 4.279246] [drm] Radeon Display Connectors
<6> 4.279248] [drm] Connector 0:
<6> 4.279249] [drm] VGA
<6> 4.279259] [drm] DDC: 0x60 0x60 0x60 0x60 0x60 0x60 0x60 0x60
<6> 4.279261] [drm] Encoders:
<6> 4.279262] [drm] CRT1: INTERNAL_DAC1
<6> 4.279264] [drm] Connector 1:
<6> 4.279265] [drm] DVI-D
<6> 4.279267] [drm] HPD2
<6> 4.279268] [drm] DDC: 0x64 0x64 0x64 0x64 0x64 0x64 0x64 0x64
<6> 4.279270] [drm] Encoders:
<6> 4.279271] [drm] DFP2: INTERNAL_DVO1
<6> 4.516754] [drm] fb mappable at 0xD0040000
<6> 4.516755] [drm] vram apper at 0xD0000000
<6> 4.516757] [drm] size 786432
<6> 4.516758] [drm] fb depth is 8
<6> 4.516759] [drm] pitch is 1024
<3> 4.516763] fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing generic driver
<4> 4.517333] Console: switching to colour dummy device 80x25
<3> 4.691291] [drm:radeon_i2c_put_byte] ERROR i2c 0x08 0x30 write failed
<3> 4.715282] [drm:radeon_i2c_put_byte] ERROR i2c 0x09 0x00 write failed
<3> 4.739282] [drm:radeon_i2c_put_byte] ERROR i2c 0x0a 0x90 write failed
<3> 4.763281] [drm:radeon_i2c_put_byte] ERROR i2c 0x0c 0x89 write failed
<3> 4.787282] [drm:radeon_i2c_put_byte] ERROR i2c 0x08 0x3b write failed
<4> 4.823050] Console: switching to colour frame buffer device 128x48
<6> 4.841999] fb0: radeondrmfb frame buffer device
<6> 4.842001] registered panic notifier
<6> 4.842005] [drm] Initialized radeon 2.3.0 20080528 for 0000:01:06.0 on minor 0
<7> 4.896853] PM: Marking nosave pages: 000000000009a000 - 0000000000100000
<7> 4.896858] PM: Marking nosave pages: 00000000bffcb000 - 0000000100000000
<7> 4.897505] PM: Basic memory bitmaps created
<7> 4.909724] PM: Basic memory bitmaps freed

This is a new install and the machine is not yet in production so I have the option to experiment with it a bit.

I would be grateful for any help in fixing this or suggestions for diagnosing the problems.


Does this boot up ok in failsafe mode?

SDB:Configuring graphics cards - openSUSE


I have a server HP Proliant with a ES1000 embedded video card and I have there two installations one is Opensuse11.2 and the other is Opensuse11.3

This card worked correctly on Opensuse 11.2 in resolution 1600*1000 (driver radeon) but in 11.3 this was much more complex.

After the install of Opensuse 11.3 the card was using the framebuffer and not the radeon driver, the maximum resolution was 1024768 but my screen is a new lcd with a preferred mode 19201080

I tried using the xorg.conf from opensuse11.2 this resulted in a display with a resolution of 16001000 but all colors where greens (from dark green to light green) and I was unable to solve this. Thereafter I removed the xorg.conf and updated some files in /etc/X11/xorg.conf.d but and I’m still limited to 1140900 :stuck_out_tongue:
I needed to uncomment the instruction

Driver "radeon"

in file 50-device.conf and add the modelines in file 50-monitor.conf. (copied from the xorg.conf from opensuse11.2)

In the xorg.log.0 I found some remarks about some modes ignored due to insufficient bandwith but (why did these modes work in opensuse11.2 >:( )


thanks for the link.

I was able to get the console working with the link provided. Remarkably the first thing I tried worked.

SDB:Configuring graphics cards - openSUSE

I did not try other resolutions higher than 1024x768.


In fact, this is a very troublesome problem. I have had the same. I decided after a restart and editing Grub - added “nomodeset” to continue the installation process and follow-up.