No video after 11.4 installation

Hello all and thank you for being here for us. My issue is after having good video during installation of 11.4 Opensuse, I have bad video after installation. When 11.4 restarts I have an unreadable video pattern which renders the rest of the installation useless. It’s strange that 11.4 loads the images at boot and installs with good video, but an unreadable video after installation. My previous installations of 11.4 have been flawless. On this system I’m using a Biostar MCP61 system board, AMD Athlon CPU dual core 64, on-board video(Nvidia), 1 TB hard drive, and an analog Viewsonic VA721 17inch LCD monitor. I had Opensuse 11.1 running well on this system before I attempted an upgrade to 11.4. I tried, at initial install of 11.4, to adjust the resolution down to 1024*768 which had no effect on the installation. Then I entered “vga=0x31a” as a booting command at initial install with no good effect. After several install attempts with different configs I still get no viewable image on the display. Any thoughts?

Thanks,
Jet Driver

Try adding nomodest to the boot argument or even try failsafe boot
File:Nomodeset-example.jpg - openSUSE
Then add the nvidia repo and away you go

Thank you, sir, for your prompt response. I suspected you would respond. Your past suggestions have always provided good results. Thank you for your help.

Jet Driver

Let us know if you get stuck

Actually, there is a logical reason for that, albeit in your case its not so pleasant logic. So here is some theory for you … :slight_smile:

Installation typically uses the FBDEV graphic driver which is a highly compatible extremely LOW performance driver.

During the install (toward the end) the openSUSE installer will change to use a different driver: typically “intel” for Intel hardware, “radeon” for AMD/ATI hardware, and “nouveau” for nVidia hardware.

The configuration of these video drivers is automatic using ‘udev’ and kernel mode setting (where kernel modesetting is relatively new since around openSUSE-11.2/11.3) and where kernel modesetting is very useful nominally to automatically configure one’s PC for the video hardware. However as you have discovered the automatic video configuration does NOT always work ! :frowning:

Hence in the openSUSE-11.4 release notes it advises that when automatic configuration does not work, to try disabling the automatic kernel mode setting by specifying the boot code ‘nomodeset’. On openSUSE-11.4 in the case of the Intel driver, this will also load the ‘FBDEV’ driver again (instead of the ‘intel’ driver). In the case of AMD/ATI hardware this will also load the ‘radeonhd’ driver (instead of the ‘radeon’ driver). And in the case of nVidia hardware, this will also load the ‘nv’ graphic driver (instead of the ‘nouveau’ driver).

The above is under the assumption there are no user specified xorg.conf nor user specified edits to the files under /etc/X11/xorg.conf.d/ directory which can force a different configuration.

Now sometimes the ‘nv’ and ‘radeonhd’ will also not work, and in cases like that one can try the boot code ‘x11failsafe’ which in the case of openSUSE-11.4 will instead load the FBDEV driver.

… Anyway, good luck with ‘nomodeset’.

Well, once again, you have provided a resolution to my problem. As I booted the 11.4 install disk, the initial screen listed the install options. I chose the installation option and added “vga=0x31a nomodeset” in the boot command. Opensuse 11.4 installed as usual, but I did not get the display problem during configuration. Thank you very much for your help and consultation. Problem solved.

Thank you for your thoughts. I learn a tremendous amount from you guys and always know who to come to for help. Your insight is treasured.

Note with the boot code ‘nomodeset’ you may be using a non-optimal graphic driver. If you tell us a bit more about your graphic hardware, if it is Intel or AMD/ATI we may be able to help you tune some better performance out of it.

Please, can you advise as to the output of the following command typed in a terminal:


/sbin/lspci -nnk | grep VGA -A2

Hmmm … surfing I note the Biostar MCP61 has this page: Debian HCL - Biostar / MCP61 which suggests a GeForce 6150SE nForce 430 which likely means you are using the nv open source graphic driver, which may be the best you can do. Its possible you can get one of the proprietary nVidia drivers to work with that hardware, but I have read of GeForce 6150SE users who struggled there.

I being one of them… I have a number of 7xxx and 6xxx on/offboard nvidia cards and at least for now I found out that they work best with version 260 of the nvidia driver, downloaded from nvidia’s site and istalled “the hard way”, which is not hard at all. oldcpu has excellent stickies and tutorial you can follow for this (if all else fails, that is), or even the driver’s readme file for opensuse give reasonable instructions IINM.

See here If you’d like to read about the symptoms I found and all I tried to fix it, until finally reverting to 260.

The output is "00:0d.0 VGA compatible controller [0300]: nVidia Corporation C61 [GeForce 6150SE nForce 430] [10de:03d0] (rev a2)
Subsystem: Biostar Microtech Int’l Corp Device [1565:1405]
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]

That confirms what I discovered by surfing for the information. A GeForce 6150SE.

Please, can you copy and post the output of /var/log/Xorg.0.log to the site SUSE Paste and submit it and then post here the website/URL address that it gives you.

====

Now if you are impatient wait for my review of that large file, then as brunomcl noted, you could try an older version of the AMD proprietary graphic driver. ie go to the web site noted :

Note: Ensure you have installed the applications gcc, make and kernel-source and kernel-syms where it is IMPERATIVE/ESSENTIAL that the version number of kernel-source and kernel-syms matches the version number of your kernel. If it does not you are likely wasting yours and everyone elses time (who may be trying to help).

Then run “yast2” (you can run yast in text mode with root permissions if X window not available) and navigate to yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to “yes”. This takes a minute or two to save once changed is submitted.

Then open (with root permissions) the file /etc/modprobe.d/50-backlist.conf and blacklist the nouveau driver by adding a line at the end of that file that states:


blacklist nouveau

and then reboot your PC to the run-level-3 full screen text mode , which you do by restarting, and when the very 1st grub boot splash menu selection menu comes up when rebooting, type ‘nomodeset 3’ so that ‘nomodeset 3’ (no quotes) appears in the options line. With those boot codes select a regular boot.

That will take you to a full screen login.

Login as a regular user. Once logged in type ‘su’ (no quotes) and enter root password.

Lets assume this is a 32-bit openSUSE install. Then navigate to where the downloaded file NVIDIA-Linux-x86-260.19.44.run is located and then run (with root permissions):


sh NVIDIA-Linux-x86-260.19.44.run -q

and acknowledge the various cautions you are given. Pay careful attention any errors (take a pix of them with your digital camera).

When it completes, ignore what it states about openSUSE, and instead restart with (root permissions):


shutdown -r now

and this time when rebooting do NOT type ‘nomodeset’. Let us know if that works ?

Note the nVidia driver we were using as an example can always be uninstalled with:


sh NVIDIA-Linux-x86-260.19.44.run --uninstall

The ‘260’ is an OLD version of the proprietary driver. You could try newer versions, although user brunomcl cautions they don’t work (for him).

p.s. Did I say to ensure you have installed the applications gcc, make and kernel-source and kernel-syms where it is IMPERATIVE/ESSENTIAL that the version number of kernel-source and kernel-syms matches the version number of your kernel ? If I did not, please take note of that.

URL: SUSE Paste

Not sure how to execute a .run file? The driver I downloaded from Nvidia is a 280.13 version. I’m a rooky at terminal execution. Trying to comply with your above requests.

Where do I find the Kernel version? Sorry, wish I was more experienced at this.

That link is no good !! You are supposed to open /var/log/Xorg.0.log with a text editor. Copy the contents. Paste the contents into SUSE Paste. Click the ‘create’ button. That will create a web page with those contents. Then post that web page link here so we can examine what was in the log file.

Have you heard of YaST ? The adminstration tool for openSUSE ?

If so, have you looked in YaST > Software > Software Maintenance ? There is a seach option in that tool, … do you know how to use it ?

OpenSUSE software applications are typically packaged in a file package called an ‘rpm’ and all the information on these files and some of their content is contained in a database, that some of us call the ‘rpm database’. That contains lists of the installed rpms (applications) , the applications versions, and various other important aspects. You can also query the rpm database with a command like:


rpm -qa '*kernel*'

ie query all rpm packages with the character sequence ‘kernel’

Try that command and post here the output.

Please, why not try the 260.x version 1st. I gave you the links.

We already have one user saying the 280.x does NOT work for your hardware. Is it not more prudent to initially go with what works ?

Why not walk before you try to sprint ?

I agree. I should stick to what works. The 260 version will be the main focus. Sorry, coming off a 14 hour flight. Topping the tanks and leaving again. Will work on this later. Thanks for your help. I really appreciate it.