No Valid EFI partition.

I note that my situation may not be unique.
Recent Lenovo laptop, came with W10.
I have added a 1 TB WD Green ssd to complement the UMIS 256 GB NVMe.

Added, and removed LinuxMint as SECURE BOOT.
Added and removed PClinuxOS as LEGACY BOOT.

Installed Leap 15.3 with SECURE BOOT ENABLED.

I have made several attempts to install a BOOT manager to achieve DUAL booting,
I have only achieved DUEL booting, it will boot from the USB I installed from.

Execution of command “”/usr/sbin/shim-install", “–config-file=/boot/grub2/grub.cfg”]]" failed.
Exit code: 1
Error output: No valid EFI partition

I change to REMOVE MBR as seen in another post/answer.


I may have enough egg on my face to make an omelette.

I had tried Paragon in W10, NoGo, Gparted wont install and run.
So YAST partitioner and gingerly poke and prod…

EDIT to Mount as /boot/efi I believe.

MBR remove, NVR unchecked.

AND Voila it rebooted with the OpenSuSE option available.

So SOLVED possibly.

That’s part of the computer experience.

EDIT to Mount as /boot/efi I believe.

Yes, that is what was missing (based on your error message).

I’m glad you found it for yourself. That’s the best way of learning.