No user after installatoin

I just installed Tumbleweed - and have no user after that? … Booted from live CD and see that /home directory is empty? …

I installed again - and the same result :open_mouth:

What could be the reason?

There is a checkbox to not install any User in the Installtion.
Do you click that?

That’s what I thought the first time, so I went second time and was careful especially for this :slight_smile:

However - same result :frowning:

Anyway - can I do something to fix it? Or I need to re-install again …

No. At the login screen hit Ctrl-Alt-F2, login as root, and do


Then navigate to Security and Users. From there you have the option to create a user. Then reboot. A homedir will be created and on 1st login of the user the default folders/content will be created.

Hmmm never saw or heard of that very unique problem :\

Default install today puts home on the root partition (Not sure why they are doing this) but you still can specify that home goes on the designate home partition and mounted as /home. You will have to specify that in the install. If this is the case in your situation then you can also simply change the mount point in Yast and reboot

AFAIK only if the root partition is formatted BTRFS, then the User’s home is created as a BTRFS sub-volume on the only partition that’s not the swap partition (root partition).
If the root partition is not formatted BTRFS, of course this can’t happen so something else has to be set up, I haven’t explored that but would expect a fallback to the ole /home partition formatted XFS by default…


When I try Ctrl+Alt+F2 - I get a console with error messages being thrown constantly. Some “PCI bus error, severity=corrected …” … I can’t really see the full messages.

I didn’t format it as BTRFS but rather EXT4. Could that be the problem? Although it will be very weird to me if that is the case …

That should not matter. I only use “ext4” (except when testing). And I have not run into this problem.

On the other hand, I seem to recall that somebody had problems with users being setup, due to not using “btrfs”. I’m not sure of the exact circumstances that cause this. And I’m pretty sure that there’s a bug report on the problem. So I guess that could be related to your problem.

I figured out how I got here, even though I still can not install the OS completely.

So - pretty silly from my side, but still: at the end of the installation the process freezes and after that the installer crashes, which happens before the user setup. That’s why I have no user after that.
This is what happened the last two times, don’t know how I didn’t mention that before …

So - I created a thread about the other problem with some more useful info :