No USB Sound SUSE 11.0

I have installed a clean install of 11.0 from 10.3. I’m using BOSE usb speakers that worked fine under 10.3 and also Vista which I can dual boot to.
I have gone through the audio troubleshooting and the usb audio seems to be detected but there is no sound. I checked Yast/sound and it shows card model as USB Audio, when I look at “other”/volume, there is no sound control shown and when I “test” Master Volume there is no sound.
I ran the following script
wget -O && bash

output here general pastebin - howard - post number 1061376

Then this

su -c ‘wget -O tsalsa wget && bash tsalsa’

output here:
tsalsa.txt - (beta)

Any help would be greatly appreciated.

I had the same problem with a Plantronics headset that worked fine in OpenSuSE 10.3. I solved by switching everything through the OSS server. Not a perfect solution but it seems to work. Just have to specify to the program to use /dev/dsp1.

Do you have alsa-firmware installed?

Have you tried running “alsaconf” with root permissions ? Does user root have sound?

What are you using as a sound test? Try:
speaker-test -Dplug:front -c2 -l5 -twav

I find your mixer settings confusing. Do you have 2 cards?

Amixer contents for card 1 [Audio] _____________________________________        
amixer set 'PCM',0 76% on        

Amixer contents for card 2 [U0x46d0x8d7] _____________________________________        
amixer set 'Mic',0 Mono: Capture 0 0% on        
amixer set 'Auto Gain Control',0 off  

What happens when you set “auto gain control” ON ?

Can you post the contents of your /etc/modprobe.d/sound file after running “alsaconf”. ie
cat /etc/modprobe.d/sound

Also, post output of:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2

Have you tried creating a custom .asoundrc file to switch on your USB device? ie under /home/your-user-name with a text editor create a text file called .asoundrc and save the following contents in that file:

# usb.default begins ###
pcm.!default {
type hw
card 0
ctl.!default {
type hw
card 0
# usb.default ends ### 

then restart alsa with rcalsasound restart and try that sound test. DON’T turn up you sound too loud. You don’t want to blow your speakers in case we get lucky.

Failing that, try for card-1

# usb.default begins ###
pcm.!default {
type hw
card 1
ctl.!default {
type hw
card 1
# usb.default ends ###

then restart alsa with rcalsasound restart and try that sound test.

Thanks for the help’
I have an onboard sound card that is disabled in the bios so my only sound is through my usb speakers.

alsaconf: “no supported pnp or pci card found”

Sound Test output:
speaker-test 1.0.16

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
Playback open error: -2,No such file or directory
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
Playback open error: -2,No such file or directory

output: cat /etc/modprobe.d/sound

options snd slots=snd-usb-audio

uniq.unknown_key:USB Audio

alias snd-card-0 snd-usb-audio

output: rpm -qa | grep alsa


ouput rpm -qa | grep pulse:


output rpm -q libasound2:


Thanks for yor help

This surprises me. Its very rare alsaconf gives such an error.

Can you type:
dmesg > dmesg.txt
and post the dmesg.txt file to general pastebin - simplified internet collaboration

This is important as it notes your usb sound card as being snd-card-0. Hence the .asoundrc file that I provided is likely the one with “card 0”.

Have you rebooted since you installed alsa-firmware? If not, please do so.

Try removing these 4 apps. Reboot, and try your sound again.

Finally, searching the alsa web site for the snd-usb-audio kernel module (ie the USB generic driver), I note a lot of updates to the USB generic driver in 1.0.17 RC1 and 1.0.17 RC2 of alsa. Hence it might be worth while trying an alsa update. So update your alsa from a xterm/konsole with root permissions with (follow the EXACT sequence):

zypper ar multimedia
zypper install alsa alsa-utils alsa-tools alsa-firmware libasound2
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-default
zypper rr multimedia

Then reboot, and test your audio again (per the test I recommended). Also try running in a konsole with root permissions ‘alsaconf’ again. Test your audio. Check your mixer.

Thanks for your help.
I finally have sound, I’m not sure what part of the last suggestion worked but it did.
Now I need to figure why I don’t have sound in Firefox and Amarok, one thing at a time
Thanks again

Congratulations. I am most curious to discover what worked, but I don’t want to press you on this. Perhaps when you have the chance, you could post the output of:
rpm -qa | grep alsa
cat /etc/modprobe.d
and also post the contents of any /home/username/.asoundrc file.

Reference amarok, … please setup your repositories per the guidance here: Repositories/11.0 - openSUSE-Community in particular adding OSS, NON-OSS, Update and Packman repositories. Then replace the Novell/SuSE-GmbH amarok and xine-lib with the packman packaged versions:

  • amarok
  • libxine1
  • mad

Reference firefox, add mplayer and mplayerplug-in. ie install:

  • mplayer
  • smplayer
  • mplayerplug-in
    If you do this after setting up your repositories as noted above, all of the dependencies will be looked after automatically for you.

You should also install flash-player, but there may be 64-bit considerations that I can not help you with.

I was having the very same problem. Thanks to your tips it is now solved!! (I am using Microsoft Lifechat LX-3000 headset.

The only thing I was not able to implement was the removal of:


When I tried to remove them, Yast2 kept running but never finished getting ready to remove them. I guess that maybe because I have VirtualBox installed(!?).

Thanks Again.

Paulo André


I have the same problem with an usb audio card, it’s a e-mu 0202 by creative.

I had 2 cards, this one and another pci card.
First i could see both of them and kmix would let me choose which one i wanted to use. the problem was that the other one was set as default, and the usb one didn’t work well. for example when i logged in i had no sound, then, after several attempts to switch it on and off and changing some settings in kmix and “sound” in the yast2 i could manage to get it running. but it didn’t seem to make any sense cause i had to go to the same process all over again every time i rebooted the system, so i removed the pci card because i was not using it.

So right now the yast sees the card in the hardware information, but it still doesn’t want to work.

i’ve renewed the alsa firmware and installed the default kernel rpm, and it still doesn’t work.

so i wondered if you could please help me

tell me what information to send you and i’ll be gratefull if you cold help me

thanks, alex

It would have been better if you had started your own thread. While tagging on to an existing thread works in some forums, it does not work particularly well in ours.

Reference your sound problem, I should caution you that I do not own a USB sound card. I’ve never owned a USB sound card. So anything I might be able to offer in terms of advice is strictly theoretical, or is simply based an a hazy and possible faulty recollection of what I have read about another user posting.

You mention kmix, so I assume you are using KDE.

I don’t understand your hardware configuration. Are you saying your mother board has no onboard sound, and you had both a PCI and a USB sound card, and that you have removed the PCI sound card, and now have only the USB device?

Could you please put your PC into the hardware configuration you desire to have working and then run the following script when your PC is connected to the Internet. Simply copy and paste into a konsole:

wget && su -c 'bash ./tsalsa'

when prompted for a password, enter the root password. Please examine carefully the number of jacks (line in/out, mic, speaker) on your PC and enter that into the script as a plug/jack when asked. This script when complete, will give you a URL linked to a page where info on your sound configuration has been copied. Please post here that URL.

If you do not have the program wget, then install it first so you can download/run that script.

Also, please copy and paste the following into a konsole and post the output here:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Based on the above, I “might” be able to provide a recommendation.

Also, if you created a custom .asoundrc file, please also paste its contents to If you don’t know what I mean by an .asoundrc file then don’t bother, as clearly you did not knowingly create one.

Ok, so here’s the link: tsalsa.txt - (beta)
I did not created that file you mentioned,asoundrc.
Please notice that i have 6 jacks on the sound card, but it is not a surround one.i have the following:
1 jack for stereo output
1 jack for left speaker output(if i want to split the sound for left and right)
1 jack for right speaker output
1 jack for giutar(or other instrument) in
1 jack for mic in
1 jack for headphone output

About that other sound card on the pci, yes i had both cards installed and i removed the pci one.
Also i have an onboard sound card(so that would be the third) but it’s disabled from bios and suse didn’t seem to see it.

Thakns again,

Thanks for that. Please also do not forget the following:

Oh i somehow forgot about those commands, sorry.

So, here it is:

alex@alecs:~> rpm -qa | grep alsa
alex@alecs:~> rpm -qa | grep pulse
alex@alecs:~> rpm -q libasound2
alex@alecs:~> uname -a
Linux alecs #1 SMP 2008-07-13 20:48:28 +0200 i686 i686 i386 GNU/Linux
alex@alecs:~> cat /etc/modprobe.d/sound

it seems that the last command has no output…

isn’t it a little bit odd that the system seed the correct device, still it doesn’t want to work?


I think there should be such a file. Please now follow the instructions in the audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

In particular pay attention to step-2:

After implementing step-2, you should have an /etc/modprobe.d/sound file. If so, after implementing step-2, please again run:
cat /etc/modprobe.d/sound
and paste the output here (if your sound still does not work after step-2)

This is what i get with speaker test:

alecs:/home/alex # speaker-test -Dplug:front -c2 -l5 -twav

speaker-test 1.0.17

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib confmisc.c:768: (parse_card) cannot find card ‘0’
ALSA lib conf.c:3513: (_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392: (snd_func_concat) error evaluating strings
ALSA lib conf.c:3513: (_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251: (snd_func_refer) error evaluating name
ALSA lib conf.c:3513: (_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3985: (snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2184: (snd_pcm_open_noupdate) Unknown PCM front
Playback open error: -2,No such file or directory

I’ll get back to the other steps, but i want to mention a problem: altough the card is recognized by the system, i can’t find it in the manual sound configuration in the yast…

Also these commands return “no such file or directory”
cat /proc/asound/version
cat /proc/asound/modules
cat /proc/asound/cards

After a little bit search on the alsa site, i found this
Matrix:Module-emu10k1-fpga - AlsaProject
it seems that there’s a beta driver for this soundcard.
i’ll try to see if there’s any chance to make it work.
the most annopyng thing is that i know it works, but it just doesn’t want to.

thanks again,
i’ll keep in touch

I don’t think you are following the instructions precisely enough. The command “bash” is associated with script file you have to download first. Did you download it?

I do not see the evidence that you tried YaST > Hardware > Sound nor “alsaconf” (with root permissions), and I specifically asked you to post the output of ‘cat /etc/modprobe.d/sound’ after running that step ( #2 ).

If you go your own way to Hg (Mercurial), then you are most likely on your own. I almost certainly can’t help you there.

Just to be certain you are clear on this.

Good luck in what ever approach you take.

These steps are after step-2. There is no point in doing these if you skip step-2.

I think the guide makes it clear you are supposed to run the steps in sequence, not jump around.

You have totally lost me now.

I’ve followed the steps exactly, i’ve downloaded that file, but as i sayd, the output was “no such file or directory”.

On the other hand, everything i’ve done didn’t worked on kde, there’s still no sound.
But as soon as i changed the session into gnome the sound seems to work,i have sound even in amarok and firefox.
i think this is very odd, but it seems that i have to get used to gnome…i’d really have prefered the kde but in the given circumstances i don’t thionk i have much of a choice

Thank you very much for the advices, i don’t really know what part was the one that solved the problem, but obviously it must have been something.
Best wishes, alex

Step-2 advises you to:
a. go to YAST > Hardware > Sound and configure your sound card,

and if that doesn’t work,

b. run “alsaconf”.

You mean to say those gave no error messages, and they did not work?

And gnome works without an /etc/modprobe.d/sound file?

ie no output from
cat /etc/modprobe.d/sound

well…that’s the thing…after changing some settings and following some of the steps on the link you gave me but also on the alsa site, the new output is:
alex@alecs:~> cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.16rc2 (Thu Jan 31 16:40:16 2008 UTC).
alex@alecs:~> cat /proc/asound/modules
1 snd_usb_audio
alex@alecs:~> cat /proc/asound/cards
1 [USB ]: USB-Audio - E-MU 0202 | USB
E-MU Systems, Inc. E-MU 0202 | USB at usb-0000:00:1d.7-1, high speed

Even the gnome GUI sees the e-mu card in the “control Center”.

The output for cat /etc/modprobe.d/sound is now, but that happens because i put those things there manually, as they were included in the steps for the alsa site:

alex@alecs:~> cat /etc/modprobe.d/sound
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-emu10k1
# module options should go here

   # OSS/Free portion
   alias char-major-14 soundcore
   alias sound-slot-0 snd-card-0

   # card #1
   alias sound-service-0-0 snd-mixer-oss
   alias sound-service-0-1 snd-seq-oss
   alias sound-service-0-3 snd-pcm-oss
   alias sound-service-0-8 snd-seq-oss
   alias sound-service-0-12 snd-pcm-oss

OSS/Free portion - card #1

   alias sound-slot-0 snd-card-0
   alias sound-service-0-0 snd-mixer-oss
   alias sound-service-0-1 snd-seq-oss
   alias sound-service-0-3 snd-pcm-oss
   alias sound-service-0-8 snd-seq-oss
   alias sound-service-0-12 snd-pcm-oss

   # OSS/Free portion - card #2 (cmipci)
   alias sound-slot-1 snd-card-1
   alias sound-service-1-0 snd-mixer-oss
   alias sound-service-1-3 snd-pcm-oss
   alias sound-service-1-12 snd-pcm-oss

In the alsa site i had to use modutils, but i didn’t have that and i couldn’t install it due to some conflicts with other packages, so i didn’t have any file named config.modules or modules.config. That’s why i put those lines in this file. I don’t know if they have any effect, maybe they don’t.

If I can help you in any way to find out why the sound card is working on gnome, but not kde, and eventually what made it work/not work in the first place, i’d be gladd to provide you any necessary infromation from my system.

Best wishes,