No USB devices in Virtualbox

Hi, I just was checking things out on VirtualBox guest OS’s which I thought were all ok and noticed that USB doesn’t work.

VBoxManage list usbhost
Host USB Devices:

UUID:               8267d7b6-9d69-4fd6-beda-006df93bd6e5
VendorId:           0x04ca (04CA)
ProductId:          0x300b (300B)
Revision:           0.2 (0002)
Port:               4
USB version/speed:  1/1
Address:            sysfs:/sys/devices/pci0000:00/0000:00:14.0/usb2/2-5//device:/dev/bus/usb/002/004
Current State:      Unavailable

UUID:               28a0b324-6bed-420e-a02e-f1e9abaf7836
VendorId:           0x04f2 (04F2)
ProductId:          0xb3f6 (B3F6)
Revision:           41.83 (4183)
Port:               7
USB version/speed:  2/2
Manufacturer:       Chicony Electronics Co.,Ltd.
Product:            HD WebCam
SerialNumber:       0001
Address:            sysfs:/sys/devices/pci0000:00/0000:00:14.0/usb2/2-8//device:/dev/bus/usb/002/003
Current State:      Unavailable

UUID:               488887c2-54ae-4147-96e7-7cae8b54f673
VendorId:           0x054c (054C)
ProductId:          0x02a5 (02A5)
Revision:           1.0 (0100)
Port:               1
USB version/speed:  2/2
Manufacturer:       Sony
Product:            Storage Media
SerialNumber:       9B4001408050003623
Address:            sysfs:/sys/devices/pci0000:00/0000:00:14.0/usb2/2-2//device:/dev/bus/usb/002/005
Current State:      Busy

I installed guest additions and user is member of vboxusers so why are 2 unavailable and 1 grabbed by linux host and not passed on to vbox?
I suspect that my scanner, u710 video capture, and several others will present further problems.

FWIW, I have Leap running as a guest OS (and Windows 7 host). I had to explicitly allow various USB devices via host OS to be visible (passthrough) to the guest.

See if this helps…

http://www.htpcbeginner.com/access-usb-drive-in-virtualbox-guest-os/

Yep my install needs the extension pack which I downloaded but there are no instructions to how to install just a vain statement saying install the extension pack. Do I use some cyptic vboxmanager command, use zypper command, use rpm command, use Yast, or gzip cuz it’s a gzip archive
with no instructions where to unpack and wgat to do next.

Do you really need the extension pack? I didn’t have to do anything special with the openSUSE guest. Only guest addtions was required and the ‘virtualbox-guest-tools’ package was already installed by default.

I haven’t had to do this (and I have a Windows host OS anyway), but form what I understand the VBoxManage utility is used to to install the extension pack (.vbox-extpack file)

sudo VBoxManage extpack install name-of-extension-pack.vbox-extpack

You can list installed extension packs with

sudo VBoxManage list extpacks

Others, feel free to correct or add to this…I’m new to the VM world

The extension pack is needed to enable USB2 ports (two are shown in the OP) or USB3; on the GUI interface install by:
File > Preferences > Extensions > “Adds new package” button.

Then follow deano_ferrari’s advice on enabling/passthrough of the devices you need.

Yes, that’s how I’ve just installed the extension pack (via GUI), but so far had been able to access my storage devices using OHCI.

Misread thread and posted some stuff that won’t help the situation.

If you use openSUSE’s virtualbox packages (on the host), you need to explicitly enable USB:
copy the file /usr/lib/udev/rules.d/60-vboxdrv.rules to /etc/udev/rules.d/, open the copy in a text editor and remove the comments from the lines as instructed in the file.
I.e. it should look like this afterwards:

KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="vboxusers", MODE="0660"
#
#these lines below give access permission to vboxusers to properly work with usb nodes, but enabling them could be security risk (bnc#664520) !!
#if you can live with this security problem put these lines below in to the new file /etc/udev/rules.d/60-vboxdrv.rules so they will stay enabled also after package update
SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/lib/udev/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/lib/udev/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/lib/udev/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/lib/udev/VBoxCreateUSBNode.sh --remove $major $minor"


I marked the modified lines in red, you only need to remove the ‘#’ at the beginning.

Then USB should work.

The expansion pack is not even needed for USB 1.1 support, only for 2.0 and higher.

USB 1, 2, & 3 working in opensuse 13.2 with Virtualbox version 4.3.34_SUSEr104062
With a lot of help over time with the community here are the steps that work at least for an Acer Aspire 64 bit quad core runing
linux version 3.16.7-29desktop on a opensuse 13.2 platform & kde 4.14.9

   1 Install Virtualbox
   2. Goto Yast->users&groups and add vboxusers to your user profile
   3.Click file from the upper menu of virtualbox manager and choose network and define usually NAT os the type for the virtualbox to linux side
  •          the network should be the same in the guest as by virtualbox
     4. Define your virtual guest(s) and install them identifying memory, harddisks, shared folders, USB devices intended for use
    
  •          make sure your intended shared folder exists
     5. Start the virtual guest one at a time if you have many. In each verify network access, install guest-additions by going to the devices dropdown menu item.
     6. Open a terminal as root and check if /etc/udev/rules.d/60-vboxdrv.rules exists if it does not goto /usr/lib/udev/rules.d/60-vboxdrv.rules and copy the file to /etc/udev/rules.d/60-vboxdrv.rules
     7. Edit the file to remove the comments as per wolfi323 said in this excert
    

KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="vboxusers", MODE="0660"
#
#these lines below give access permission to vboxusers to properly work with usb nodes, but enabling them could be security risk (bnc#664520) !!
#if you can live with this security problem put these lines below in to the new file /etc/udev/rules.d/60-vboxdrv.rules so they will stay enabled also after package update
SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/lib/udev/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/lib/udev/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/lib/udev/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/lib/udev/VBoxCreateUSBNode.sh --remove $major

You now have virtualbox with network, and USB 1.1 and file sharing.
8. download virtualbox extensions from virtualbox5.0 release at virtualbox.org
9. Go back into virtual manager and under the file menu choose extensions which will open your download folder
and select the extension pack you just downloaded. Provide the root password. And now you have USB 2.0 and 3.0 support.

Hope this helps others.

Thanks to the many contributors to this issue.

Good to know you’ve got it working now. A bit easier for me with a windows-based host. Thanks for reporting back.