no updater error now, blank update page

I was getting the error. Now, if I click on the update icon. It comes up with a blank update page, instead of saying no updates available. I tried this too FYI.

> sudo zypper refresh
root’s password:
Repository ‘openSUSE-11.0-Non-Oss’ is up to date.
Repository ‘openSUSE-11.0-Oss’ is up to date.
Repository ‘Updates for 11.0’ is up to date.
All repositories have been refreshed.

lv

What is the output of this command?

$ sudo zypper dup

Today, I clicked on the red icon and received the latest updates. The icon is green again. If I click on it, I get the update screen with nothing to update. When I clicked on it before, it said “no updates available”.

>sudo zypper dup

Reading installed packages...

The following packages are going to be upgraded:
  xmoto vcdimager speex portaudio libmtp libiso9660-5 libdc1394_control12 ftgl
dbus-1-qt3-32bit chkrootkit compat


The following NEW packages are going to be installed:
  liblazy1-32bit libcap1


The following packages are going to be REMOVED:
  liblazy-32bit libcap


Overall download size: 21.3 M. After the operation, additional 9.8 M will be used.
Continue? [YES/no]:
Downloading package xmoto-0.4.2-20.1.x86_64 (1/13), 19.8 M (33.1 M unpacked)
Downloading: xmoto-0.4.2-20.1.x86_64.rpm [done (163.1 K/s)]
Installing: xmoto-0.4.2-20.1 [done]
Downloading package speex-1.1.99.3-28.1.x86_64 (2/13), 429.0 K (491.0 K unpacked)
Downloading: speex-1.1.99.3-28.1.x86_64.rpm [done (139.0 K/s)]
Installing: speex-1.1.99.3-28.1 [done]
Downloading package portaudio-19-232.1.x86_64 (3/13), 62.0 K (179.0 K unpacked)
Downloading: portaudio-19-232.1.x86_64.rpm [done]
Installing: portaudio-19-232.1 [done]
Downloading package libmtp-0.2.6.1-16.1.x86_64 (4/13), 67.0 K (297.0 K unpacked)
Downloading: libmtp-0.2.6.1-16.1.x86_64.rpm [done]
Installing: libmtp-0.2.6.1-16.1 [done]
Downloading package liblazy1-32bit-0.2-39.1.x86_64 (5/13), 9.0 K (14.0 K unpacked)
Downloading: liblazy1-32bit-0.2-39.1.x86_64.rpm [done]
Installing: liblazy1-32bit-0.2-39.1 [done]
Downloading package libiso9660-5-0.80-3.1.x86_64 (6/13), 24.0 K (48.0 K unpacked)
Downloading: libiso9660-5-0.80-3.1.x86_64.rpm [done]
Installing: libiso9660-5-0.80-3.1 [done]
Downloading package libdc1394_control12-1.2.2-6.1.x86_64 (7/13), 30.0 K (76.0 K unpacked)
Downloading: libdc1394_control12-1.2.2-6.1.x86_64.rpm [done (3.2 K/s)]
Installing: libdc1394_control12-1.2.2-6.1 [done]
Downloading package libcap1-1.10-10.1.x86_64 (8/13), 8.0 K (16.0 K unpacked)
Downloading: libcap1-1.10-10.1.x86_64.rpm [done]
Installing: libcap1-1.10-10.1 [done]
Downloading package ftgl-2.1.2-148.1.x86_64 (9/13), 44.0 K (133.0 K unpacked)
Downloading: ftgl-2.1.2-148.1.x86_64.rpm [done]
Installing: ftgl-2.1.2-148.1 [done]
Downloading package dbus-1-qt3-32bit-0.62-179.1.x86_64 (10/13), 20.0 K (55.0 K unpacked)
Downloading: dbus-1-qt3-32bit-0.62-179.1.x86_64.rpm [done]
Installing: dbus-1-qt3-32bit-0.62-179.1 [done]
Downloading package chkrootkit-0.47-85.1.x86_64 (11/13), 253.0 K (746.0 K unpacked)
Downloading: chkrootkit-0.47-85.1.x86_64.rpm [done (70.7 K/s)]
Installing: chkrootkit-0.47-85.1 [done]
Downloading package compat-2008.5.6-6.1.i586 (12/13), 315.0 K (1.5 M unpacked)
Downloading: compat-2008.5.6-6.1.i586.rpm [done (19.6 K/s)]
Installing: compat-2008.5.6-6.1 [done]
Downloading package vcdimager-0.7.23-132.1.x86_64 (13/13), 308.0 K (1.3 M unpacked)
Downloading: vcdimager-0.7.23-132.1.x86_64.rpm [done (93.7 K/s)]
Installing: vcdimager-0.7.23-132.1 [done]


lv

I wonder if this has to do with the trouble I got myself into this morning. Basically, I clicked on the suse icon in the bottom right of the task bar and accepted an update to do with dbus. I selected both the patch and the two upgrades.
The result was that my konsole was killed and when I restarted , in the hope that that would fix the problem,I was told that I have no window manager! The error message was :“Unable to find a window manager. Please make sure you installed one! Exiting…”

I was able to log into a terminal that appeared to obtain root permisions. I then tried to launch YaST from the command line to find out what had happened to dbus related stuff. To my shock, I found that YaST had been deleted!

I have left my laptop with someone (much more experienced with linux than myself) to try and fix it, but in the meantime I have nothing!

I was running opensuse 10.3.

Lukomwa