No tlmgr in texlive 2008

I finally find texlive 2008 in OpenSuse publishing repo.
(However it is impossible to find via because texlive 2008 term result in nothing.)

But after updating whole texlive tree I see that there is no tlmgr installer, it is no-available in the repo too.
What to do???

seba@whistler:~> tlmgr
bash: tlmgr: command not found

locate tlmgr gives:

seba@whistler:~> locate tlmgr

and perl /home/seba/tmp.uzqCt6gFgd/master/texmf/scripts/texlive/

Can't locate TeXLive/ in @INC (@INC contains: /usr/lib/texmf/tlpkg /usr/lib/perl5/5.10.0/i586-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/lib/perl5/site_perl/5.10.0/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl .) at /home/seba/tmp.uzqCt6gFgd/master/texmf/scripts/texlive/ line 59.
BEGIN failed--compilation aborted at /home/seba/tmp.uzqCt6gFgd/master/texmf/scripts/texlive/ line 59.

I don’t know whether this will help but all the files you list are in your home folder. I am not sure why you haven’t installed them in /usr where all the other Texlive files are though I presume from your listing that some should be in /bin.

You are mistaken.
The files in my folder is only the shell script downloaded from CTAN which was supposed to fix the problem but it didn’t.

There is no tlmgr binary in none of the texlive 2008 packages from repo Publishing.

As the latest version of tlmgr was only released yesterday, it will not have been included in 11.1.

Why not start from scratch and install the latest package from CTAN: directory: /tex-archive/systems/texlive/tlnet/2008

I dont use 11.1 only 11.0 with added repository Publishing for 11.0.
I dont have any repos added for 11.1

Building from scratch? In linux it is genrally bad idea when comes to texlive. Many applications DEPENDS on texlive packages FROM THE REPO. So even if I build from scratch I still need to have version installed from repo which is ridicoulous.

tlinst packages on CTAN may be good for Gentoo but not for way the Suse works.

A bit late and abridged, but here goes: tlmgr was removed in texlive-2008 (SuSE RPMs), because the developers want YaST to handle all updates. Tarball installation with tlmgr on 10.3 worked OK (no dependency troubles), but tlmgr is one of the weirdest GUIs I ever saw, so I got rid of it again. Did you try mpm for obtaining missing packages?

long version and sources here: http://greek***** (Oh blimey, should have chosen a more PG blog title. Yep, it’s the nagging woman/female dog variety of risqué)

You should award medal for reply for dead post…but this is normal on this forum :slight_smile:

I tried new mpm-pdftex beta 2 ported to linux but it does not work for now.
If it will whole use of tlmgr will be obsolete.