no suspend/sleep now

I have openSUSE installed both in my desktop (32-bit) and laptop (64-bit). My desktop is five years old gateway (P4) and laptop is HP DV 2500t. In both of them them sleep/hibernate works fine. Just want to share what configuration I did. Thought it might help.

I put a config file into “/etc/pm/config.d/” with,


and named it modules.

I have a nVidia video card in my laptop so also followed NVidia Suspend HOWTO.

I added a line in “/etc/pm/config.d/modules” to stop and then restart network connection automatically after suspend mode.


As I have Intel 495AGN wireless card. Works great for me. Only problem I have is the laptop rarely hang while going to or coming out of hibernation. Not sure why, may be one of you could help.

Good info!

Putting the modules to unload in the SUSPEND_MODULES=" " of the config file would be the official way.
I was having the issue that my network was not resuming correctly every time, putting it in the sleep.d hook script solved that.

As for having a problem with the rare hang when resuming… check the /var/log/pm-suspend log. Again it’s good to have a copy of a version when suspend/resume has gone well and hold that against a version when it messed up. This also goes for /var/log/messages.

On 10.3 the Xorg video driver was giving me freeze type of issues when suspending/resuming. I got that sorted by installing Xorg 7.3 (as 10.3 is ships with Xorg 7.2), but that was using an Intel graphics card.

Any hint’s/hunches on what is causing your freeze up?

It could be new Kernel update. This freeze issue started around a week ago. Hibernation used to work fine even with out **SUSPEND_MODULES=" "**in the config file. I had KDE 3.5 and gnome installed. I reinstalled again, this time only with KDE 3.5 to see whether it makes any deference. But the issue is still there. Most of the time it works fine but freeze up randomly. Specially it happens if trying to hibernate after watching some video online. Always the freeze up it happens when the system is done saving the compressed image file to the disk or done reading the image file. After that it just doesn’t do anything. The log file shows the suspend or thaw process is completed.

At this point am confused what’s going on.:confused:

Re: NVIDIA Suspend HOWTO this note:

Note: AGP support will only work with chipsets, which are supported by the nvidia kernel module. Otherwise AGP support will be disabled! Check this with “cat /proc/driver/nvidia/agp/status”. If there is no line “Status: Enabled”, then AGP support is not available. The graphics card will work without AGP, but performance will be bad.
doesn’t make that sound like a good idea!

I did create the “modeles” file and added the line for suspending ath_pci but it didn’t make any difference that I can tell.

It’s hard if not impossible to sell people the idea of putting linux on a laptop if things like suspend don’t work. Everyone I know uses that feature (suspend) all the time.

True, your best bet here is to be selective on what laptop you buy. There are enough out there supporting suspend (and Linux in general) pretty good. I’ve been quite happy with the Dell Latitude series as they haven’t given me any headaches over this…
Always also be careful with the video chipset as Intel, in my experiance, is still the safest (don’t read performance here) option.

Thanks for this. Worked like a charm except for the Nvidia bit. I have a PCI-ex card and this howto is a bit dated as such. However, the following seems to work fine in the modules file:

suspend_modules="ath_pci nvidia"

I added the last line after a post in the nvidia suspend how to. Seems to do no harm. Might try commenting it out and see if it works.

P.S. I will make a amend post if any of this info is incorrect as I am at work now and on a windows machine :smiley:

Thanks firozehh for the edits you suggested. At first I thought they weren’t working but as of 2 days ago resume and wireless resume has worked great. I’m keeping my fingers crossed. Thanks!