No Speaker-Sound on Acer Aspire 9802 - ALC 883

At first, sorry for my bad english :frowning:

I have the same problem like other guys with the laptop.

Here my System:
wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh
==> general pastebin - markus - post number 1071013

su -c ‘wget -O tsalsa wget http://home.cfl.rr.com/infofiles/tsalsa && bash tsalsa’
==> tsalsa.txt - nopaste.com (beta)

/home/markus # rpm -qa | grep alsa
alsamixergui-0.9.0rc1-705.1
alsa-devel-1.0.16-39.1
alsa-docs-1.0.16-39.1
alsa-firmware-1.0.16-24.1
alsa-tools-gui-1.0.16-47.1
alsa-tools-1.0.16-47.1
alsa-plugins-1.0.16-57.1
alsa-tools-devel-1.0.16-47.1
alsa-oss-1.0.15-48.1
kalsatools-1.5.0-544.1
alsa-1.0.16-39.1
alsa-utils-1.0.16-35.1
/home/markus # rpm -qa | grep pulse
/home/markus # rpm -q libasound2
libasound2-1.0.16-39.1
/home/markus # uname -a
Linux 2.6.25.9-0.2-default #1 SMP 2008-06-28 00:00:07 +0200 i686 i686 i386 GNU/Linux
/home/markus # cat /etc/modprobe.d/sound
options snd slots=snd-hda-intel

u1Nb.g5Eu65_2Iy6:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel
options snd-hda-intel model=auto

i try to use all other possible models like “acer”, “acer-aspire” and so on :frowning:

thx

greetings markus

I note from here:
Kubuntu GNU/Linux (8.04 Hardy Heron LTS, 7.10 Gutsy Gibbon…) on ACER Aspire 9814 WKMi and other 9800 laptop series
that a kbuntu user managed to get this working on an Acer Aspire 9814 WKM.

Then I looked at the tsalsa script output from your PC and I noted this:

Vendor/device: 8086:27d8 Subsystem: Acer Incorporated [ALI] 9814 WKMI  

which suggests your laptop is very similar.

They tried the 3stack-dig and also the 6stack-dig model options. Did you try them? Don’t forget to restart alsa (with rcalsasound restart) after each attempt, and check your mixer. Also note if you run alsaconf or yast>hardware>sound after editing your /etc/modprobe.d/sound file it will wipe out your custom settings (which you don’t want) so don’t run those.

Finally, how many of the ALSA-Configuration.txt file options did you try? Here is a list of the options from that file:

	ALC883/888
	  3stack-dig	3-jack with SPDIF I/O
	  6stack-dig	6-jack digital with SPDIF I/O
	  3stack-6ch    3-jack 6-channel
	  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
	  6stack-dig-demo  6-jack digital for Intel demo board
	  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
	  acer-aspire	Acer Aspire 9810
	  medion	Medion Laptops
	  medion-md2	Medion MD2
	  targa-dig	Targa/MSI
	  targa-2ch-dig	Targs/MSI with 2-channel
	  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
	  lenovo-101e	Lenovo 101E
	  lenovo-nb0763	Lenovo NB0763
	  lenovo-ms7195-dig Lenovo MS7195
	  haier-w66	Haier W66
	  6stack-hp	HP machines with 6stack (Nettle boards)
	  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
	  6stack-dell	Dell machines with 6stack (Inspiron 530)
	  mitac		Mitac 8252D
	  auto		auto-config reading BIOS (default) 

Hello and thanks.

All Bold rows i have tried:


	ALC883/888
**	  3stack-dig	3-jack with SPDIF I/O
	  6stack-dig	6-jack digital with SPDIF I/O
	  3stack-6ch    3-jack 6-channel
	  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O**
	  6stack-dig-demo  6-jack digital for Intel demo board
**	  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
	  acer-aspire	Acer Aspire 9810**
	  medion	Medion Laptops
**	  medion-md2	Medion MD2**
	  targa-dig	Targa/MSI
	  targa-2ch-dig	Targs/MSI with 2-channel
**	  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)**
	  lenovo-101e	Lenovo 101E
	  lenovo-nb0763	Lenovo NB0763
	  lenovo-ms7195-dig Lenovo MS7195
	  haier-w66	Haier W66
	  6stack-hp	HP machines with 6stack (Nettle boards)
	  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
	  6stack-dell	Dell machines with 6stack (Inspiron 530)
	  mitac		Mitac 8252D
	  **auto		auto-config reading BIOS (default)**

I get the subwooofer working under Kubuntu. But wont use Kubuntu. I’m an absolutely N00b (i think so) and try Kubuntu and Suse and Suse seems very well for me.

My Thread:
Acer Aspire 9802 -Lautsprecher kein Sound- [UPDATE] - Thema anzeigen - ubuntuusers

If it’s working with Kubuntu it have to work with Suse.
First problem, i cant compile the alsa driver because the manual from kubuntu doesn’t work by suse. I know but i don’t know how to do :slight_smile:
https://help.ubuntu.com/community/HdaIntelSoundHowto

I can’t find the following file and perhaps there is the problem:


sudo vi /etc/module
Code:
snd-hda-intel model=acer-aspire

Can anybody help me, plz ? :slight_smile:

ps. sorry 4 my bad english :slight_smile:

In opensuse the file one edits is /etc/modprobe.d/sound, and not something called “/etc/module”. Apologies, as I had thought you understood that, based on what I read in your initial post:

I am now thinking your edits were not successful?

To edit a file, such as /etc/modprobe.d/sound, if one is not familiar with the “vi” editor, one can do so from an xterm/konsole under X window by the following:

  • if KDE: kdesu kate and then open the file “/etc/modprobe.d/sound”
  • if Gnome: gnomesu gedit and then open the file “/etc/modprobe.d/sound”
    and when prompted for a password, enter root password.

Hence if you edited the wrong file, I think you need to do this again. Do not forget to restart alsa after each edit is completed, with:
rcalsasound restart

:smiley: Sorry that’s a misunderstanding :slight_smile:

In Kubuntu with an Acer Aspire Laptop you have to edit two files. The second file there is:
sudo vi /etc/module
Code:
snd-hda-intel model=acer-aspire

The first file is a similar file and thats the file i edit in suse


cat /etc/modprobe.d/sound
options snd slots=snd-hda-intel
# u1Nb.g5Eu65_2Iy6:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=auto

But all i do in suse don’t work. That’s the reason i think there is a second file too.

i really do everything in the SDB from the Suse HP, but it doesn’t work.

Any idea?

THX :smiley:

Greetings Markus

I should have asked earlier, can you expand on this. When you say you have the “same problem like the other guys with the laptop”, what problem precisely is that?

I take it you HAVE SOUND, but your Acer Aspire 9802 laptop (which I believe has a little built in subwoofer (2.1) system), and your problem is that all your sound is coming out of that subwoofer, and not the 2 other laptop speakers?

Is that correct?

[If so, then I’ve been on the wrong approach … what we need is likely to implement a custom .asoundrc file tuned to 2.1 sound].

:frowning: sorry again i wish i can better english :slight_smile:

By Kubuntu it was exactly the problem you say.
**But i want to use SuSE and there only comes Sound from the Headset. No Speaker is going to work.
**

Thx for your patience whit me :slight_smile:

And don’t forget i’m a n00by :confused:

markus

OK, so with Kubuntu you obtained only sound from the subwoofer, but not from the other two speakers.

And with openSUSE you only obtain sound from the headphones, and not from the speakers.

I am running out of ideas to test. … but in your mixer, I notice the following from the tsalsa script:

Amixer contents for card 0 [Intel] _____________________________________        
amixer set 'Master',0 74% on        
amixer set 'PCM',0 75% 75%        
amixer set 'Front',0 74%,74% on        
amixer set 'Line',0 100%,100% on        
amixer set 'Mic',0 74% off 74% off        
amixer set 'Mic Boost',0 67% 67%        
amixer set 'IEC958',0 off        
amixer set 'IEC958 Default PCM',0 on        
amixer set 'Capture',0 Capture 17 55% off Capture 17 55% off        
amixer set 'Capture',1 Capture 16 52% off Capture 16 52% off        
amixer set 'Input Source',0 Items: 'Mic' 'Line' Item0: 'Line'        
amixer set 'Input Source',1 Items: 'Mic' 'Line' Item0: 'Line' 

How about setting IEC958 = ON and/or IEC958 Default PCM = ON (just in case your laptop uses digital audio). You can set them off afterward if it doesn’t work. Also try setting your Line (now at 100%) to OFF, and see if that makes a difference. The alsa implementation in some of the hardware audio codecs had controls reversed, so it does not hurt to try different combinations, … just be certain to set things back properly when you have completed testing.

Also, you should try ALL of the model options in the ALSA-Configuration.txt for the ALC883, and not just the one’s you highlighted in bold. You should also double check the one’s you highlighted in bold.**

Hello agian und THX for the first step :smiley:

The subwoofer works only but it works. I hope to get the other speakers play :slight_smile:

If there is another guy who wants sound from his Acer Aspire 9802

I get it work like Kubuntu with the follo settings:

vi /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.g5Eu65_2Iy6:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel
options snd-hda-intel model=acer-aspire

~> allmixer

And set the Headset output OFF !!! Then the subwoofer works :wink:

Have anybody an idea the get the other speakers work?
I try in the allmixer everything but they doesn’t scream :frowning:

greetings and THX to oldcpu

Thanks for that.

Could you, one more time, try “6stack-dig” in place of “acer-aspire” and restart your alsa with rcalsasound restart and test again with your mixer.

Note it doesn’t appear alsa has the implementation 100% correct yet for this laptop, so it is possible your mixer settings are ‘mixed up’. … ie. maybe mastervolume is in the place of front, and surround is in the place of headphones/LFE, and center for subwoofer, or some other strange permutation.

So 1st record your current settings, then try different settings. If nothing works, go back to the “model=acer-aspire” and restore the mixer settings to what you know works.

Thanks.

Hello.

The best results for an Acer Aspire 9802 was with the modul=medion
wenn your soundcard is an:


00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

vi /etc/modprobe.d/sound

options snd slots=snd-hda-intel
options snd-hda-intel model=medion

u1Nb.Tpl9SMkJSdD:82801G (ICH7 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

2.1 was working very fine :smiley:

And now i will be setup the TV-Card …

Greetings markus

Fabulous, … all 3 speakers working …

Maybe you could do me a favour? I put an entry in the openSUSE HCL for your acer 9802.
HCL/Laptops/Acer - openSUSE
To help me fill it in better, I assume you only have tried 2D (and not 3D video), … is that correct? Have you succeedd with wireless? Blue Tooth? any luck with Power Management?

Thanks

Hello.

i will be give you all information i can get.
But in the moment i have great problems to get the tv-card working.

attention translated by google:
the drivers was recognized but the DVB-T receivers.
even after I

modprobe saa7134 dvb-tuner card = 81 = 54 & dmesg
have entered the recipient does not. But i have to read more instructions and hope to get it work, then do i tell it to you.
Or aks you holes in the abdomen -> German speech :slight_smile:

wireless
Wireless works. During the operation can be controlled through the wireless hardware button off, but only after a restart again.
translate by google :smiley:

bluethoot
at the moment not tested … coming soon.

Power Management
It starts when opensuse starts an i can switch the CPU-Power,
what i have to test with the power managment?

ps. how can i test 3D ? Is there any program?

greetings

Sorry, I do not have a TV card … my wife does, but I don’t.

I also do not use a 3D desktop, so I can’t help there either.

I think you should start a new thread for each of the above.

I have an Acer Aspire 9810

After much fiddling on 10.x and 11.0, I was able to get sound working (somewhat) for my ALC 883, but never on all channels.

Now, I have a fresh install of 11.1/Gnome from the LiveCD in a new partition. I set my /etc/modprobe.d/sound settings from the 11.0 installation and have no sound on any channels:

options snd_slots=snd-hda-intel

u1Nb.hAUj7BuZxFD:9814 WKMI

alias snd-card-0=snd-hda-intel
options snd-hda-intel model=acer-aspire enable=1 index=0

Booting into OpenSuse 11.0 or Windows Vista Ultimate gives me working sound, while booting into OpenSuse 11.1 does not.

The gnome mixer shows Left and Right channels only (11.0 Kmixer shows quite a few more) and “appears” to play (it shows dynamic levels bouncing around.)

Unfortunately, I don’t have external speakers to check the SPIDF jack – it may or may not be enabled. In KMixer, there was a headphone option where muting it would toggle the jack or built-in speakers, but I can’t find where to do that in the gnome mixer and I do not have any KDE stuff in this 11.1 installation.

Alsa info and dmesg all looks good.

Any ideas would be appreciated.

memswiler, can you start a new thread? I do not know if an Acer Aspire 9810 has the same hardware as a 9802. It could be different, and having different hardware in the same thread is just going to confuse me.

Thanks.