No space left on device

I’m having this problem after installing in the wrong partition, see attached picture (Link: ), I’m using all space for /dev/sda2 but I have a lot of free space on /dev/sda3. Snapper and btfrs are not working. I’m getting error to configure them.

Well, what can I do to free the space on /dev/sda2. The GUI is not lunching anymore since the last installation.

Thank you all for the help;

For anyone who has any questions about BTRFS on any topic,
I’ve collected what I consider the best links on my Wiki

Specifically regarding running out of space, first efforts to resolve should be to run the “btrfs balance” command as described in these two references


Thank you for the Wiki files, I found them very helpful and I tried to resolve the problem reading them but As I mentionned my btrfs and snapper are not working, here for example when I tried to run btrfs balance I’m getting: ‘ERROR: cannot access ’ /mnt/btrfs’: No such file or directory. I don’t have a btrfs file;

So what should I do in this case?

Thanks for the help;

You didn’t provide nearly enough information about what you were doing when you failed the mount.

The SDB provides a step by step procedure trying different things

So, for instance before you try anything more difficult you should attempt to remove any snapshots you don’t need… ie. anything that isn’t the first or recent. If successful, you may be able to free up enough space to boot and consider other files or other snapshots for removal.

If you start at the above location and then try one thing after another, report back any success until you run into a failure.


What prevents you from installing in the correct partition?

I ran into this problem last week and gparted made all the necessary corrections to reallocate partition space. I ran out of root (/) partition space just as a result of normal system installs. It is a btrfs partition. I had TBs of space in my /home partition which was formatted ext4. Booting into gparted dvd with nothing else mounted, I successfully increased the root btrfs space and decreased the /home ext4 space to give me plenty of root partition space. First I decreased the ext4 partition size making an Unallocated region. Second I increased the root btrfs space to include the unallocated space. Gparted automatically moved all the files in ext4 partition to accomodate the size reduction. Gparted increased the btrfs size and reformatted the unallocated space from ext4 to btrfs.

All is now fine and I lost no home partition data or root directory files. All works.

If you can’t boot due to not enough space for root, you need to get a gparted iso disk off another computer or a friend. Then boot into that dvd or usb with gparted on it.

Worked fine for me. Good luck to you.

Tom Kosvic

I just had the problem, that Baloo file indexer filled my logs until I ran out of space.
Check the size of /var/Log
And the content, in case you have severl GB of logs.
In my case, deleting the baloo settings in /home/user/… baloo solves the logging problem.

50G for / ?
I only use 15G and it is enough.
Have you checked /var/log ?
I just had an issue with baloo file indexer crashing its data base and creating 13G of logs.
After checking /var/log and the entries I deleted 13G of log files and the baloo index file in my /home and everything was fine again