No soung in OpeSuse 11.2 in Firefox 3.5 via hdmi

Hello. There is such a problem.
Although there is sound via hdmi (music, video, kde), there is no sound in firefox via hdmi. But what’s more there is sound in headphones and analog output but I just can’t make my sony tv to grab sound from analog output.

So I want to ask you if you know how to make firefox to play sound through hdmi?

Thank you for your help)

Can anybody just give a tip what can be wrong?

  • sound (music, video) in players and os works fine
  • no sound in firefox via hdmi but there is sound via analog or headphones (also analog) (so generally 2 analog outputs work but only for firefox, not for os sound
  • in yast->sound sound test showed me that only analog can play test sound, no test sound (when trying to test in yast->sound) via hdmi

It is very strange. There is a solution) Just to mount normal speakers, but as for me I think the problem is junt in few lines of checkboxes… Have no clue what to try next:sarcastic:

I don’t really know much about sound through HDMI, but if you’re using and ATI graphics card maybe it has to do with this:
[Phoronix] Radeon HDMI Audio Set For Linux 2.6.33 Kernel](
In that case, it will probably work with the 2.6.33 Kernel.

Other that that, I can’t really help… Maybe someone else has better idea what it could be.

Thank you very much for your reply) I am using Intel video, but realtech sound and somehow sound in my machine can be sent via hdmi) It is Shuttle (small) computer).

I found out that in smplayer I have sound output as “alsa (0.3-HDA Intel” and only with it (not simply alsa) sound works via hdmi.

In VLC there is no such an option and there is sound only using analog output. This is really strange.
I deleted pulseaudio, installed vlc, made it as a plug-in in firefox.

So maybe I should write somewhere that !hdmi (or something (hdmi)) is my default audio output.

Why sound works in KDE not yast… simply because there is priority settings in KDE but just only audio card in yast. So that is the problem I think. Programs like flash and VLC (don’t know why since smplayer works fine via hdmi) “look” into some yast’s configs and see that “analog” is default…

Maybe there is a solution)

I’ve been staying out of this thread, because I have not successfully configured HDMI for audio on a PC and I am not certain if I can help.

But I think there may be a couple of things you did not try.

When I think about it, this is expected. Smplayer is very good in that in its preferences it has controls where one can select the hardware audio device in which the sound is played. Not all players offer this capability.

I am not convinced it was necessary to delete pulse.

The place is likely YaST and possibly also in KDE’s configure desktop.

Is not the HDMI showing up in YaST ?

When you go to YaST > Hardware > Sound, what do you see ?

Can you provide the output recommended in our multimedia stickie (2nd half of that stickie): Welcome to multimedia sub-area - openSUSE Forums

Thank you very much for your help)

In yast I only have my intel audio card, there is no mention about hdmi at all.

rpm -qa ‘alsa

rpm -qa ‘pulse

(I also can install full pulse and try again)

rpm -q libasound2

uname -a
Linux linux-pb4a #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/sound
cat: /etc/modprobe.d/sound: Нет такого файла или каталога (means no such file)

cat /etc/modprobe.d/50-sound.conf

options snd-hda-intel model=auto
options snd slots=snd-hda-intel

u1Nb.QKTE0zh8SMA:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

There is all I have as output of your commands) Hope you can help me)

Once again, I have configured KDE to use only HDMI in KDE’s configure desktop (as primary). And all sounds of KDE can be played through hdmi. But not VLC, Flash Player, Firefox.

I tried to set smplayer plugin in firefox as default for playing mp3 etc. but no use) (maybe I should just install pulseaudio maybe not I don’t know)

Thanks. Please also run the diagnostic script that stickie asks for. You can do that by typing, with your pc connected to the internet:


and select SHARE/UPLOAD when prompted. When it is finished it will give you a URL. Please post that URL here. Just the URL.

I was able to output sound through my TV via HDMI with 11.2 and FF3.5 by right clicking on KMix > Show Mixer Window > Settings > Configure Channels > Tick IEC958 > Close > Untick Mute box on IEC958