No sounds after security update

I don’t have sound on my linux box after a security update. I have a battle right now, and I think is time for ask for help
I ran the alsa script and is available here:

To oldcpu, sorry for my last post, here is the new one.


Its possible (in fact likely) you may need to do an update to alsa to match your current kernel version. but first, I note this in your mixer:
Simple mixer control ‘Speaker’,0
Front Left: Playback 64 [100%] [0.00dB] [off]
Front Right: Playback 64 [100%] [0.00dB] [off]
Simple mixer control ‘Speaker’,1
Front Left: Playback 64 [100%] [0.00dB] [off]
Front Right: Playback 64 [100%] [0.00dB] [off]
Simple mixer control ‘Speaker’,3
Front Left: Playback 64 [100%] [0.00dB]** [off]**
Front Right: Playback 64 [100%] [0.00dB]** [off]**
Those 3 speaker controls are muted. On my PC if I mute speaker 0 I will get no sound. So you could try unmuting those.

If that does not work, we can look at updating your alsa.

What is the output of:
rpm -qa | grep alsa

I just upgrade alsa, no errors and I check the kmix and those speakers. unfortunately still no sound.
But I get a very loud beep from the speakers when an email arrives.

Here is the rpm -qa | grep alsa



OK, I can see you did the user-space alsa updates, but not the more cutting edge (essentially daily (or momentary) snapshot packages from the upstream GIT trees). Alsa-update-snapshot - openSUSE

Did you reboot your PC after those updates? Its essential !

Still, before trying the daily snapshot updates, you could try to force your PC’s model configuration upon boot.

I note the options that can be forced are listed here (an extract from the HD-Audio-Models.txt file for 1.0.20 of alsa) with a short description:

  ref		Reference board
  ref-no-jd	Reference board without HP/Mic jack detection
  3stack	D965 3stack
  5stack	D965 5stack + SPDIF
  dell-3stack	Dell Dimension E520
  dell-bios	Fixes with Dell BIOS setup
  auto		BIOS setup (default)

Please provide the output of

cat /etc/modprobe.d/sound

and I’ll walk you thru how to test each of those model options, one at a time, to see if one restores your sound.

I rebooted the PC still no sound, :’(

here is the cat /etc/modprobe.d/sound

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel


OK, so lets try to force an audio configuration. If you recall this post:

So what we will do is edit the /etc/modprobe.d/sound file, trying each of those options one by one, restarting alsa, and restarting your mixer after each attempt, and testing the sound.

Lets try “3stack” first. So with root permissions open the file /etc/modprobe.d/sound with an editor. … you can do that in

  • kde with: kdesu 'kwrite /etc/modprobe.d/sound’

  • gnome with: gnomesu gedit /etc/modprobe.d/sound
    and enter root password when prompted for a password, and then add a line to the start of that file so that the file looks like:

options snd-hda-intel model=3stack
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

Save the change. Now restart alsa with su -c ‘rcalsasound restart’ and restart your mixer (kmix in kde, alsamixer in gnome) and test your sound. Check your mixer thoroughly.
Do not use the “boot sound” as your sound test.

Note when testing your sound, test with both regular and root permissions, and also test with and without headset.

If that does not work, then in the /etc/modprobe.d/sound file, replace “3stack” with the next item in the list (5stack) and try again. ie save file, restart alsa, restart mixer, test sound.

If that does not work, keep trying each item in the list.

If that does not work, then try installing the daily snapshots (note you must send 6 zypper commands): Alsa-update-snapshot - openSUSE

HEY, is working now. Wow what a work you did oldcpu
Thanks a lot, it works on my user and root.
Tested a wide of different formats all of them works.
Now the flash videos online not sound., like youtube, CNN and such.

Any suggestions for flash videos online?

Thanks in advance…

What worked? “3stack” ?

For flash videos I use flash-player and mplayerplug-in (although mplayerplug-in is now depreciated and being replaced by gecko-mediaplayer).

What is the output of:
rpm -qa | grep flash

I get:

oldcpu@hal1000:~> rpm -qa | grep flash

Although in some cases it is necessary to remove libflashsupport as it can interfere with flash on some PCs.

Yes I use 3stack.
One thing I noticed after this was the Kmix showed for first time the headphones volume control (awesome), and the maximum volume is up to 64, before was 100. But with my speakers volume I can adjust that.

For flash:
rpm -qa | grep flash:


I’m a KDE-3.5.10 user, and I don’t use flash-plugin-pulseaudio nor flash-plugin. I checked my KDE-4.3 sandbox PC, and it does not either.

Still, if I were you I would start by removing libflashsupport, and then try different web sites and see if they work.

Note, as I stated above, I use mplayerplug-in together with flash-player.

WORKS now, I just removed libflashsupport-000-67.1 first and nothing happended, then I removed flash-plugin-pulseaudio-r2138-2.135 and the sound came fine on flash videos.

Tested those websites, and there is sound now.

Man, thanks a lot for help me to fix this.

I’ll give a try to mplayerplug-in.

Thanks again.