no soundcards found...

Hello everyone,
After a package update, I am not able anymore to play sounds on my laptop.

I’ve run this command

aplay -l

and I’ve obtained this output:

aplay: device_list:270: no soundcards found...

if I digit this:

sudo lspci -nn |grep -i audio

output is blank.

If I use pavucontrol, I don’t have any Hardward Output Devices.

My current sound configuration in /etc/modprobe.d/50-sound.conf is:

options snd slots=snd-hda-intel enable=1 index=0 model=auto
# u1Nb.XEcs4J_tcO2:7 Series/C210 Series Chipset Family High Definition Audio Controller
alias snd-card-0 snd-hda-intel

Note that I’ve manually added this parameters, but nothing it’s changed.

enable=1 index=0 model=auto

I’ve also reinstalled kernel packages, alsa and pulseaudio packages from yast.

I don’t know what the problem is. I don’t know what i’m supposed to do.

Please, can anybody help me?

Welcome to openSUSE forums.

I would like to try help. To do so I need more information on your sound configuration than what you provided.

Please open an xterm/konsole and as a regular user, with PC connected to the internet, send this command to run a diagnostic script :


and select the SHARE/UPLOAD option when prompted. Let the script run to completion. When it completes in the xterm/konsole there will be a URL/web-address that indicates where the diagnostic information was uploaded. Please post that url/web-address here.

Hopefully with that information I may have a suggestion as to a way forward.

Thank you for the reply.
I did what you’ve said to me.
Here it is:

This is a puzzle.

Could you delete the 50-sound.conf file.

Then reboot. Do NOT yet go to YaST to configure the sound, but rather run the diagnostic script again and post the output here. I want to see the script output without that 50-sound.conf file in place that clearly has failed to configure your PC audio device. Post that web address/URL here please.

Then after running the script, while I am pondering the script, you could go to YaST hardware > sound and again try to configure your audio device.

I do note from the above script, your PC is a HP EliteBook 850 G4. Surfing I read that the G4 has a Conexant Hd Audio 11.39.2168.57. I can not find further detail on the audio Hardware codec. Nor can I find yet if GNU/Linux supports the Conexant Hd Audio 11.39.2168.57. However I do know that sometimes devices are referred to by names differently in MS-Windows than in GNU/Linux, so that ‘may’ be why I can’t find GNU/Linux information on that device. I note your post suggested a Series/C210 Series Chipset Family High Definition Audio Controller, but I don’t know if that is accurate as I can’t find any information surfing to confirm that.

You could check the HP BIOS to ensure sound is enabled in the BIOS (if there is such a control).

I checked inside the openSUSE 42.3 alsa-firmware.rpm file, and I don’t see any information on a C210, so installing alsa-firmware may not help - although you could try such as a speculative effort.

I’ve read also of users trying different special model option values. For example:

  • when ‘nofixup’ is passed, the device-specific fixups in the codec parser are skipped.
  • when generic is passed, the codec-specific parser is skipped and only the generic parser is used.

I don’t know enough about sound to understand the significance of skipping the codec-specific parser or the generic parser. I have read of Ubuntu users with C210 audio codec claiming ‘model=generic’ worked for them. But I also read of different Ubuntu users who learned applying the audio codec ‘model=generic’ did not work and blocked their audio. So I have no specific suggestions there.

Lets see if the script gives anything with the 50-sound.conf file removed.


My surfing on the HP EliteBook 850 G4 and GNU/Linux did suggest sound works for this computer under Ubuntu 16.04.2 which comes with a version 4.8 kernel. OpenSUSE Leap 42.3 only has a version 4.4.90-28 (?) kernel.

Ergo possibly (?) it may not be supported by an older 4.4 kernel.

Its also possible support for the HP EliteBook 850 G4 audio requires a newer kernel, in which case you may need to update to one of the newer custom kernels from a special openSUSE repository with newer kernels. I know the daily openSUSE ‘stable’ kernel is currently 4.13.9 but when it says stable, and I don’t know how ‘stable’ it actually may be. It may not be stable. Further I don’t normally do such kernel updates (to more cutting edge kernels) myself so rather than me blindly recommend a repository for such, lets see if another openSUSE user chimes in here who has experience there.

It should be fine, although additional steps may be needed for those using proprietary driver support. You can have multiple kernel installed with openSUSE as explained here…

Add the Kernel:stabe repo with

zypper ar -f Kernel

Then do

zypper se -s kernel

Find the kernel-default version listed in the stable kernel repo eg version 4.13.9-2.1.ge7d7106…

then do

zypper in kernel-default-4.13.9-2.1.ge7d7106

When you next reboot, grub will offer a selection of installed kernels to boot from.

I deleted the file 50-sound.conf (I did a backup) and I re-execute the script as you’ve said to me.
Here it is the new diagnostic report:

Yast hardware > sound prompted to me that no cards were found and proposed to me a driver list to probe, after that I confirm the operation, the card list is empty.

Before the package update it worked fine, I had a kernel update, but if I try to boot with the previous one I will have the same problem.

I’m going to read the others replies as soon as possible and I will reply you.

Ok thanks. That pretty much confirms the 50-sound.conf was NOT at fault.

I suspect a kernel update (which updates the alsa sound driver) may be you best approach.

I believe you are in bug reporting territory, although if a kernel update fixes the problem then likely the openSUSE packager for sound already knows of the problem. If a kernel update does not fix the sound, then IMHO a bug report is needed in order to get a reasonably quick fix. If need be, we can provide guidance on how to raise the bug report when the time comes.

Thank you for your reply. As suggested from you and from oldcpu, I’ll try to update my kernel in the next few days because I am in the middle of something and I can’t afford any trouble right now.

I will update you in the coming days.