No sound :(

Here’s the output:

calvin@linux-kmee:~> aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Creative [HDA Creative], device 0: CA0132 Analog [CA0132 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Creative [HDA Creative], device 1: CA0132 Digital [CA0132 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

“amixer -c2” didn’t work so I tried -c1 and -c0:

calvin@linux-kmee:~> amixer -c2
Invalid card number.
Usage: amixer <options> [command]

Available options:
  -h,--help       this help
  -c,--card N     select the card
  -D,--device N   select the device, default 'default'
  -d,--debug      debug mode
  -n,--nocheck    do not perform range checking
  -v,--version    print version of this program
  -q,--quiet      be quiet
  -i,--inactive   show also inactive controls
  -a,--abstract L select abstraction level (none or basic)
  -s,--stdin      Read and execute commands from stdin sequentially
  -R,--raw-volume Use the raw value (default)
  -M,--mapped-volume Use the mapped volume

Available commands:
  scontrols       show all mixer simple controls
  scontents       show contents of all mixer simple controls (default command)
  sset sID P      set contents for one mixer simple control
  sget sID        get contents for one mixer simple control
  controls        show all controls for given card
  contents        show contents of all controls for given card
  cset cID P      set control contents for one control
  cget cID        get control contents for one control
calvin@linux-kmee:~> amixer -c1
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 99
  Mono:
  Front Left: Playback 99 [100%] [9.00dB] [on]
  Front Right: Playback 99 [100%] [9.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Surround',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Mic SVM',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [on]
Simple mixer control 'Mic1-Boost (30dB)',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined cswitch cswitch-joined
  Playback channels: Mono
  Capture channels: Mono
  Mono: Playback [off] Capture [on]
Simple mixer control 'IEC958 Default PCM',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 23
  Front Left: Capture 0 [0%] [0.00dB] [on]
  Front Right: Capture 0 [0%] [0.00dB] [on]
Simple mixer control 'AMic1/DMic',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'AMic1/DMic Auto Detect',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'Analog-Mic2',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 23
  Front Left: Capture 0 [0%] [0.00dB] [on]
  Front Right: Capture 0 [0%] [0.00dB] [on]
Simple mixer control 'CrystalVoice',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'Crystalizer',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Dialog Plus',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Echo Cancellation',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'Equalizer',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'HP/Speaker',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'HP/Speaker Auto Detect',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Noise Reduction',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [on]
Simple mixer control 'PlayEnhancement',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Smart Volume',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Voice Focus',0
  Capabilities: cswitch cswitch-joined
  Capture channels: Mono
  Mono: Capture [on]
Simple mixer control 'VoiceFX',0
  Capabilities: cenum
  Items: 'Neutral' 'Female2Male' 'Male2Female' 'ScrappyKid' 'Elderly' 'Orc' 'Elf' 'Dwarf' 'AlienBrute' 'Robot' 'Marine' 'Emo' 'DeepVoice' 'Munchkin'
  Item0: 'Neutral'
Simple mixer control 'What U Hear',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 99
  Front Left: Capture 90 [91%] [0.00dB] [on]
  Front Right: Capture 90 [91%] [0.00dB] [on]
Simple mixer control 'X-Bass',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
calvin@linux-kmee:~> amixer -c0
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',1
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',2
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',3
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]

I tried the same variations as above because it wasn’t working, all commands gave the same output:


calvin@linux-kmee:~> speaker-test -c2 -D hw:2,1  -l1 -twav

speaker-test 1.0.27.2

Playback device is hw:2,1
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib pcm_hw.c:1667:(_snd_pcm_hw_open) Invalid value for card
Playback open error: -2,No such file or directory
calvin@linux-kmee:~> speaker-test -c2 -D hw:2,0  -l1 -twav

speaker-test 1.0.27.2

Playback device is hw:2,0
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib pcm_hw.c:1667:(_snd_pcm_hw_open) Invalid value for card
Playback open error: -2,No such file or directory
calvin@linux-kmee:~> speaker-test -c1 -D hw:2,0  -l1 -twav

speaker-test 1.0.27.2

Playback device is hw:2,0
Stream parameters are 48000Hz, S16_LE, 1 channels
WAV file(s)
ALSA lib pcm_hw.c:1667:(_snd_pcm_hw_open) Invalid value for card
Playback open error: -2,No such file or directory
calvin@linux-kmee:~> speaker-test -c1 -D hw:2,1  -l1 -twav

speaker-test 1.0.27.2

Playback device is hw:2,1
Stream parameters are 48000Hz, S16_LE, 1 channels
WAV file(s)
ALSA lib pcm_hw.c:1667:(_snd_pcm_hw_open) Invalid value for card
Playback open error: -2,No such file or directory
calvin@linux-kmee:~> speaker-test -c0 -D hw:2,0  -l1 -twav

speaker-test 1.0.27.2

Playback device is hw:2,0
Stream parameters are 48000Hz, S16_LE, 1 channels
WAV file(s)
ALSA lib pcm_hw.c:1667:(_snd_pcm_hw_open) Invalid value for card
Playback open error: -2,No such file or directory
calvin@linux-kmee:~> speaker-test -c0 -D hw:2,1  -l1 -twav

speaker-test 1.0.27.2

Playback device is hw:2,1
Stream parameters are 48000Hz, S16_LE, 1 channels
WAV file(s)
ALSA lib pcm_hw.c:1667:(_snd_pcm_hw_open) Invalid value for card
Playback open error: -2,No such file or directory

Your ‘aplay -l’ output gave

card 1: Creative [HDA Creative], device 0: CA0132 Analog [CA0132 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Creative [HDA Creative], device 1: CA0132 Digital [CA0132 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

so the ‘speaker-test’ needs to match the card and sub-device reported ie

speaker-test -c2 -D hw:1,0  -l1 -twav

Here’s the output (I heard no sound):

calvin@linux-kmee:~> speaker-test -c2 -D hw:1,0  -l1 -twav

speaker-test 1.0.27.2

Playback device is hw:1,0
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 262144
Period size range from 32 to 131072
Using max buffer size 262144
Periods = 4
Unable to set hw params for playback: Invalid argument
Setting of hwparams failed: Invalid argument

*I do not understand the ‘why’ of this:
*

and it makes me wonder if your hardware changed once again. Please, when you run the ‘speaker-test’, also run the ‘aplay -l’ so that we can confirm that your device order has not shifted once again.

In any event, its looking like you need to write a bug report on this in order to obtain support from the SuSE-GmbH sound expert (sound packager) who is also an alsa sound driver developer. There is guidance here for bug reports: http://en.opensuse.org/openSUSE:Submitting_bug_reports

You can use your openSUSE forum username and password when logging on to bugzilla.

Be sure your user is in the audio group.

Does the sound work for root?

calvin@linux-kmee:~> aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Creative [HDA Creative], device 0: CA0132 Analog [CA0132 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Creative [HDA Creative], device 1: CA0132 Digital [CA0132 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

calvin@linux-kmee:~> speaker-test -c2 -D hw:1,0  -l1 -twav

speaker-test 1.0.27.2

Playback device is hw:1,0
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 262144
Period size range from 32 to 131072
Using max buffer size 262144
Periods = 4
Unable to set hw params for playback: Invalid argument
Setting of hwparams failed: Invalid argument

Does that look right?

And no, root has no audio either.

I see not fault with it. In addition to trying hw:1,0, did you also try hw:1,1 ?

In any event, I recommend you raise a big report to obtain the attention of the sound packaging ‘experts’ from SuSE-GmbH in Nuremburg, where at least one of them (maybe more) are also alsa sound driver developers.

hw:1,1 gives the exact same output.

I’ll report the bug.

Please specify your machine (which vendor, product, etc), what desktop system
you’re testing, and what did you try. Pointing a forum URL helps only as a
reference. Instead, provide the raw data here, describe the above concisely in
Bugzilla.

And, most importantly, please give alsa-info.sh output. Run it with
–no-upload option, and attach the output to Bugzilla (don’t paste).

Thanks.

This is what reply I got from posting the bug report. I don’t know what to reply with, I don’t know what he means
by “what did I try”. I tried to play sound.

And that last paragraph, this is what it means to me. In the terminal type “alsa-info.sh --no-upload”.
I will then get output I’m not supposed to copy and paste, so how do I attach it to bugzilla?

Open a terminal/konsole , and send the command


/usr/sbin/alsa-info.sh --no-upload

then go to the directory /tmp and look for a file named “alsa-info.txt.xxxxxxx” (where ‘xxxxxxx’ ) is some number. When you submit the bug report, attach that file to the bug report :slight_smile: (There is a control at the bottom of the bug report indicating how to attach a file).

Reference the bug report state you have no sound on with a Sound Blaster Z in an MS-7845 MSI pc with 64-bit openSUSE-13.1 . Note you identified the Sound Blaster Z as the device hw:1,0 and hw:1,1 and the following commands yielded no sound.
speaker-test -c2 -D hw:1,0 -l1 -twav
speaker-test -c2 -D hw:1,1 -l1 -twav

Advise also that you checked the speaker cables (which I hope you did) and that this is not a fault with the cables being connected incorrectly.

There is no point in referenceing this forum thread, as the SuSE-GmbH sound packagers need all the information in the bug report, and they will not accept a reference to a support forum thread.

Good luck, and thankyou for your support to openSUSE on resolving this problem.

My sound works fine in Windows (I dual boot), so the cables are guaranteed to be connected correctly.

Be certain to mention that in the bug report.

OMG!

I can’t believe this, I can’t find the bug report :confused: Bugzilla needs some sort of “My Reports” button , **** it, it’s not in my history either (which is weird).

Any idea how I can find the bug report on bugzilla?

Edit: Hahaha, My Reports :slight_smile: Way down at the bottom of the page.

I see the bug report here:
https://bugzilla.novell.com/show_bug.cgi?id=863494

It does not look to optimistic for your Sound Blaster Z (poor to no GNU/Linux functionality).

The person helping you in that bug report is no less than Takashi Iwai, who is an alsa sound driver developer, so few (any ? ) know this subject better than he. Note that recommends you try turning off “HP/Speaker Auto Detect” to see if that makes something working. He also suggests you try to fiddle with mixer switches. You can see them if you send the command:


alsamixer -c1

and that will launch the program alsa mixer and you should be able to toggle the settings and then test your sound then after toggling the settings.

Using the ‘alsamixer’ application to attempt to tune the mixer settings is likely easiest. Its also possible to do this with amixer program , but one needs exact syntax to make amixer work, and I am not very good at that.

For example, to turn on ‘Crystal Voice’, a way to do it may be:


amixer -c 1 -- set 'CrystalVoice' on

or to turn the speaker ON may be:


amixer -c 1 -- set 'HP/Speaker' on

Your alsa-info.txt file suggests HP/Speaker Auto Detect is already OFF, but if you wished to switch it ON (contrary to the recommendation given to you) then you could try:


amixer -c 1 -- set 'HP/Speaker Auto Detect' on

Again, I could have the syntax wrong, and hence the ‘alsamixer -c1’ command recommendation is likely better.

Done that but I’m failing to figure out what button toggles on and off :confused:

I’ll post the output just in case there’s something important there. It seems like the commands did work (but there’s still no sound, I’ll reboot to see if that’s needed after writing this post).

calvin@linux-kmee:~> amixer -c 1 -- set 'HP/Speaker' on
Simple mixer control 'HP/Speaker',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
calvin@linux-kmee:~> amixer -c 1 -- set 'HP/Speaker Auto Detect' on
Simple mixer control 'HP/Speaker Auto Detect',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]

In this case, I don’t think a reboot is necessary. You can try different combinations of them, …ie one ON while the other OFF. I think < not sure> the syntax for the OFF may be:


 	amixer -c 1 -- set 'HP/Speaker' off

and


 	amixer -c 1 -- set 'HP/Speaker Auto Detect' off

but I could wrong wrt the syntax.

Now it says amixer doesn’t like the arguments. So does this mean that no distro is gonna like my Soundblaster Z?

How do I use my onboard sound? In YasT there are two other sound devices, I don’t know what one of them is but the other is my onboard sound, they say “not configured” on the left, where the number (Index) would be.

configure them and move them to the top

If could be it is upper case “OFF” instead of lower case “off”.

Also, one can toggle those settings with alsamixer and not have to use amixer.

As was pointed out on the openSUSE bugzilla by the SuSE-GmbH packager, who is also an alsa sound driver developer, that device has poor support in GNU/Linux.

Is your motherboard sound enabled in BIOS ? Having typed that, your motherboard sound device has an ALC1150 hardware audio codec and I note a number of users have had problem with that, for example this thread: https://forums.opensuse.org/showthread.php/494624-Realtek-ALC1150-alsa-driver-problem?highlight=ALC1150

If you wanted to get that ALC1150 working, your approach may be to enable it in BIOS, try to configure it in YaST, and then if it does not work write a separate bug report on it to obtain the assessment/support of the SuSE-GmBH sound packager. If anyone can help there, he is your best chance.

Thankyou and good luck.