No Sound

I’m currently running OpenSuse 13.1 KDE. I had went to OpenSuse.Org located a Codecs file, downloaded & installed it, and for a few days it was fine. Now, all of a sudden, I have no sound either in Banshee (trying to play a CD) or online with either Firefox or Chromium playing You Tube videos. Any idea as to what I can do to resolve this issue?
Any help, much appreciated.


Does any other application than those you mention give you sound ? If not, check kmix for settings.

If other apps give sound, have you checked pulse audio volume control (pavucontrol) application to see it is configured appropriately for the applications you mention ? There is some guidance here on pavucontrol (you may need to install it if not already installed):

Have no sound in browsers or banshee/amarok and Kmixer won’t even open for me.

oK, so I understand no sound in any application.

Please note that in a forum such as openSUSE forums, there are typically ‘stickie’s’ at the top of each forum subsection, providing suggestions to users. 5-years ago I wrote this stickie: … its still in place and I think it is mostly still valid.

Please, can you do a simple test for your sound ?

A simple test to see if your sound works, is to open a konsole or xterm, and type or copy-paste:

speaker-test -Dplug:front -c2 -l5 -twav

Note that Linux is case sensitive, and “D” is not the same as “d”. While the konsole/xterm has mouse focus, hit CTRL-C to stop the test. Note that you should check your mixer settings (alsamixer in the terminal, though graphical programs like kmix may also be used) to ensure that PCM and Master Volume are not muted. If need be, raise the sound levels and retry until you hear sound. Note that the test for surround sound is different.

If that test yields errors, try instead this more simple test:

speaker-test -c2 -l5 -twav

If there is no sound from either test when using a konsole (or xterm) as a regular user, try as user root, i.e. type su and then try the test line. If you get sound with root permissions, but you got no sound as a regular user, then you probably have a permissions problem. In that case, let us know as there is a fix we can pass for that.

If no sound from any of the above, then please, per the stickie,


and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
Note if for some reason that gives you no website/url/address then run it with the no-upload option:

/usr/sbin/ --no-upload

and post the file /etc/alsa-info.txt it creates to Pastebin.comand press SUBMIT on that site and again post here the URL/website-address it provides.

… some clarification on running the script “” … when you run:


you should get something like this (if it asks for an update, select NO):](

followed by this (select the SHARE/UPLOAD option):](

followed by this (its quickest if you simply select ‘NO’ to seeing the output - you will see it on the web page) :](

followed by this (where in RED is the URL).](

Just post the URL you get (similar to the RED URL in my example, but yours will be different).

Again, if you can not get that, then run this with the no upload option:

/usr/sbin/ --no-upload
which will create the file /tmp/alsa-info.txt. Copy that file and paste it on []( and press submit. That will give you a URL address. Please post that URL here.