no sound

Running openSUSE 12.1 on a lenovo 3000 V200. I just upgraded to KDE 4.8.2.

I just noticed that I am getting no sound output, and the most recent thing I did was upgrade KDE. However, I also run LXDE, and I have no sound output using that either.

The audio group is included in my user settings, so that is not the problem. My sound is not muted. However, there is no application (like Amaraok, Audacity) or system sounds that will come through the speakers or the headphones.

What else should I check to figure out the problem?


Nevermind I got it working by going through the helper checklist on the sticky threads. Amarok still doesn’t work, but the rest of the sound is. Not really sure what I did besides tweaking the master volume, but it seems to have worked.

Glad to read you have sound working now. I like to install the additional application pulse audio volume control (pavucontrol) and use that to control my volume, although it is strictly not necessary. I blogged about some basic pavucontrol useage here: Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

Thanks! Yes I installed the pavucontrol and it seems to make controlling sound in general. I still have much to play around with in that regard.

One thing I noticed now that I have upgraded to KDE 8.2 on 2 computers is that neither of them will play music files with Amarok. If this is a problem with Amarok or KDE, perhaps I should post on one of their forums, but I will start here. My Amaraok app uses Xine as the phonon backend (not sure what phonon is, but that is what it says), and in the configuration graphic, I have it set up with internal audio as the sound card. However, it defaults to my A4tech webcam as the sound card, whenever I close the configuration screen even if I set it to the internal audio as the sound card. On the audio playback device preference in Amarok configuration, which only has the internal card listed and not the webcam, if I hit the “test sound” button, the test sound plays through the speakers just fine. However, no music will play out of the play lists on the Amarok main screen.

This has happened on both computers that I upgraded to KDE 8.2. Other sound applications so far seem to work ok, though I haven’t tested them all. Kaffeine and Banshee both play files ok.

I do not update my KDE to versions different than what come with a packaged openSUSE release - I found too many irritating problems as a result. Hence I don’t even attempt support in such cases. Someone other than myself will need help here. Starting a new thread with an appropriate subject/title is likely a good idea.

Ok, no prob. I will start a new thread.