No sound

I have a newly set up computer with 11.4 64 bit. Intel Core i5, under Sound Configuration in YaST I have

‘5 Series/3400 Series Chipset High Definition Audio’


‘nVidia Corporation’

I have built in speakers in my screen, connected via HDMI. I hear no sound from any source, neither via HDMI, nor via a separate sound cable connected to the sound connector on the back of the computer nor via the head phone jack on the front.

I have tried setting each of the two cards as the ‘primary card’ but that doesn’t change anything.

Any help would be much appreciated.

Are you sure the volume mixer is ON

SDB:Audio troubleshooting - openSUSE

Well - the slider at the volume icon shows full volume for ‘High Definition Audio Controller Digital Stereo (HDMI)’, and when I click ‘Mixer’, the slider for ‘Internal Audio Analog Stereo’ is also at full volume. So, I would say yes …

First try in console /etc/init.d/alsasound restart . I it helps, get a rid from PULSE. PULSE makes all problems with sound.

I have found installing ‘pavucontrol’ and then running ‘pavucontrol’ has allowed me to unmute devices, and select specific devices, and thus get audio working (assuming alsa is properly configured). If alsa might not be configured then more detail is needed.

To help assess the alsa driver configuration I need more information, such as that recommended to be provided by the multimedia stickie, which I quote: Welcome to multimedia sub-area
… and to make this easier for you I will quote the relevant section:

please post … providing in your post the following information:


and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
Note if for some reason that gives you no website/url/address then run it with the no-upload option:

/usr/sbin/ --no-upload

and post the file /etc/alsa-info.txt it creates to and press SUBMIT on that site and again post here the URL/website-address it provides.

… some clarification on running the script “” … when you run:


you should get something like this (if it asks for an update, select NO):](

followed by this (select the SHARE/UPLOAD option):](

followed by this (its quickest if you simply select ‘NO’ to seeing the output - you will see it on the web page) :](

followed by this (where in RED is the URL).](

Just post the URL you get (similar to the RED URL in my example, but yours will be different).

Again, if you can not get that, then run this with the no upload option:

/usr/sbin/ --no-upload

which will create the file /tmp/alsa-info.txt. Copy that file and paste it on and press submit. That will give you a URL address. Please post that URL here.

Also provide the following:

  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here