No Sound

my sound device
Realtek ALC883-Intel 82801 HBM ICH8M HDA on laptop

Problem starts at setup of the system suse 11.3. It finds device but cannot continue. So I skip configuration. After login to system. I try to configure device with yast. Yast also see device but I can’t modify anything because yast don’t response.

(My English not good)

I tried with alsaconf but it cannot find the device. Please help!

openSUSE-11.3 has not been released. Hence this thread was moved to Pre-Release/Beta.

This thread has now been moved to Pre-Release/Beta. Both WEB based (browser based) and NNTP based users are invited to respond and try to help user freeman58030 (post quoted).

Thankyou for your understanding.

The ALC883 is supported so my first thought is that your installation CD/DVD has a problem. Please, did you do an md5sum of the downloaded .iso file, and compare that to the md5sum listed on the openSUSE web site? Also, did you burn the .iso file to a +R or -R CD/DVD (and NOT to an RW CD/DVD) and burn at the slowest speed your burner allows? That is important.

Are you certain your sound is switched ON in your laptop’s BIOS ?

Please, can you also provide the following information:

  • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
    SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. Run the script /usr/sbin/ and after the script finishes it will give you a website/URL address to pass to the support personnel. Please post here the output URL address. Just the URL address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
    If it give you no address, then run it with the -no-upload option:
/usr/sbin/ --no-upload

and open the file /tmp/alsa-info.txt with a text editor, and copy the contents into New - Pastie and press ‘paste’ on that site and then post here the URL/website address it gives you.

  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • In a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

alsaconf was depreciated in openSUSE-11.2 (it last worked on openSUSE in version 11.1). So it will not work in version 11.3.

Although not exactly your configuration, I have

82801DB/DBL/DBM ICH4/ICH4l/ICH4M AC '97 Controller

as my laptop sound device. The install made note of it, but no sound. YAST recognized it, allowed many types of changes, but … no sound. The solution was embarassingly simple and (in retrospect) obvious. In Gnome Control Center (not YAST), go to Sound. In the “Output” tab, the sound device should be “Internal Audio Analog Stereo”, and in the “Connector” drop-down, select “Analog Output/NO Amplifier”. Voila! Sound is working!. For some reason, the install had recognized the device, set same as “Amplifier”, and set the volume very low!.

sorry it is long.

  1. I try to check DVD

linux:~/openSUSE-DVD-Build0625-i586.iso> md5sum openSUSE-DVD-Build0625-i586.iso

d22f8c93f99d9af4cc457f62f7a99a7c openSUSE-DVD-Build0625-i586.iso

I search number at google. It was found in an index.

  1. Is sound is switched on in BIOS?

There is no option. I can’t turn off. Also there is no problem in vista.

  1. did you burn the .iso file to a +R or -R CD/DVD (and NOT to an RW CD/DVD) and burn at the slowest speed your burner allows?

  2. /usr/sbin/

I ran the script. It upload automatically.

  1. rpm -qa ‘alsa


  1. rpm -qa ‘pulse


  1. rpm -q libasound2


  1. uname -a

Linux linux 2.6.34-8-desktop #1 SMP PREEMPT 2010-05-17 17:30:24 +0200 i686 i686 i386 GNU/Linux

  1. cat /etc/modprobe.d/50-sound.conf

cat: /etc/modprobe.d/50-sound.conf: No such file or directory

  1. cd /etc/modprobe.d # (There is no file about sound)

0-system.conf 50-bluetooth.conf 50-iwl3945.conf 50-thinkpad_acpi.conf
10-unsupported-modules.conf 50-ipv6.conf 50-nvidia.conf 50-tv.conf
50-blacklist.conf 50-ipw2200.conf 50-prism54.conf 99-local.conf

… hmmm… thats openSUSE-11.3 Milestone7. I do not know what the md5sum for that is supposed to be.

I am having this problem with openSUSE 11.3 RC2

linux-f5i8:/home/stephen # lspci | grep Audio
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)

linux-f5i8:/home/stephen # rpm -qa ‘pulse

linux-f5i8:/home/stephen # rpm -qa ‘alsa

linux-f5i8:/home/stephen # uname -a
Linux linux-f5i8 2.6.34-12-desktop #1 SMP PREEMPT 2010-06-29 02:39:08 +0200 x86_64 x86_64 x86_64 GNU/Linux

linux-f5i8:/home/stephen # cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel

u1Nb.L9bG3sID4aA:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

I have gone into kde mixer and everything is set to max but no sound (nothing muted).

Any obvious suggestions - I even went back into yast edited sound card and enabled it again.


problem resolved with installation of alsa-firmware.

My question is why alsa-firmware wasn’t installed during installation, I don’t recall this problem with 11.2. As I remember correctly the sound worked out of the box.

Its been this way since around openSUSE-10.2 or 10.3.