No sound

Hi all,

I just installed openSUSE 11.2. When I had installed it, I could play music from youtube and others, but no mp3-files. Because of that I followed the steps described in this thread:
Multi-media and Restricted Format Installation Guide - openSUSE Forums

When I finished that, I still couldn’t play my mp3-files and couldn’t even play music from youtube anymore.
If somebody can help me out with this, I would be very glad.


Please confirm if you have login and logout audio
or what happens in Yast - Hardware - Sound (test sound)?

Please post result of this:

zypper lr -d

Audio help
SDB:AudioTroubleshooting - openSUSE

This is the result of zypper:

| Alias | Naam | Ingeschakeld | Vernieuwen | Prioriteit | Type | URI | Service

1 | 11.2 | 11.2 | Ja | Ja | 99 | rpm-md | Index of /suse/11.2 |
2 | repo-debug | openSUSE-11.2-Debug | Nee | Ja | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
3 | repo-non-oss | openSUSE-11.2-Non-Oss | Ja | Ja | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
4 | repo-oss | openSUSE-11.2-Oss | Ja | Ja | 99 | yast2 | Index of /distribution/11.2/repo/oss |
5 | repo-source | openSUSE-11.2-Source | Nee | Ja | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
6 | repo-update | openSUSE-11.2-Update | Ja | Ja | 99 | rpm-md | Index of /update/11.2 |

There is also no log in and log out sound. (I just tested that)

After te reboot for testing the log in and log out sound, my internet isn’t available anymore. So I am now using another pc for getting online. I think I will reinstall openSUSE, but how will I get to play mp3-files and .avi? Because thats for me the most important files to play and with the “how to” on this forum I didn’t get it to work.

Re-install if you like
The guide you quoted earlier is one of mine, and it should work. But your repo list is missing a repo it asks you to add ‘Packman’
Do you know why it’s missing?

Are you sure you have installed everything as per the instructions in my guide?

You could have another go but if your internet is down now, you may be better starting fresh. You need to follow my guide to the letter.

Isn’t this one packman?

1 | 11.2 | 11.2 | Ja | Ja | 99 | rpm-md | Index of /suse/11.2 |

I was thinking it was, but if it isn’t, how do I put packman in the repo list? I was really thinking I succeeded in that. (I am completely new with openSUSE and just working a few months with linux, so I don’t have that much knowledge of it)

And yes, I think I did everything exactly how it was standing there, but if you say it should have worked, I guess I didn’t.

No it is not.

You need to sort your Internet connection IMHO before you start messing with your sound/audio.

In truth setting up multimedia in openSUSE is incredibly easy, IF one knows how to do it. Note the capital “IF”. It is especially easy in openSUSE-11.2 IF one knows how to do it. Again, the capital “IF”.

In essence, once internet is established, one adds “packman” to their repository list, sets packman as the “system source” for multimedia applications, and then adds a small number of additional selected applications, and everything typically works. But a failure to properly do what that sentence entails (and to also understand what it precisely entails) has stumbled many users new to openSUSE Linux.

YES Sorry about that. It’s my fault I didn’t hover the url to check, normally users give a name that can be identified easily in software manager.

Is it your wireless or ethernet that is not working now?

For example, this is how my packman entry looks

12 | packman                             | packman                     | Yes     | Yes     |   99     | rpm-md |

Did you do this in software management

If you can get your internet back, you can try that. If it was your wireless that went down, can you hook up directly with a ethernet cable?

I am using ethernet, simply because it’s faster and more stable. Does one of you two use IRC or another messenger for faster help?
It would really help me if somebody could explain it step by step.

I do use IRC but right now I have to go cook food.

If you have eth0
work on the guide

tell us if you use gnome or kde too

I use the gnome version. At what time will you be on IRC for help? I am online at #TheAtlanteans, that’s a private channel.

Hmmm, my pc got crashed while doing updates. So I restarted the pc and wanted to do the updates again, now every time I try to update I get the following message:

I tried to do the updates one by one, but with every update I get the same message. Is this easily fixable or do I need to reinstall again?

I recommend you switch to the QT UI
Follow this
How To Get QT zypper GUI in GNOME YAST - openSUSE Forums

Then try this in a su -

zypper up

Become su in Terminal - HowTo - openSUSE Forums

I’ll try for 7PM UK time

I have successfully set the zypper at qt, but with the installing of the packages with the terminal I gain the following message:

kars@linux-gw8e:~> zypper up
Root privileges are required for updating packages.

Normally I have to fill in a password for using root, but it wasn’t asked here and I don’t know how I can run terminal in root.

Try this:

su -

and enter root password when prompted for a password. Note the prompt changes from > to #

and then type:

zypper up

I gave you a how to on root in post #15
I’m on IRC #suse