No sound

I have opensuse 11.2 and I have no sound from opera or firefox. I have checked Yast and it looks like all of the default sound apps are loaded. I have a newer PC with soundcard on the mobo. I also have XP on this machine and the sound works. Any suggestions?

SDB:Audio troubleshooting - openSUSE

What is your criteria for stating sound does not work?

Is it only opera and firefox and sound works elsewhere? If sound works else where, please post, advise us, and go no further in reading this post of mine.

If no sound in any application, then try each of the following in a terminal, first as a regular user and then with root permissions. Try with and without headsets:

  • first:
 speaker-test -Dplug:front -c2 -l5 -twav
  • second, try again:
speaker-test -c2 -l5 -twav
  • third:
speaker-test -c2 -D hw:0,0 -t wav -l3
  • fourth, this next command has a volume meter at the bottom of its output with a changing number of #'s and %'s to show volume levels so run this command and tell me if the number of #'s and %'s are changing:
aplay -vv /usr/share/sounds/alsa/Front_*
  • fifth: and also:
aplay -vv /usr/share/sounds/alsa/test.wav

Do any of those give an indication of sound ?

If the audio troubleshooting guide recommended by caf4926 does not help you in solving your sound problem, and if none of the above tests give sound, then please provide the information recommended to be provided in the second half of our multimedia stickie in this thread Welcome to multimedia sub-area - openSUSE Forums , and I quote:

If that that does not help you get your basic sound working, please post in this “multimedia” sub-forum, providing in your post the following information:

  • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
    SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script /usr/sbin/ and after the script finishes it will give you a Website URL/address to pass to the support personnel. Please post here the output website URL address. Just the URL address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.2 or later, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

Sorry for the delay in posting. I tried playing a cd and had sound with the cd. I could not get a DVD to play at all. The sound problem seems confined to Firefox and Opera. Thanks for your help.

Multi-media and Restricted Format Installation Guide - openSUSE Forums

wrt Firefox and opera, ensure you have “flash-player” installed.

Also if using KDE, ensure the order of sound devices under MENU > Configure Desktop > Multimedia is consistent with the order of sound devices under YaST > Hardware > Sound.

Also, check your mixer’s PCM settings when playing video/audio from opera/firefox. It will often be dynamically set to zero, and you need to move the volume levels UP again.