No Sound...

I just install openSUSE 11 as a dual boot with Windows Vista sound works fine in vista but not in suse so i started to follow this guide SDB:AudioTroubleshooting - openSUSE

on the first step to run
“rpm -q alsa alsa-utils alsa-firmware”

i get back
“package alsa-firmware is not installed”

so then the next step i run
“zypper install alsa-firmware”
it says Alsa firmware already installed nothing to do…

now im stuck on “STEP-2: Trying YaST &/or ALSACONF to configure ones sound”

where it tells me to delete the soound card and reconfigure it, but when i try to i get

An error occurred during installation of
SB0400 Audigy2 Value
The kernal module snd-emu10k1 for sound
support could not be loaded this can be
caused by incorrect modual peramiters including
invalid IO or IRQ peramiters.

so now im not sure what to do next.

PC: Dell Inspiron 531
OS: Vista (32bit)/openSUSE 11 (32bit)
CPU: Intel Core 2 Quad Core 2.4ghz
RAM: 4gb
HD: 500GB
Vid: Nvidia Geforce GeForce 8600 GT
SC: Sound Blaster Audigy 2 Value

I am HIGHLY suspicious of a syntax error on your part (or less likely your rpm database is corrupted). Please post the output of:
rpm -qa | grep alsa

Lets sort out what you have installed, before we proceed.

ran it and i get back


With root permissions, rename the file /etc/modprobe.d/sound to /etc/modprobe.d/sound-old and try YaST again to configure your sound card. Test your sound. If that fails then with root permissions in a konsolse type alsaconf to try to setup your alsa/sound. This is all part of step-2 of the troubleshooting guide.

Just carry on following the guide from there.

I went ahead and ran “alsaconf” and it configured my sound card at least it appears that way in yast sound configuration but im still not getting any sound. in yast sound config is is only list my sound card and when i select it on the bottom window it says

SB0400 Audigy2 Value
-configured as sound card 0
-drivers snd-emu10k1