no sound

If I go into YAST I can get sound to work but when I exit it there is only a dunny sound avaiable. Now do I start the sound system again like it does in yast ? what is the command to restart sound?
opensuse 13.2 is what I’m using on an Dell Inspiron.

I found it was not loading (or unloading) the sound mod. did modprobe snd-hda-intel (what yast says I have) and now it works. Can someone tell me where to add this line in the boot sequence so it is done at boot ?

There are several ways to force modules being loaded at boot, in particular /etc/modules-load.d/ and /etc/modprobe.d/.
But if you configure the card in YaST (select the card and click on “Edit”), it should actually create a file /etc/modprobe.d/50-sound.conf that loads the driver. Does that not work?

This is what my /etc/modprobe.d/50-sound.conf contains:

options snd slots=snd-hda-intel
# u1Nb.rR8CwXYvElF:82801G (ICH7 Family) High Definition Audio Controller
alias snd-card-0 snd-hda-intel

The second line is just a comment so that YaST recognizes to what hardware that entry belongs. You can omit that of course.

it does write the file, but when I boot it doesn’t seem to load it. I have to run modprobe and even then it will not always work. I have to go the yast and reset all and then have it restart the sound to make it work. I want to know what command it is running to reset sound.


sudo modprobe -r snd-hda-intel
sudo modprobe snd-hda-intel

I.e. unload the module and load it again.

tried that, says can’t unload it is in use, but all that shows in the mixer (KMIX) is dummy. It works within yast, but not outside of it…?

You have to quit all programs that are using it, like YaST and kmix.

Run this to see all of them:

lsof /dev/snd/*