No Sound yet??? PC Speaker nt Working!!!

I got Opensuse 11.0 in lenovo pc.

But no sound yet…!!!

However mic sound is running properly…

Bt Pc Speaker yet nt work???

cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xd0200000 irq 22

> But no sound yet…!!!

just five minutes ago i read (somewhere in these fora) that a guy
fixed his sound problem by turning the “front speakers” volume up
from their DEFAULT setting of zero (off)…

see if you can find that knob, and tweak it…
where? don’t remember (it HAS been five minutes), maybe in the mixer…

see caveat:
DenverD (Linux Counter 282315) via NNTP, Thunderbird, KDE
3.5.7, SUSE Linux 10.3, #1 SMP i686 athlon

I’m hoping the recommendation provided by DenverD works. But if adjusting your Front Speakers as noted by DenverD does not help, then you could start by trying to work your way through the openSUSE audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

If that doesn’t work for you, then we need you to provide more information on your hardware/software audio configuration, including your mixer settings. In after having attempted to work through that guide, you still do not have audio, then then we need more information to give you an accurate recommendation.

To provide more information, with your PC connected to the internet, please copy and paste the following into a gnome-terminal / konsole:

wget && su -c 'bash ./tsalsa' 

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following, one line at a time, into a gnome-terminal/konsole and post the output here.
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Good luck!

rpm -qa | grep alsa

** rpm -qa | grep pulse**
** rpm -q libasound2**
** uname -a**
Linux linux-0xay #1 SMP 2008-06-07 01:55:22 +0200 i686 i686 i386 GNU/Linux

** cat /etc/modprobe.d/sound**

options snd slots=snd-hda-intel

u1Nb.ziVi+zrixe1:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

speaker-test 1.0.16

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 16384
Period size range from 32 to 8192
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
0 - Front Left
1 - Front Right
Time per period = 2.732577
0 - Front Left
1 - Front Right
Time per period = 3.071495
0 - Front Left
1 - Front Right
Time per period = 2.901320
0 - Front Left
1 - Front Right
Time per period = 3.071721
0 - Front Left
1 - Front Right
Time per period = 3.071390


Thanks for that. I note you do NOT have alsa-firmware installed. I also note you have the older kernel on your openSUSE-11.0 (as opposed to the latest Your /etc/modprobe.d/sound file has the structure associated with it being automatically created by YaST.

The script also tells me your PC has an AD1986A. Doing an alsa search on the AD1986A, the most current change appears to have been made with 1.0.16 of alsa, which you have installed (so your audio driver appears ok). Search results for AD1986A- AlsaProject

Anyway, thanks for this information. Its possible we may need to apply a custom setting to your /etc/modprobe, but first look at your mixer settings:Amixer contents for card 0 [Intel] _____________________________________
amixer set ‘Master’,0 97% on
amixer set ‘Headphone’,0 100%,100% on
amixer set ‘PCM’,0 0%,0% on
amixer set ‘Front’,0 94%,94% on
amixer set ‘Surround’,0 87%,87% on
amixer set ‘Center’,0 97% on
amixer set ‘LFE’,0 81% on
amixer set ‘Line’,0 Mono: 68%,68% on
amixer set ‘CD’,0 Mono: 100%,100% on
amixer set ‘Mic’,0 Mono: 81%,81% on
amixer set ‘Mic Boost’,0 67% 67%
amixer set ‘Phone’,0 Mono: Capture off
amixer set ‘IEC958’,0 off
amixer set ‘IEC958 Default PCM’,0 on
amixer set ‘PC Speaker’,0 93%,93% on
amixer set ‘Aux’,0 Mono: 100%,100% on
amixer set ‘Mono’,0 Mono: 100%,100% on
amixer set ‘Capture’,0 Capture 0 0% off Capture 0 0% off
amixer set ‘Mix’,0 Mono: Capture off
amixer set ‘Stereo Downmix’,0 off off From that, I see your PCM is a 0% (in red above). It needs to be switched ON and at about 65% to 75%. Please look inside your mixer, move that up, and try the sound test again. Note that PCM can be changed dynamically by the programs that you run. I also put in “orange” some other parameters whose settings you could investigate.

If that does not work, please install alsa-firmware (it is on the opensuse OSS repository), reboot, and try your sound again. Be certain to check your mixer.

Please advise if that doesn’t work, as if it does not, I will propose some changes to your /etc/modprobe.d/sound file.

Good luck.

I set PCM = 100% so many times bt there is nt NO Sound yet…

Just downloadin alsa-firmware now…

Also, don’t forget to to into YaST > Hardware > Sound > Other > Volume and move the volume bars there to about 75%.

Note there is no need to go to 100%. IMHO if it doesn’t work at 75%, its unlikely it will work at 100.

Good luck with the alsa-firmware install. Don’t forget to reboot after installing it.