No Sound with X-fi on openSuSe11.2... Grrrrrr

First things first… I am a total noob with linux. And I am very sorry if I am not posting in the right place. I am trying desperately to get my sound card working but with no look upto now. Card is recognized in hardware information in Yast control centre, however when i try and play anything there is no sound. I have also tried configuring my sound card but i get An error occurred during the installation of X-Fi. The kernel module error for sound support could not be loaded. This can be caused by incorrect module parameters, including invalid IO or IRQ parameters. I’ll be really grateful if anyone could help me resolve this issue as it’s driving me round the bend. Running openSuSe 11.2 x86_64. Thanks

Support for X-fi in Linux is very new, with support only “just” being added in version 1.0.21 of alsa. The 2.6.31 kernel, which ships with openSUSE-11.2 contains 1.0.21 of alsa. In addition to the kernel, openSUSE-11.2 ships with packaged rpms with 1.0.21 of alsa. So there is support for X-Fi in openSUSE.

However the alsaconf configuration tool is depreciated, and does NOT work with openSUSE-11.2’s /etc/modprobe.d file naming convention. In addition the openSUSE-11.2 tool YaST has NOT been updated to work with the X-Fi sound device.

Hence what you must do is go to the directory /etc/modprobe.d and delete the file “50-sound.conf”.

Then reboot your PC.

Your sound should be working then. Please ensure you go to your mixer (kmix in KDE and alsamixer in gnome) and move up your volume levels, including master, PCM and speaker (I’m not certain what controls X-Fi has).

Note, when testing your audio, please use the 3 checks from the audio troubleshooting guide (typically only 1 or 2 of those will work, so do not be surprised if only one works - you only need 1 to work): SDB:AudioTroubleshooting - openSUSE - How to test your sound

Good luck. Don’t spend too much time on this. Post if you get stumped.

thanks for the prompt reply but that file is not even there… any other ideas?
It actually seems like the drivers are not installed at all

The drivers are there. I explained above.

What is your criteria for saying there is no sound? What application are you running that gives you that assessment? What applications did you try? What files did you try play?

i tried amarok i also tried doing the sound test and also my sound card is not showing in the Yast sound control centre.

Thats inadequate. Its a horrible sound test.

You probably do not have the codecs for amarok.

And I already explained YaST was not updated for X-Fi. Did you read my post?

Please read this and follow it for setting up your multimedia:
Multi-media and Restricted Format Installation Guide - openSUSE Forums

also when i try and play an audio file a popup in the lower right hand side of the screen says the audio playback device ALSA default output does not work. Falling back to.

Reference, falling back to default, this is a known bug. I believe a number of users have reported this on both 11.1 and 11.2. For 11.1 there are a more than a fewthreads here, where users have posted solutions that worked for them:

Ok thanks i’ll try these few tips. thanks for your support anyways. If i have any further issues i’ll post again. Thanks

If you have trouble, please with your computer connected to the internet, copy and paste the following into a terminal (to run a diagnostic script that gives more information):
/usr/sbin/alsa-info.sh
that will ask if you wish to UPLOAD/SHARE? Select to UPLOAD/SHARE and when it is done it will give you a URL. Please post the URL here. Just the URL.

Please also provide the output of copying and pasting:
cat /etc/modprobe.d/50-sound.conf
(hopefully you will get nothing)

I ran into this same issue for a friend a few days ago, if you use the YAST2 sound to configure or run alsaconf it’ll blow up X-Fi completely and Phonon will go bonkers. The only way to restore functionality is to remove the modprobed files as oldcpu pointed out, technically all “sound” files in /etc/modprobe.d/ and reboot.

Tearing out my hair. followed what it says in the link you posted Multi-media and Restricted Format Installation Guide - openSUSE Forums. tried to play a file in vlc and i can see the slider moving but no sound comes out. done also the sound test as mentioned on the same website and this is what i get:
robin@linux-gxff:~> speaker-test -Dplug:front -c2 -l5 -twav

speaker-test 1.0.21

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib pcm.c:2211: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
Playback open error: -2,No such file or directory
ALSA lib pcm.c:2211: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
Playback open error: -2,No such file or directory
ALSA lib pcm.c:2211: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
Playback open error: -2,No such file or directory
ALSA lib pcm.c:2211: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
Playback open error: -2,No such file or directory
ALSA lib pcm.c:2211: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
Playback open error: -2,No such file or directory

I have also followed the links about the pop up saying falling back to default but it keeps happening. I really want to move away from windows but this is very frustrating

http://www.alsa-project.org/db/?f=ac1930e3f02bb9b906079d14131b744890bf6882

I still don’t have this file 50-sound.conf in my etc/modprobe.d folder. What am i doing wrong?

thanks for the advice but cannot do that as i don’t have that file in my modprobe.d directory

Out of curiosity, do you have an onboard sound adapter? If so, disable it in BIOS.

Also, did you make sure the mixer looks sane when it comes sound volumes? Something like this;

http://i283.photobucket.com/albums/kk282/Chrysantine/th_x-fi.jpg](http://i283.photobucket.com/albums/kk282/Chrysantine/x-fi.jpg)

Yeah i have a realtek sound card onboard but it is disabled in bios as i never use it. As in regards to that mixer i wouldn’t know how to get to it lol i am such a noon, who managed to set up a wifi network on suse by himself. If you noticed from the alsa link report posted alsa doesn’t even recognize the card so i doubt very much i would be able to load a mixer, especially the creative one. But if you tell me how to get to it i’ll have a look for it

Can you post the results of:
ls -l /etc/modprobe.d/
here, please?

Also the mixer is ALT+F2 and kmix after which you should have a little speaker on the bottom right corner of your screen (in the systray). Click it and choose mixer. You can enable more channels to show under Settings / Configure Channels, you’ll want at least PCM enabled alongside the normal ones and pull that up.

robin@linux-gxff:~> ls -l /etc/modprobe.d/
total 44
-rw-r–r-- 1 root root 2873 2009-10-24 04:08 00-system.conf
-rw-r–r-- 1 root root 532 2009-10-24 04:08 10-unsupported-modules.conf
-rw-r–r-- 1 root root 5890 2009-10-24 08:14 50-blacklist.conf
-rw-r–r-- 1 root root 128 2009-10-21 23:49 50-bluetooth.conf
-rw-r–r-- 1 root root 23 2009-12-02 17:38 50-ipv6.conf
-rw-r–r-- 1 root root 33 2009-10-19 19:04 50-ipw2200.conf
-rw-r–r-- 1 root root 86 2009-11-02 12:11 50-nvidia.conf
-rw-r–r-- 1 root root 18 2009-10-19 19:04 50-prism54.conf
-rw-r–r-- 1 root root 398 2009-10-24 04:02 50-thinkpad_acpi.conf
-rw-r–r-- 1 root root 0 2009-12-02 17:28 50-tv.conf
-rw-r–r-- 1 root root 0 2009-12-02 17:38 50-yast.conf
-rw-r–r-- 1 root root 47 2009-10-24 04:08 99-local.conf

When i try and start kmix all i gt is this speaker bouncing up and down on the screen but nothing happens