No sound with SUSE 11

Hello all. I am pretty new to Linux so I am not sure what to do. Just installed SUSE 11 as a duel boot with Windows. I have a Japanese computer because I live in Japan and started usin Linux because I wanted my computer in English. It is an “all in one” machine. It is a Valuestar VW900/D. I believe the chipset is as follows:

It uses the Intel 82915GV / 82801FB chipset.
The sound chip is the ADI-company’s AD1981B.

Any suggestions would be helpful. Thanks!

Can you work your way through the openSUSE audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE
Be certain to install alsa-firmware, rebooting afterward to test.

Also, some 11.0 users are having problem with pulse-audio. You could try removing that (with an intention of restoring it back later, so take notes as to what you remove).

Could you also provide the output of:
cat /etc/modprobe.d/sound
and I’ll provide you an exact entry (such as model=laptop) applicable to an AD1981B to add to your /etc/modprobe.d/sound file that might help.

One thing that you might need to do is go into YAST and make sure that the volume is set correctly on your sound card. All of my channel volumes were set at the lowest setting.



I have tried to install alsa and it didn’t fix the problem. I also followed the help section with no prevail. Any more suggestions?

In addition to answering my question from this post (which you have not done yet), where I asked for output of: cat /etc/modprobe.d/sound
No sound with SUSE 11 - openSUSE Forums

Please also paste the output of:
rpm -qa | grep pulse
rpm -qa | grep alsa
rpm -q libasound2

And also, when your PC is connected to the internet, copy and paste these two diagnostic scripts into an xterm/konsole and paste here the output URL that they will provide you:

wget -O && bash 

when this next script prompts you for a password please enter the root password and also type “NO” for every question that you do not understand.

su -c 'wget -O tsalsa wget && bash tsalsa' 

both of the above scripts will give you a URL. Please paste that here.

Only after obtaining the above information can I make a recommendation.

i am experiencing the same problem after going through the install alsa instructions, and the SDB Audtio Troubleshooting tutorial. i have no sound. i am trying to setup the Audigy 2ZS as my primary sound card. here is my info:

options snd slots=snd-hda-intel,snd-emu10k1

jqQS.9jPiZAnlR97:SB Audigy 2 ZS (SB0350)

alias snd-card-1 snd-emu10k1

mDsH.vLXC8EvZgR7:MCP55 High Definition Audio

alias snd-card-0 snd-hda-intel

cdpoe@linux-mnbo:~> rpm -qa | grep pulse
cdpoe@linux-mnbo:~> rpm -qa | grep alsa
cdpoe@linux-mnbo:~> rpm -q libasound2

general pastebin - cdpoe - post number 1069827
tsalsa.txt - (beta)

thank you for your assistance. :slight_smile:

You have two audio cards I see. Anyway, from tsalsa.txt, as a minimum, its very clear you have a mixer configuration problem and you did not setup your mixer correctly for your 2nd (Audigy) card.

Amixer contents for card 1 [Audigy2] _____________________________________        
amixer set 'Audigy Analog/Digital Output Jack',0 off  

That jack should be ON.

Please look here at Chrysantine’s guide:
[Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA - openSUSE Forums](

Thank you! The guide was perfect! The switches tab in the kmix was what I missed. I clicked that to ‘on’ and all is well… thanks again! :smiley:

VIA Kt266 motherboard, Athlon 2400. Upgraded to (not installed fresh) suse 11 from 10.3, lost most audio, lost ability to play multimedia outside gmplayer (kaffeine doesn’t display). gmplayer can play audio if a previously running gmplayer is already running, but 2nd gmplayer can’t do video. KDE seems able to generate beeps though.

This reads like one (or possibly both) of two possiblies:
a. repository problem, where you may have mixed Videolan packaged rpms with Packman packaged rpms, and
b. problem with “desktop effects” impact on video

Reference item-a, I recommend you setup your repositories with ONLY OSS, Non-OSS, Update, and Packman. Only those 4. No others. You can add others if and as required for specific applications and then remove (the other repos) when not required. Guidance for setting up those 4 repos for openSUSE-11.0 is here:
Repositories/11.0 - openSUSE-Community
if you have videlan repos added, I recommend you remove it. And then after removing it, change your videolan installed players (and also libffmpeg0) for the packman versions.

Reference item-b, if you are using ‘special desktop effects’ (3D, the “cube” and such) then you may have to change the output video mode of your player from “auto” or “xv” (xvideo) to “x11” (as a work around).

Good luck, and WELCOME to our forum.

Hi, hope this thread is not dead yet. I’m experiencing similar problems, and after running the, the following is the resulting message:

Your ALSA information is located at

Please inform the person helping you.

Apparently, it is working, but no sound comes out the speakers. To whom can I direct this? Any help, as of course, will be much appreciated.

I see from the script output that you are running SLED-11. Typically, SLED problems are handled here: SUSE Linux Enterprise Desktop (SLED) - NOVELL FORUMS

We support openSUSE on this forum.

I can try help, but my lack of familiarity with SLED may mean I may not know some aspects.

Anyway, the first thing I note from the script is your HP Presario V3000 PC has SLED-11 with the and 1.0.17/1.0.18 of alsa. The PC’s hardware audio codec is a Conexant CX20549 (Venice).

The mixer on the PC appears to be mis-configured. I note:
!!Amixer output
!!-------Mixer controls for card 0 [NVidia]

Card hw:0 ‘NVidia’/‘HDA NVidia at 0xc0000000 irq 17’
Mixer name : ‘Conexant CX20549 (Venice)’
Components : ‘HDA:14f15045’
Simple mixer control ‘Master’,0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Front Left: Playback 20 [47%] -34.50dB] [on]
Front Right: Playback 20 [47%] -34.50dB] [on]
Simple mixer control ‘PCM’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Front Left: Playback 0 [0%] -30.00dB] [off]
Front Right: Playback 0 [0%] -30.00dB] [off]
Please move up the maser volume from 47% to 95%. And please switch ON the PCM volume control and also move it up to 95%.

Note in KDE your mixer is “kmix” (the small speaker in right hand corner). In Gnome your mixer is “alsamixer”.

Also, please note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:

aplay -vv somefile.wav

With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Good luck, and please let us know if you have success.