No sound with SMPlayer, VLC OK

I have been using VLC to play downloaded files which have been .flv because that was the player that started when the files were selected and it just worked. The sound device is just shown as “default” but I have no idea what that is.

I have just downloaded another file and when I clicked on it SMPlayer opened and started to play but there was no sound.

Wondered why SMPlayer started instead of VLC and saw that the newest file was .mp4, however SMPlayer doesn’t give any sound with the .flv videos either, on the other hand VLC plays .mp4 files too with sound.

Clearly I need some guidance on how to set up SMPlayer please.

A further question. I have recently been getting error messages as follows:-
Potential ALSA version problem:
VLC failed to initialize your sound output device (if any).
Please update alsa-lib to version 1.0.23-2-g8d80d5f or higher to try to fix this issue.

However when I searched for the suggested file I couldn’t find it but before I go any further, is this a real problem or could it be due to having the sound turned off from the keyboard? .

Grateful for any advice please.

What output audio mode are you using in smplayer ? I typically use “OSS”.

IMHO thats a VLC bug.

Hi Oldcpu,
Audio output mode, I have discovered was set to pulse. I have changed it to OSS as you suggest and now I have sound. Many thanks. I see there are three alsa options also. What is the difference? It seems from the error message that VLC uses alsa.

A bug possibly, but not fatal and I have more or less confirmed it only happens when sound has been switched off at the keyboard so I can live with it.

BTW I saw and agree with your comments on the reorganised Packman repo site. Recent starts on my laptop have asked me to accept new Packman keys. Is this a related matter or something more sinister?

The option pulse will use the pulse audio system. The option ‘oss’ will use the alsa oss emulation driver (and hence the alsa API, I believe). If pulse is selected, then IMHO the best way to get vlc working with pulse selected is to install the application ‘pavucontrol’ and then launch ‘pavucontrol’ and then play a video with vlc while pavucontrol is playing. One can then select a different audio device to get the app (in this case vlc) working with pulse.

Of course even when using pulse, alsa is in use.

This is something that I believe worked on and off and is working now. Its a good thing.