no sound with opensuse 11

hello together

after update from opsenSUSE 10.3 (here was all fine) to version 11 I have no sound anymore and I have no idea why. I already upgrade to the unstable alsa-driver but it don’t work

here are the informations of may system:

Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)


general pastebin - bilz - post number 1052892

rpm -qa | grep alsa:


rpm -qa | grep pulse:


rpm -q libasound2:


uname -a:
Linux linux #1 SMP 2008-06-07 01:55:22 +0200 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/sound:

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

rcalsasound restart:
/usr/sbin/alsactl: save_state:1501: No soundcards found…
Shutting down sound driver done
Starting sound driver: hda-intel done

hope anyone could help me

thanks and regards

have you worked your way through this?

SDB:AudioTroubleshooting - openSUSE

might help, if not i would wait until oldcpu comes on he knows all about this stuff.

Yes I have, but one problem is that I don’t have a directory
/proc/asound/card0/ so the command head -n 1 /proc/asound/card0/codec to find out which soundchip is in use do not work.


Thats very strange that it worked in openSUSE-10.3 but not in 11.0. The script does not provide much as your sound card is not “recognized”.

Did you do a CLEAN install from 10.3? or an upgrade install from 10.3 ?

Did you reboot after updating your alsa? Thats important. Without doing that, everything else is meaningless, and must be done again.

After rebooting, did you try alsaconf (in a konsole with root permissions)? or try YaST > Hardware > Sound ?

What can you tell us about your laptop or motherboard?

It’s not the good old “Channel in the mixer is muted” problem, by any chance?


You don’t say if you’re using kde4 or 3.5. Check the kmixer channels, make sure they’re all on.

You can do:

lsof | grep snd

It’ll tell you what’s using the sound card. You can kill the process(es) to free the card. Also, pulse audio is still not perfect, so you might want to remove all references to it and rerun alsaconf.

I use kde 3, and I don’t have any possibilities to set up anything in the mixer. kmix shows ony an empty dialog, so it is not only a set to mute problem.

I have upgraded my system, it was not a new install.

I try to set up the sound card over yast, but yast says that I have a problem with the mode or IRQ. befor that I rebooted my system

I also try alsaconf -> throws no errors but the kmix is also empty afterwords

lsof | grep snd did not show any

I have a acer aspire 5650 laptop and I use 10.0 to 10.3 with some problems with the card reader but never with the soundcard


This is one of the reasons I really dislike it when users upgrade their system. These sorts of things are not supposed to happen, … but they do.

Please HOW did you go about upgrading your system? Did you do it via CD/DVD, or did you do it by downloading over the web.

If you did it via CD/DVD, then please check the md5sum like I requested. If you did it by other method, then I don’t think I can help. You could have a mix of configuration files, and a mix of libraries, and I don’t know what else, that is breaking your sound. At the risk of sounding like a broken record, this is one of the reasons I really dislike it when users upgrade their system.

openSUSE-11.0 is the fastest of the openSUSE’s since I can remember, to clean install from CD/DVD. IMHO you will spend more time chasing this problem, than you will lose installing (unless you have custom databases and custom compiled applications scattered through /usr and /opt and /var and other locations).

Well, I already think about a new install, but if you comment correctly it will take a lot time to set up the system as it was before.
I upgrade the system so early cause of the card reader which will work now with the aktual kernel…

thanks for your help and time

Use the same sound card can not get it working in suse 10.3 even with all the advises found on suse web site . It did work with suse 9.3
The point is Ich7 is a quit difficult sound card it vary a lot
there was a lot off information about this sound card on the Intel website
The knew the problems but during my search there was not yet a fix
And now using suse 11. kde4.04 beside the problem mentioned in my thread it works.
Suse 11. was a clean install I always do also
with my other distro
My humble opinion save /home and always do I clean install


I just wanted to mention this. I had the same symptoms using a very similar audio adapter (82801H (ICH8 Family)). This was not after an upgrade to 10.3 – this was a clean install of openSUSE 11.

The way I got it working was to remove ALL the packages that referenced Pulse. I don’t know if it was necessary to remove ALL – but after I did that and rebooted, sound worked fine.