No Sound with 11.4, Intel z68, Realtek ALC889, Gigabyte GA-Z68MA-D2H-B3

I am struggling to set up sound. The story is this. After the fresh install of 11.4 (a few days ago) there was sound at least once when I logged into KDE. Then I must have done something wrong, because the next day sound was gone. I cannot remember what it was, probably I just muted in some KDE program. Anyway, when I tried to get my sound back, I could not. I then had the stupid idea to simply re-install the sound via YAST. After doing this I carefully checked of course that the sound was not muted, but still: no sound. I then had the even more stupid idea to look for a driver for this Realtek chip. Downloaded it from the Realtek site (realtek-linux-audiopack-5.16) and tried an automatic install which was ‘unsuccessful’ to put it mildly. Because now I cannot even do the YAST-Install anymore. When I try to do so I get the message (translated from german) "Error during install of Intel Corp. Kernel module snd-hda-intel could not be loaded. A possible reason could be wrong / invalid parameters…
Now my question: Can I somehow clean all sound settings so that I can set up sound via YAST “from a clean table”? Unfortunately I read the posts on these ALC889-problems here in the forum only after I messed up my things. It took me so much time to set up the other things (applications, printer, display) that I would rather give up sound than do a fresh install…

This is a real mess. It reads that the kernel module for sound (ie the driver) that comes with the kernel has been over written by either a corrupted, or a badly installed driver from the realtek site, in what appears to be an MS_Windows approach to solve a GNU/Linux problem.

If it were me (with my knowledge level) in this situation, given someone else’s PC to fix, I would :

  1. either bit the bullet and re-install GNU/Linux (most likely) and setup up GNU/Linux the way I want. You note you would rather live without sound than do that. For me it is just the opposite. Sound is more important to me.
  2. or force a re-install of the kernel in order to replace the corrupted kernel module. That’s not something I do often, and I don’t feel comfortable trying to explain to you how to do this given what it appears to be your knowledge level (frankly its something I would be reluctant to describe to someone at my own knowledge level)
  3. or update alsa to the latest alsa version, being certain to install the alsa-driver-kmp package which will replace what appears to be a corrupted kernel module and install the other appropriate (and only the appropriate) alsa apps. I wrote a guide on how to do this here: SDB:Alsa-update - openSUSE … unfortunately I am pathetic at writing guides (as I have lost touch with my inner newb) and my experience is greater than 50% of users who attempt to follow that guide fail, and I am NOT able to write an easier to follow guide. So that also looks like a poor approach.

I think you should just bit the bullet and re-install. At most you lose a few days.

When you re-install, ensure you do NOT have a webcam nor other USB audio device attached (as that will confuse the YaST installer for sound). Attach the webcam AFTER the install. Also after installing, also install the pulse audio volume control application pavucontrol and run pavucontrol to better tune pulse audio. Note also if you have inconsistent and messed up settings in YaST > Hardware > sound and also inconsistent/messed up settings in KMenu > Configure Desktop > Multimedia > Phonon this will appear a lot more difficult than it actually is.

Apologies - but given what you have done thus far, I have no easy magic solutions.

First of all, thank you, oldcpu, for this detailed advice. Maybe I should really re-install… The silent PC would be a wound for years :frowning:
But besides the extra effort that the re-install would bring there is also a risk consideration: Somehow I fear that my sound might not be set up automatically during the next install. If it needs my interfering, i.e. setting parameters or so, chances are that I will end up with a mess next time as well. Therefore one final question. I do not have web cam or anything that could confuse YaST in sound matters. I only have printer, display, mouse and keyboard. How do you gauge my chances that my sound will be properly recognized and set up if I conduct the 11.4 net-install (as I did last time). Your suspicion that my knowledge is rather limited is quite correct. I therefore need a high probability of an “automatic passage”

Its a real possibility that sound may not work automatically.

I recommend if your PC has the capability, to download a liveCD and boot to the liveCD. That requires no installation. And if your PC has sufficient RAM, then install the application ‘pavucontrol’ (it will ‘install’ into RAM). Then test your sound, using pavucontrol to help you configure the sound. If you can get that to work, you should have confidence that a re-install will work.

And IF you decide to go for a re-install, FIRST, before doing so, try to force a kernel to update to itself (ie re-install ONLY the kernel). ie go to YaST > Software > Software Management, and identify your kernel (it will be kernel-desktop or kerrnel-default). Reselect it in YaST (such that the selection changes from black mark to a green check mark). And let the kernel update to itself. Then restart, and again try to tune your sound , being careful to install the application ‘pavucontrol’ also.

Then if that does not work, but assuming your GNU/Linux still runs (but with no sound) try the alsa update that I quoted : SDB:Alsa-update - openSUSE (again being careful to run ‘pavucontrol’ to try to tune your audio configuration) and if that fails, only then Re-Install openSUSE completely.

ie in my list above, first try Item-2 (force kernel to re-install), then try Item-3 (update alsa), and only then try Item-1 (re-install openSUSE).

The LiveCD trial is a good idea. SDB:Alsa-update - openSUSE sounds intimidating but maybe I am lucky and do not have to do it. I let you know about the outcome in case I decide to go for it … Thank you!

I decided to install 12.1.
Sound was working from the start without my having to do anything.

Great news !