No sound when sony vgn-a690 laptop is in docking station

I recently installed opensuse 11.1 on my laptop and for the most part I am very impressed. There is only one thing holding me back from changing my development platform from windows to Linux. That thing is that there is no sound on my laptop when its in its docking station. The sound does seem to work fine when I’m on battery power.

More specifically, I am testing the sound with:

speaker-test -c2 -l5 -twav

I don’t get any errors, just no sound when powered via the docking station. If I turn the power off (running on batteries),the sound comes back.
I have tried the following options, and none fix the problem.


I restated the sound system between settings by logging in and out. I assume that this worked, although I’m sure there is a better way.

Any help would be greatly appreciated!

Here is the output of alsa-info:

!!ALSA Information Script v 0.4.56
!!Script ran on: Thu Mar 19 03:20:34 UTC 2009
!!Linux Distribution
Welcome to openSUSE 11.1 - Kernel \r (\l). openSUSE 11.1 (i586) LSB_VERSION=“cor
!!Kernel Information
Kernel release:
Operating System: GNU/Linux
Architecture: i686
Processor: i686
SMP Enabled: Yes
!!ALSA Version
Driver version: 1.0.19-git20090317
Library version: 1.0.19
Utilities version: 1.0.19
!!Loaded ALSA modules
!!Sound Servers on this system
Installed - Yes (/usr/bin/pulseaudio)
Running - Yes
ESound Daemon:
Installed - Yes (/usr/bin/esd)
Running - No
!!Soundcards recognised by ALSA
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xfebf8000 irq 16
!!PCI Soundcards installed in the system
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High
Definition Audio Controller (rev 04)
!!Advanced information - PCI Vendor/Device/Susbsystem ID’s
00:1b.0 0403: 8086:2668 (rev 04)
Subsystem: 104d:81cd
!!Loaded sound module options
!!Module: snd_hda_intel
bdl_pos_adj : 1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-
enable : Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y
enable_msi : 0
index : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,
position_fix : 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
power_save : 0
power_save_controller : Y
probe_mask : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-
probe_only : N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N
single_cmd : N
!!HDA-Intel Codec information
Codec: Realtek ALC260
Address: 0
Vendor Id: 0x10ec0260
Subsystem Id: 0x2600000
Revision Id: 0x100300
No Modem Function Group found
Default PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
GPIO: io=4, o=0, i=0, unsolicited=1, wake=0
IO[0]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0
IO[1]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0
IO[2]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0
IO[3]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0
Node 0x02 [Audio Output] wcaps 0x11: Stereo
Converter: stream=0, channel=0
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Node 0x03 [Audio Output] wcaps 0x211: Stereo Digital
Converter: stream=0, channel=0
Digital category: 0x0
rates [0x560]: 44100 48000 96000 192000
bits [0x1e]: 16 20 24 32
formats [0x1]: PCM
Node 0x04 [Audio Input] wcaps 0x10011b: Stereo Amp-In

A couple months later I tried hooking up an external amplifier and speakers using the line out jacks on the back of the docking station. To my surprise, everything worked perfectly. I think the problem only happens when using the built in amp in the docking station. It could also be that an update that I installed fixed the problem, but I don’t recall installing any sound related updates.

I have now officially switched my development platform to Linux and despite a somewhat steep learning curve, I am very happy. My thanks to all the open source developers!

Glad to read you are seeing some success.

Sorry that I could not help with the docking station issue. I don’t have a docking station for my laptop, and I was very reluctant to speculate.