No Sound When Playing Flash

Just coming off of a fresh install, installed the multimedia codecs with one-click and now have no audio when playing flash videos (YouTube, etc) in Firefox and Konqueror.

I can play mp3 and flac files in Amarok ok though.

running this query, I can see it looks like everything is installed:

kenny@linux-9nlb:~> rpm --query --all ‘libav*’ ‘libpostproc*’ ‘libswscale*’ ‘xine’ ‘gst’ MPlayer ‘vlc’ | grep -v avahi | sort

gstreamer-0_10-0.10.24-3.1.i586
gstreamer-0_10-plugins-base-0.10.24-2.4.i586
libavcodec52-0.5.22648svn-0.pm.1.1.i586
libavdevice52-0.5.22648svn-0.pm.1.1.i586
libavformat52-0.5.22648svn-0.pm.1.1.i586
libavutil50-0.5.22648svn-0.pm.1.1.i586
libgstapp-0_10-0-0.10.24-2.4.i586
libgstinterfaces-0_10-0-0.10.24-2.4.i586
libgstreamer-0_10-0-0.10.24-3.1.i586
libpostproc51-0.5.22648svn-0.pm.1.1.i586
libswscale0-0.5.22648svn-0.pm.1.1.i586
libvlc2-1.0.6-9.1.i586
libvlccore2-1.0.6-9.1.i586
libxine1-1.1.18.1-1.pm.37.2.i586
libxine1-codecs-1.1.18.1-1.pm.37.2.i586
libxine1-gnome-vfs-1.1.18.1-1.pm.37.2.i586
libxine1-pulse-1.1.18.1-1.pm.37.2.i586
MPlayer-1.0rc2_r30099-2.pm.6.2.i586
phonon-backend-gstreamer-0_10-4.3.1-3.3.i586
phonon-backend-xine-4.3.1-3.3.i586
vlc-1.0.6-9.1.i586
vlc-gnome-1.0.6-9.1.i586
vlc-noX-1.0.6-9.1.i586
vlc-qt-1.0.6-9.1.i586
xinetd-2.3.14-143.2.i586
xine-ui-0.99.5cvs20091115-0.pm.1.4.i586
kenny@linux-9nlb:~>

Any ideas what I might be missing? (I also checked caf4926’s post for each item and did a search for them manually in Yast and see that all of those packages listed are all installed)

Problem solved - the mixer levels were at the max except for the PCM slider, which had the volume was at 0.

Overlooked the simplest thing

The first thing I note is you have mixed rpms from the videolan repository with the packman repository. The packagers of those two repositories package their codecs into different locations, and its quite common that the application of one of those repositories will not play with codecs provided by the other.

To avoid a conflict, it behooves openSUSE users to just select one of those repositories.

Since packman is the largest 3rd party repository , my recommendation is you remove the videolan repository from your software package manager’s list of repositories, and replace every videolan packaged app that you have installed with a packman packaged application (exception is libdvdcss rpm). That is EASY to do if one goes to YaST > Software > Software Manager.

Next, assuming you are using openSUSE-11.2, problems with flash are typically because

  • PCM volume was dynamically set to zero volume when flash started, and one needs to move the volume back up, or
  • one has multiple sound devices recognized in YaST > Hardware > Sound and flash is attempting to play the audio with an inappropriate sound device. For example, in KDE one needs to go the Kickoff Application Launcher > Configure Desktop > Multimedia and ensure the output device preference is consistent with what is correctly functioning in YaST,
  • in Firefox go to Edit > Preferences > Applications > Shockwave Flash File and change to “Use Flash Player (default)”.

Note for new and average users I recommend one set up their software package manager with 4 and ONLY 4 software repositories. These are the 3 official repositories OSS, Non-OSS, and Update and the largest 3rd party repository Packman. Just those 4. No others. None. There is guidance here for setting those up: Repositories/11.2 - openSUSE-Community OSS, Non-OSS, and Update should already be setup. Simply add Packman. And disable or remove all others. Stick with the 4 I mentioned. IF for some reason you MUST install an application from a 5th repository, then add the repository, install the application, and then remove or disable the 5th repository. I recommend the 1 click install NOT be used.

Again: ONLY OSS, Non-OSS, Update and Packman.

Good luck.

Well done in sorting it. I was still busy typing possible solutions while you sorted this.

I still think you should sort your repositories as you WILL IMHO have other problems until you do this.