No sound whatsoever on 13.1 KDE

Hi guys. I am having a problem with audio lately. Everything was going peachy but now nothing plays. I have tried to run KMix but it doesn’t open for whatever reason.

My laptop is a Gateway NV51 and runs FGLRX drivers, maybe that’s the problem.

KMix should be started automatically when you login.
And if you start it when it is already running, nothing happens.

Click on the icon in the system tray to open it.
Or if you don’t have that, kill kmix before you start it, maybe it is hanging.

To your actual problem, I take it you are using PulseAudio, right?
Try the following:

  • remove the folder ~/.config/pulse/, and reconfigure your pulseaudio settings (output device f.e.) in KDE’s audio settings or pavucontrol.
  • switch off PulseAudio as a test in YaST->Hardware->Sound->Other->PulseAudio Configuration and logout/reboot.

Do you get a test sound in YaST?

Nix klingt! No test sound, so I’m gonna try the nuclear option you suggest.

When this happens, what is showing in KDE’s System Settings > Multimedia > Audio settings, in the Device Preferences’ right hand panel?

BTW, for unknown reason my KMix failed to start on KDE startup this evening (has happened at least once before), but it started ok manually. I checked my system settings, and when this happens it unusually shows “PulseAudio Sound Server”, so my audio device wasn’t fully opened by KDE P/A support as normal. However I still have sound, tested via the “Audio Hardware Setup” tab, but also I had to switch “Connector” setting to Speakers.

Still, no sound. Maybe the drivers are broken, or something.

It shows a list of things:

-HDA ATI SB (CX20584 Analog)
-HD-Audio Generic HDMI 0 (HDMI Audio Output)
-PulseAudio Sound Server
-HDA ATI SB, CX20584 Analog (Default udio Device)

What should show?

IIRC it normally has a single “Internal Audio …” listing i.e. just a single line. Are any of your hardware listings above actually greyed-out (indicates not active)?

PS. It might show “Built-in Audio Analog Stereo” normally.

Run this command in terminal (normal user):

pacmd list-sinks | grep device.description

What do you get reported?

Here it is:

device.description = "Built-in Audio Digital Stereo (HDMI)"
                device.description = "Built-in Audio Analog Stereo"

Thing is, it plays audio on headphones now, and on HDMI it plays from VLC or Kaffeine, but not from web streaming videos.

P.S. Besides, now when changing volume with hardware keys it jumps by 4%, while it has always done it by 5%. This is so broken I’m tempted to wipe my openSUSE partition clean and start all over anew.

I am in complete panic now. I want to reset EVERYTHING sound-related to its default configuration and then start building from there. As luck would have it I fear that’s not even remotely possible.

EDIT: As mysteriously as everything broke, now everything works fine.

Thank you all for your advice, I’ll be here scratching my head until it hurts. Maybe a set of new updates could be responsible?

Ok, normally that pacmd output (looks ok) should cross-reference with the device settings list in System Settings > Multimedia.

You didn’t reply to my question re “greyed-out” entries in System Settings. Did you notice any?

What release of KDE are you on (4.13?)? My comments above refer to occasional issue on Tumbleweed system at KDE 4.12.4, but I will later double check my standard system (not at 4.13). :slight_smile:

No, nothing greyed-out, that was something frustrating.

And yes, I am on 4.13, and no Tumbleweed, decided to stick to 13.1 (although I do have added the kernel repo to upgrade to 3.14).

Just a note

Reinstalling the OS is a Windows idea. You truly have to mess things up royally to really have to reinstall the OS.

My standard 13.1 system has this: a single listing of “Built-in Audio Analog Stereo” in Multimedia Settings > Device Preference, and usually that on Tumbleweed. That’s fairly standard for most devices, mine being integrated Intel audio chip with HDMI although not connected and never listed with the KDE’s P/A support. Your listing might be a bit different. However what you see there doesn’t look right. I noticed another problem on leaving my Tumbleweed system which usually accompanies the P/A and KMix failure:

The usual reboot or shutdown via the “Leave” entry of the desktop’s context menu (right-click) does nothing when I have the issue with audio. I get round it with ctl-alt-F1 (to get a console), followed by a ctl-alt-del to reboot or power-off.

This failure seems to coincide with me occasionally trying to access the KDE desktop too early during startup, and before KMix opens in the system tray (usually the last addition to the desktop). I’m thinking that this problem arose with systend’s appearance, and I also first noticed it on 12.2 with KDE. IIRC there was some advice given in the forum to wait until the desktop had completely initialized as systemd is still involved meeting its targets during KDE startup.

I don’t think it’s specific to kernel versions, or KDE releases since 12.2 standard where it was more prone to the issue with its slower startup, and this is the first time I’ve caught it on Tumbleweed (13.1).

Sounds to me there is a mix up in the preferred devices set in the kde system settings and in kmix

True, it’s just that old habits die hard. Nonetheless I am lately avoiding Windows as much as I can to get into the Linux mindset ASAP.

Yes, or there was since now everything is working all right.

In the sense that KDE’s PulseAudio initialization failed to complete. The “Audio and Video Settings” tab only allows the user to verify completeness, and to prefer/defer devices where more than one device has been opened.

In my case a restart and patience usually fixes it.

As we discussed earlier it shouldn’t show that, in particular the line shown in red “PulseAudio Sound Server”, and I’ve now found an old note about that. It might be useful if the problem occurs again.

If “PulseAudio Sound Server” is listed in KDE’s System Settings > Multimedia > Audio and Video Settings, then KDE’s support module (module-device-manager) for PulseAudio didn’t get loaded on startup. It can be started by running the script “start-pulseaudio-kde”.

I see the script at /usr/bin/start-pulseaudio-kde, so will try it later if/when I can reproduce the issue with that listing and KMix failing to open in system tray.

Since this issue recently re-occurred (read back for details), on my standard 13.1 system, I was able to test running that script in Konsole as normal user (running PulseAudio as root is never recommended):


It worked instantly, resulting in the correct “Built-in Audio Analog Stereo” listing in System Settings > Multimedia > Audio…, and I then just needed to start up KMix.

Not surprisingly, this didn’t repair the failing “Leave” entry in the context menu (right-click desktop) which I mentioned previously.