No sound what so ever in opensuse 12.1 need help

i just upgraded from 11.4 of which the sound worked after the upgrade to 12.1 i get not sound what so ever

Toshiba Satellite a100-976 audio (REALTEC ALC861) is the sound card according to yast on this laptop !

You ought to mention if this is in kde or gnome

Try installing pulse audio volume control (pavucontrol) and use that to tune each applications audio output/playback.

Toshiba Satellite kde 4.7.2 3gb ram

i installed pulse audio volume control, turned everything up and still no sound

Check that the Master volume slider in Yast > Hardware > Sound > other/volume
Is set to at least 70%

In KDE you may also need to check the System Settings > Hardware > Multimedia > Phonon > Device Preference
Especially if you have more than one audio device, as you may have to set the prefer device here

Another openSUSE-12.1 user with an ALC861 had a problem with sound, and in their case they stated the only solution for them was to install a non-standard kernel ! Thread is here:

I do not recommend that approach, unless all else fails. Instead, I recommend you:

  • first try forcing alsa sound driver into a specific configuration upon boot using a model option, and if that fails
  • second try to change the alsa sound driver kernel module using an update from alsa from the SuSE-GmbH sound packagers openSUSE multimedia repository

BEFORE starting, I recommend you run a sound diagnostic script, so as to establish a baseline of your audio configuration that existed when sound does NOT work:


and select the SHARE/UPLOAD option and make a note of the website/url address you are provided that points to where your PC’s sound configuration is located.

then …

FIRST - Try a model option

The model options for the ALC861 , as indicted in the HD-Audio-Models.txt file that is on your hard drive ( /usr/src/your-kernel-version/Documentation/sound/alsa> ) are:

  3stack	3-jack
  3stack-dig	3-jack with SPDIF OUT
  6stack-dig	6-jack with SPDIF OUT
  3stack-660	3-jack (for ALC660VD)
  3stack-660-digout 3-jack with SPDIF OUT (for ALC660VD)
  lenovo	Lenovo 3000 C200
  dallas	Dallas laptops
  hp		HP TX1000
  asus-v1s	ASUS V1Sn
  auto		auto-config reading BIOS (default)

and I recommend you try those model options one-by-one (ie one at a time, with a PC restart in between each) to see which one works. You can apply each option by an appropriate edit to the /etc/modprobe.d/50-sound.conf file, save the change and restart. Lets say you were trying the model option ‘auto’. To do that add to the /etc/modprobe.d/50-sound.conf file the following line at the start of the file:

options snd-hda-intel model=auto

save and restart and test. If ‘auto’ does not work, then replace ‘auto’ with another option from the list, restart and test, trying each in return until you hopefully find one that works.

Now, if none of the options work, then remove the line you added to the /etc/modprobe.d/50-sound.conf file, and try the second approach

SECOND approach - update your PCs alsa.

Follow the guide here: SDB:Alsa-update - openSUSE to update your PCs alsa rpm versions, your libasound2 version, and also install the appropriate KMP packaged for your PCs kernel. Only ONE kmp package should be installed ie do NOT deviate from those instructions. And be careful you actually do update the alsa versions, as many users do not update alsa as they ignore the guide’s suggestions as to how the update can be done. After updating, restart and test.

  1. Why does sound not default to being on?
  2. “at least 70%”? Isn’t there a better recommendation? 100% (nope, there’s static in the background. You must want 90%).

I know I am snarky and naive, but you know I really do not think it should be necessary for me a technologically sophisticated geek just to get my sound to work. This 12.1 thingy got especially fun when the network configuration decided it would not get DNS server addresses from my router any more. Dang! With 11.4 I thought the install process was getting better. OK. I feel better with that off my chest. My “Card Model” was M2N72-D – an NVidia thingy that is abhorrent in the Linux world. It uses the Intel driver and all is well, now that I know that the sound card settings were reset to silent with the upgrade.

bkorb, … please … we are unpaid volunteer enthusiasts who do NOT develope nor package openSUSE, trying our very best to help a user here.

Please don’t make our unpaid volunteer support efforts more difficult than they already are by cluttering the thread with a rant.

There is a Soapbox forum here: General Chit-Chat

hi there from germany, actually iam a newbie to linux but i think have the answer to your problem

ok someone called lody solved the problem here :slight_smile:

ihave a toshiba satellite A100-773, with the same sound chip ALC861, with open suse 12.1 and gnome

now i updated th kernel to 3.1.9 ! everything works fine, especially the sound :smiley:

so thanks lody