no sound via HDMI

Hi I am new to opensuse. I am trying to get sound through my tv plugged into my graphics card but I’m not getting any sound.

I’m using opessuse 12.3

My system is
AMD Sempron 145 Processor

4GB DDR3 1333Mhz Memory

GIGABYTE 760G Chipset Motherboard

New Vertex 2 SATA II 2.5" 100GB Solid State Hard Drive
EVGA GeForce 210 1GB GDDR3

I have followed the instructions at

When this didn’t work with the default drivers for NVIDA I installed, For all NVIDIA recent cards (GeForce 6 and GeForce 7) via the one click install function from here

Does anyone have any ideas how i can resolve this please.

Many thanks


I spent quite a bit of time working getting audio to my HDMI TV about a year and a half ago. This thread summarizes my trials, tribulations and eventual success. Unfortunately I no longer own that PC, so I won’t be able to help further.

PS, welcome aboard

Having a search around, it seems that other people have also had a problem getting sound working through this card. The issue basically seems to be that by default it’s using the wrong driver which is not able to output sound. I found information at and HOW-TO:Setup HDMI audio on GeForce GT210, GT220, or GT240 - XBMC

The suggestion seems to be to edit /etc/modprobe.d/50-sound.conf and add a line like

options snd-hda-intel probe_mask=2

to the end of it. If (upon testing after a restart) it doesn’t work, you could try some of the other options from HOW-TO:Setup HDMI audio on GeForce GT210, GT220, or GT240 - XBMC instead.

Since you’re using PulseAudio they also suggest to add

load-module module-alsa-sink device=hw:1,3

to /etc/pulse/[FONT=arial] as mentioned in [/FONT],_GT220,_or_GT240#PulseAudio_Configuration

After that reboot and check if sound works.

Other people seem to have had luck with this method so hopefully it’ll get you somewhere. If it doesn’t work let us know and we’ll try something else. If it does work, let us know so that other hitting this problem know of a fix.


Try using multiple sound
See this link

Well its not very neat but I have sound.

I went into Yast/ sound configuration and hilighted the sound card on my motherboard and clicked delete.

I then added the line of code

options snd-hda-intel probe_mask=2

So it reads

options snd slots=snd-hda-intel
options snd-hda-intel probe_mask=2

NXNs.OkLMKP6gnjA:nVidia Corporation

alias snd-card-0 snd-hda-intel

at the second line not the bottom and now i Have sound out the tv. then i had to go into VLC settings to make it work there

Well I have now done a fresh install to get rid off all the earlier hashing about. Having done this i have opened up Yast/Hardware/sound then then set nVidia corpration as Primary card so it shows the Index number as 0

having done this I have followed the direction from Milliams

The suggestion seems to be to edit /etc/modprobe.d/50-sound.conf and add a line like Code:
options snd-hda-intel probe_mask=2

however I have added it as line 2 not at the end

options snd slots=snd-hda-intel,snd-hda-intel
options snd-hda-intel probe_mask=2
# 5Dex.9zCmC9gVD38:SBx00 Azalia (Intel HDA)
alias snd-card-1 snd-hda-intel
# NXNs.OkLMKP6gnjA:nVidia Corporation
alias snd-card-0 snd-hda-intel

And now i Have sound working properly everywhere.

Thanks for the help everyone.

Fantastic. I’m glad you got it working. Sometime, when messing around with things like this, it is indeed best to do a clean install so you can be sure what you’re doing.