No Sound Using HDMI Cable TO HDTV

Hi All,

I’ve just come over from Linux Mint 12 KDE to openSuSE 12.1. The reason I dropped Mint was that the ATI/AMD drivers that were provided gave me display issues and although I could port my desktop to my HDTV using a HDMI cable there was no audio. This is a known issue and the recommendation was to download another ](http://community.linuxmint.com/tutorial/view/767) driver, which I did. This worked at least for a short while and I could get audio ported to my HDTV. However, this was a fix that did not work well. Again, I had display issues and apps began to freeze.

What I did do in Mint was to alter my sound settings to direct audio to HDMI output.

This might be a simple fix, if I could find where I might be able to direct audio output to HDMI. Or, do I need to find another driver? I should mention I can get video ported to my TV just like with Mint. But, again no audio.

Any assistance would be greatly appreciated!

A general recommendation for kde users ( at least by our sound guru @oldcpu ) is to use pavucontrol

His general guide is here
SDB:Audio troubleshooting - openSUSE

I should add. I don’t use it
But my audio setup is uncomplicated and just works.
kmix does all I need.

I’m not suggesting pavucontrol will solve your problem, but it may be a step in the right direction.

caf4926,

I do have sound on my Notebook PC. Problem is getting my sound ported to my HDTV via HDMI cable. I’ll go through the sound guru’s article.

Thanks for your response.

I am using HDMI with Nvidia and I have to configure it in /etc/pulse/default.pa to make the sound work
I am not sure if it work the same with ATI cards.

While waiting for the sound gurus why not post your output with the commands:

aplay -l
aplay -L

conram,

Thanks for the post,

Per your suggestion:

ey@linux-5zoo:~> su -
Password:
linux-5zoo:~ # aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: STAC92xx Digital [STAC92xx Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
linux-5zoo:~ #
linux-5zoo:~ #
linux-5zoo:~ # aplay -L
null
Discard all samples (playback) or generate zero samples (capture)
default
Default ALSA Output (currently PulseAudio Sound Server)
sysdefault:CARD=SB
HDA ATI SB, STAC92xx Analog
Default Audio Device
front:CARD=SB,DEV=0
HDA ATI SB, STAC92xx Analog
Front speakers
surround40:CARD=SB,DEV=0
HDA ATI SB, STAC92xx Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=SB,DEV=0
HDA ATI SB, STAC92xx Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=SB,DEV=0
HDA ATI SB, STAC92xx Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=SB,DEV=0
HDA ATI SB, STAC92xx Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=SB,DEV=0
HDA ATI SB, STAC92xx Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=SB,DEV=0
HDA ATI SB, STAC92xx Digital
IEC958 (S/PDIF) Digital Audio Output
hdmi:CARD=HDMI,DEV=0
HDA ATI HDMI, HDMI 0
HDMI Audio Output
linux-5zoo:~ #

Looks like pulseaudio failed to start in your sound setting
Looking at this:

Default ALSA Output (currently PulseAudio Sound Server)

When pulseaudio failed to load several times on my machine I usually just delete
my /home/user/.pulse and restart x.

Looking at your aplay -l this is your HDMI

card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]

We will attempt to have a simultaneous output from both of your sound controllers
meaning both sounds from your devices will have an ouput sound to their respective speakers.
We will try to add it in your /etc/pulse/default.pa as su like this:

### Load HDMI device
load-module module-alsa-sink device=hw:1,3
load-module module-combine sink_name=combined
set-default-sink combined

After the changes reboot your system and keep your fingers cross.
This is how I always do on my machine but take note it is an nvidia card.
So I am not really sure if it will work.

Note:
If you haven’t installed the pavucontrol, please do so because it is the
place where it is easy to figure your sound config.
Please have a look also if all the pulseaudio requirements are already installed
on your machine.

Lastly you can run aplay command without being su

Edit:

Play with this two when you modify the default.pa
load-module module-alsa-sink device=hw:1,3
load-module module-alsa-sink device=hw:0,3

conram,

I have been digging around the Forum myself and ran across the quote below from here.

Pulse Audio Volume Control

Since openSUSE-11.4 KDE has had pulse audio installed and active by default. Gnome has had pulse audio even before then. In such a case, it can be useful for KDE users to install the application pulse audio volume control (pavucontrol) and use that application to tune one’s audio for each multimedia application. Gnome users may find pauvcontrol installed already by default. LXDE users will find they will first need to install pulse audio (as pulse audio was not automatically installed in LXDE as of openSUSE-12.1 and earlier) and only then install pavucontrol.

On openSUSE-11.4 and newer, to install pavucontrol, type “su” (without quotes) followed by root password to get root permissions in a konsole/xterm, and then to install pavucontrol type:
zypper in pavucontrol

then after it is installed, type “exit” to get rid of root permissions, and then to run pavucontrol, just type “pavucontrol”. The 1st time you run each application, tune pulse audio for that application, ensuring you have the each application tuned to use the correct audio device.

I have installed pavucontrol and running the app I have this as Audio Output:

ImageShack - Best place for all of your image hosting and image sharing needs](ImageShack - snapshot3ln.png)

As you can see both my internal and HDMI outputs are muted. This is not the case with my internal PC speakers. I do get sound.

Thanks for the guidance so far. Any more suggestions? BTW, thanks for your post.

As you can see both my internal and HDMI outputs are muted. This is not the case with my internal PC speakers. I do get sound.

Maybe this blog on the same topic will help

How to make PulseAudio work with Nvidia HDMI audio outputs under Fedora and Ubuntu | piggott.me.uk

As conram mentioned, you may need to edit /etc/pulse/default.pa (as also outlined in the blog) with the appropriate ‘load-module module-alsa-sink device=hw:1,…’ entries specific to your HDMI devices.

deano_ferrari,

Thanks for the post. I’ll read the article, but I should mention that I run ATI/AMD.

There is a nice mixer also that you can use it is the xfce4-mixer.
I find it easier even to turn on the muted analog and digital signals.
See my screenshot.
ImageShack® - Online Photo and Video Hosting

conram,

Thanks! I did the xfce4-mixer install and played with it. Now, I’ve lost video to my HDTV. I’ll play again tomorrow.

Hi All,

Following in the foot steps of greater minds than mine I decided to do a fresh install. I have been running .deb distros for about 6 - 7 years and always with GNOME. Now I am using KDE. So, I may have scrambled a few too many eggs if you know what I mean. LOL!

I can now port video to my HDTV through my HDMI cable, but still no audio.

I have several tools available to me, but still don’t know what switch to flip.

http://img823.imageshack.us/img823/6056/snapshot1nj.th.png](http://imageshack.us/photo/my-images/823/snapshot1nj.png/).

I am not sure if I am running the New ATI Video Driver which Supports openSUSE 12.1. Before I left the latest Linux Mint 12 I did an install of the latest drivers per recommendations. But, this proved to be a mess. I did have both audio and video ported to my HDTV, but my pc display started to act up and apps began to freeze. Hence, I came back to SuSE, which I ran years ago.

Any recommendations would be appreciated. Thanks in advance for any responses.

Re: ATI

You might want to look at this
http://forums.opensuse.org/content/46-ati-driver-atiupgrade.html

I’ve used Mint and it’s a fantastic distro which manages well hardware drivers etc…
And your trouble there, IMO, begs the question: ‘Is distro hoping the solution?’
I don’t mean you are not welcome here… you most certainly are.

Hi Adler,
Good to see you back using openSUSE.
Try going to yast sound and make your HDMI as default if there is an option.
In your xfce4-mixer hit the select control and check all the controls that is visible
While in that mixer in the sound card option click the alsa mixer and under switches
check all the the box. You may need to reboot.

Play an audio and checkout the configuration, playback and output devices in pavucontrol.

You should check the settings in ‘system settings’ > Multimedia > Phonon
And check all the device prefs in all the audio and areas

You should check the settings in ‘system settings’ > Multimedia > Phonon

caf4926,

If ignorance is bliss I am one happy puppy. How do I do as you suggest? I’ve been searching on my own, but no luck.

I am probably getting closer to resolving this than I think. That for your help so far.

Play this in smplayer or vlc
http://dl.dropbox.com/u/10573557/audio_prefs_kde.mkv

caf4926,

What I realized is the I’d forgotten to install VLC and needed to add some repositories. In the past I’ve used the excellent tutorials from HowtoForge. And to get VLC, as well as, other apps I used the how to here. However, it is for GNOME and I use KDE. No big deal in getting done what I needed to install.

I did use VLC to view the .mkv file you sent, but could not drill down the way you could because you - I assume - are using the GNOME Desktop. So at this point I am still stuck with no audio ported to my HDTV. Video I am able to get. I have been looking at bug reports concerning sound and KDE and it seems fortunate that I do get sound on my PC. LOL! I will keep looking for possible solutions at this end. But, if you can think of something else please pass it along. Thanks in advance and I am grateful for the assistance that you have provided so far.

I’m using kde
Multimedia I recommend is here
http://forums.opensuse.org/content/107-re-multi-media-restricted-format-installation-guide.html