No sound under wine

openSUSE 11.2 32 & 64bit
default repos + packman, nvidia
wine v 1.1.28 (default)

I was completely shocked to find that the new Wolfenstein demo works perfectly under this version of wine, but sadly I get no sound.

winecfg doesn’t play any sounds, just a faint humming sound when testing, and I get the same thing when playing the demo.

I’ve had the problem of sound sharing on this system with each install I do, and I’ve installed/re-installed many many times so far.

Anyone else have no sound under wine?

Thanks.

run winecfg
and check alsa is selected under audio

Never mind, it started working!

I changed the “dsound” lib to use “native, then built in”, and also turned off desktop compositing before entering the game, and it gave me sound this time.

Not sure which one worked, but I’m too scared to fiddle with it again in fear of it messing up.

It also seems that the test sound in winecfg is rather odd, it just sounds like a faint hum, not an actual sound at all!

I had a bit of a similar problem but then the “other way around” : Several (but not all) games are having hums and chunks with alsa, and when changing from alsa to oss in winecfg, my sound volume master control was put down to 0%. When I opened the game in a window (so that I could change the sound volume while playing the game) I changed this to 70% many times but it kept shutting down the volume to 0% after a few seconds of sound. So no damaged ears as you described but the opposite silence.
The sound test gave the same weird humming and many times wincfg just froze after clicking that button.
On the Internet I found that this could be related to pulse audio and there is some thingie called winepulse under development.

I tried to downgrade and upgrade wine in several reinstalls but that did n’ t work.
Then your remark about dsound set me on the right trail, because I fiddled with every option in winecfg, but this one. It’s now set on emulation and now the sound is as rock solid I was used to be.
Thanx!

edit: I use KDE desktop compositing and on my system that seems not to be a cause.

My system:
opensuse 11.2, kde 4.3, wine 1.139

Alsa is selected but still no sound.

Tried that too. Still no soud
d. Trying to play Tom Clancy’s Hawx. Problem Playing Tom Clancy’s Hawx under wine-1.3.29

Wine only supports alsa; if you have pulseaudio disable it (personally i had remove it) and since your sistem is under 64 bits try to install alsa libs for 32 bits, alsa-plugins both 64 and 32 bits libs as well(wine needs 32 bits libs). Here is what i have(again pulseaudio is removed) but not some pulse libs.

  1. alsa and alsa libs ImageShack® - Online Photo and Video Hosting
  2. pulseaudio libs ImageShack® - Online Photo and Video Hosting
    That is my sound configuration and i works well.

I followed your configuration but it didn’t work. As it is no sound in the game. But THANKS.

Got the same problem but with Spotify. But interestingly when I put winecfg in the terminal, before actually opening the configuration this reading comes out:

err : mmdevapi : DllGetClassObject Driver initialization failed
err : ole : apartment_getclassobject DllGetClassObject returned error 0x80004005
err : ole : CoGetClassObject no class object {bcde0395-e52f-467c-8e3d-c4579291692e} could be created for context 0x1

???