No sound through Headphone output


I have an Asus laptop (A6Va) with an Intel Sound Card.

The sound card works well with the snd-hda-intel driver.

When I plug a headset in the headphone jack output the sound from the built-in speakers is muted but there is no sound into the headset.

I manage to get sound through the headset with this :
In Yast sound configuration :

  • I edit the sound card line
  • Set “auto” in the “model” option (previously empty)
  • Then I press “Next”
  • I reboot the sound system (choose “Yes” to the question I was asked)

At this stage the jack output works well

But if I press “Finish” (to save the parameters I just set) the problems come back ! (and when I came back to the Yast Configuration Panel the “auto” parameter I just set is gone…)

What’s the matter ? What do I do wrong ?

Thanks for your help

PS: excuse my poor English, I’m French
PPS: I use OpenSUSE 11.0

This is a bug in Yast, you have to add a line to /etc/modules.d/sound by hand:

open a konsole and enter:

su (and give root password)
echo "options snd-hda-intel model=auto" >> /etc/modules.d/sound
rcalsasound restart

after that (if you’re using KDE) press alt+F2 and enter “KMix” to restart the mixer tray applet.

It’s working well, thanks !

I come from Ubuntu and I found that a gui to solve this (recurrent) problem on my laptop was a good + for OpenSUSE… but unfortunately it was buggy… Hope this bug will be solved soon !

Sorry to revive such an old thread, but I figured it was better than starting another one on the same topic.

I have the same problem, but following the above steps don’t help. For some reason, the directory /etc/modules.d doesn’t exist on my system (the equivalent directory, as far as I can tell, is /etc/modprobe.d), but manually adding the line to /etc/modprobe.d/sound has no effect.

Can anyone help me out?

You need to be sure of your model before adding any module parameters. From a console, execute these commands:

cat /etc/modprobe.d/sound
hwinfo --sound (you need to be root to execute this one)

Copy/paste output here if you need more help.

Did you hand edit the file as root?

I tried going through YaST first, but it still has that bug in it, so yes, I edited it manually as root. The changes show up in YaST, as expected, but the problem’s still there.

cat /etc/modprobe.d/sound returns:

options snd slots=snd-hda-intel
# GA8e.OxOKbkWU0j9:VIA High Definition Audio Controller
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=auto

The fourth line was what I added in, per the instructions above.

hwinfo --sound returns:

09: PCI 201.0: 0403 Audio device                                
  [Created at pci.310]
  UDI: /org/freedesktop/Hal/devices/pci_1106_3288
  Unique ID: GA8e.OxOKbkWU0j9
  Parent ID: HSco.OEBK5K+PTbB
  SysFS ID: /devices/pci0000:00/0000:00:13.0/0000:02:01.0
  SysFS BusID: 0000:02:01.0
  Hardware Class: sound
  Model: "VIA High Definition Audio Controller"
  Vendor: pci 0x1106 "VIA Technologies, Inc."
  Device: pci 0x3288 "VIA High Definition Audio Controller"
  SubVendor: pci 0x1509 "FIRST INTERNATIONAL Computer Inc"
  SubDevice: pci 0x2f07 
  Revision: 0x10
  Driver: "HDA Intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xd1000000-0xd1003fff (rw,non-prefetchable)
  IRQ: 17 (19674 events)
  Module Alias: "pci:v00001106d00003288sv00001509sd00002F07bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #12 (PCI bridge)

Replacing “auto” with the model name listed by hwinfo doesn’t work either, if that’s what I’m supposed to pick up on. This is embarrassing…

I too do not have an /etc/modules.d directory. Makes me think its a typo.

I also confess this is the first I’ve read of putting “rcalsasound restart” in the /etc/modprobe.d/sound file. If rcalsasound restart helps, then the place I typically recommend for it is in the /etc/init.d/boot.local file.

I also find “hwinfo --sound” falls short of providing the information I like to have when helping a user with their sound. … I like to know

  • mixer settings
  • kernel information
  • opensuse version information
  • hardware audio codec information
  • various software configuration information
    … and I find the easiest way to get that is to run either of the scripts from here: openSUSE - Scripts_to_run_to_obtain_detailed_information on sound
    … I think its possible the script may even find its way to be included with future versions of alsa.

Anyway, I would like to try help here (if moving the location of “rcalsasound restart” doesn’t help), but can you please run this tsalsa script (with your PC connected to the internet copy and paste this line into an xterm/konsole):

wget && su -c 'bash ./tsalsa' 

when it prompts for a password, enter the root password. When it is complete, it will also give you a URL. Please post that URL here.

… please also provide output of running the following one line at a time in an xterm/konsole:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2

are you a KDE4, KDE-3.5x, or Gnome user?

I also confess this is the first I’ve read of putting “rcalsasound restart” in the /etc/modprobe.d/sound file. If rcalsasound restart helps, then the place I typically recommend for it is in the /etc/init.d/boot.local file.

I don’t think anyone suggested this. The following was suggested a few posts back:

su (and give root password)
echo “options snd-hda-intel model=auto” >> /etc/modules.d/sound
rcalsasound restart

True, but never-the-less, the way I read this thread, it was attempted! :eek: I also am not aware of an /etc/modules.d directory on openSUSE-10.3 nor 11.0.

I only have KDE, is this Gnome specific? or is it a typo? we all make typos ]

Sorry, this was my fault.

Correct is this:

su (and give root password)
echo "options snd-hda-intel model=auto" >> /etc/modprobe.d/sound
rcalsasound restart

Um, I don’t remember saying I ever tried to do that…

Guess I forgot to post the basics, though, sorry. openSUSE 11.0 w/ GNOME, running on an Everex CloudBook (standard hardware, no mods).

The tsalsa script returned the URL: tsalsa.txt - (beta)

rpm -qa | grep alsa returned:


rpm -qa | grep pulse returned:


rpm -q libasound2 returned:


Reading back over the thread it was me misreading. I’m bad. :o

This could be difficult to crack. Your PC has a VT1708 hardware audio codec. It is not listed in the ALSA-Configuration.txt for 1.0.16 of alsa, hence I do NOT think the line in your /etc/modprobe.d/sound with “model=auto” will help. I think it best to remove that for now.

I do note there is an update for the VT1708 in the latest update to alsa:
Search results for vt1708 - AlsaProject

so I recommend you try updating your alsa by sending the following 6 commands in sequence, from an xterm with your PC connected to the Internet. Type “su” first to get root permissions:

zypper ar multimedia
zypper install alsa alsa-utils alsa-oss alsa-tools alsa-firmware alsa-plugins libasound2
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-default
zypper rr multimedia

Then restart your PC and test your audio (check your mixer).

If that doesn’t work, then you probably could try to try updating your pulse audio to see if that has any improvement. There are many updates to pulse audio available, and I can walk you thru that if need be. But I don’t think that will help.

I’ve tried before and failed in helping users with a VT1708:
Headphone Jack Not Working - openSUSE Forums

From what I can see, you probably should write a bug report on this. I noticed some ubuntu users got this to work by a custom hack to alsa source code, and then they did a custom recompile.
Ubuntu 7.04 on Amilo Li 1705 problem [Archive] - Ubuntu Forums
rather than propogate that situation, it would be more useful for the Linux community if users would write a bug report, to get this fixed.

Alsa bug reports:
opensuse bug reports: Submitting Bug Reports - openSUSE

I have one Toshiba Satellite A135 and this help me. But my volume is low compared with win-xp… I rised up the volume in Kmix, but not help me…
any solution?

— sorry for my english — im learning in tellme more online site …

You may need to check that master channel is set correctly (via kmix) and that PCM and Front sliders are all up.

@kokipinto: according to other users from other forums, the right model for the Satellite A135 is “3stack” instead of “auto”. Please give this a try, but not with the code i’ve given before, it would just add another Line, you have to change the value by hand, e.g. with ‘sudo vi /etc/modprobe.d/sound’.

For the volume: First try it with with ‘alsamixer’, this shows all channels. Then be sure to unhide all Channels in Kmix - it hides some even by default for me…
For me, i have two “front” channels, one’s hidden by default, the other one does nothing, and the hidden one is master…
Even there is a headphone-switch (no volume slider, just a switch), which mutes my internal speakers…

Hope this helps, good luck

Btw.: I’m wondering, that model=auto have any effect, according to /usr/src/linux/Documentation/sound/alsa/ALSA-Configuration.txt, this is the default behavior of the driver…

My memory is vague on this, but someone ?? reported there was a bug report raised on openSUSE-11.0 alsa, that it was not applying the default “auto” setting, when it was supposed to, and hence the “auto” fix was working for cases where “auto” was a valid ALSA-Configuration.txt entry. I did not independantly verify this claim myself, although I have read of some users reporting that the application of “options snd-their-sound-module model=auto” (in their /etc/modprobe.d/sound file) worked for them.

Further to what user terwarf and deano_ferrari there was a thread here trying to help a Toshiba A135 user (in the archives):
Headphone Problem - openSUSE Forums

However the user never responded in the thread to the more recent recommendations, as to their success, nor to their lack of success.