No Sound through HDMI, NVidia proprietary drivers installed

I hate to rehash this, but I have gone through countless threads and done many things, but to no avail.

So here are my system specs:

CPU - Intel Atom D525 1.8
Memory - 4Gb
Chipset - Intel NM10 Express
Onboard Graphics - Next Generation NVidia ION 512 MB DDR3

Looks like this:

aplay -l

media-box@linux-h9ia:~> aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

aplay -L

media-box@linux-h9ia:~> aplay -L
    Discard all samples (playback) or generate zero samples (capture)
    Default ALSA Output (currently PulseAudio Sound Server)
    HDA Intel, ALC892 Analog
    Default Audio Device
    HDA Intel, ALC892 Analog
    Front speakers
    HDA Intel, ALC892 Analog
    4.0 Surround output to Front and Rear speakers
    HDA Intel, ALC892 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
    HDA Intel, ALC892 Analog
    5.0 Surround output to Front, Center and Rear speakers
    HDA Intel, ALC892 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    HDA Intel, ALC892 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    HDA Intel, ALC892 Digital
    IEC958 (S/PDIF) Digital Audio Output
    HDA NVidia, HDMI 0
    HDMI Audio Output
    HDA NVidia, HDMI 0
    HDMI Audio Output
    HDA NVidia, HDMI 0
    HDMI Audio Output
    HDA NVidia, HDMI 0
    HDMI Audio Output

This DOES produce sound:

speaker-test -c2 -D plughw:1,7

I have installed the proprietary NVidia driver.

I have deleted the other card in YaST > Sound and set my NVidia card to default.

I have deleted the other card in YaST > Sound and set my NVidia card to default.

After you ran aplay -x? The output suggests that NVIDIA is still second.

Also, supply what desktop environment you use, KDE, GNOME etc. and if you use Pulseaudio, pavucontrol and so on; might be useful.

Sorry, did not pay attention to what system this was: ‘Looks like this:

Do you use any DE with this?

Currently it is running LXDE. I have pulse audio installed, but pavucontrol can’t connect to it, so I will probably uninstall it tonight.

All of my YaST work (setting the NVidia to default) was done before running aplay. I know it displays that the NVidia card is still second, but I set it as default in YaST, heck it’s the only one configured in YaST > Sound.

pavucontrol can only connect to pulseaudio if pulseaudio is running of course.
So you have to have pulseaudio enabled in YaST->Hardware->Sound->Other->PulseAudio Configuration.
Just having it installed is not enough.

I know I suggested you to try with PA disabled in the other thread, but have you actually tried to set the default sound output in pavucontrol with pulseaudio enabled? (I suggested this as well, but maybe I was not clear enough)
Note that you may have to logout/login (or reboot) after enabling PulseAudio for it to work correctly.

I have not configured pulseaudio, I will do that tonight. Coming from Lubuntu, it did that automatically, which I figure is against the Linux security model. Anyway, I will look at this when I get home.

Also, I have a habit of rebooting after almost every change I make with audio/video. I think I spend most of my time rebooting when I am setting up this stuff.

I’ll let you know what I come up with.

You don’t have to reboot just log out log back in. ie that will restart the desktop environment.

You should probably try to follow wolfi’s suggestions through; but as an alternative, if it all fails, is to set up ALSA with a local .asoundrc file, it may do the trick.

I have a similar problem on my laptop; it is opposite to yours though, HDMI is set as the first device and I am unable to change that order with the YaST module. I use KDE, without PulseAudio which I do not want to use, and have the possibility to configure the preferred output device order through 'System Settings >> Phonon, this works fine; however, that order do not apply to non KDE applications, hence, the solution is a bit limited; using a simple .asoundrc configuration file is the way I manage the audio-device order.

PulseAudio does work, but I use JACK also so its just a bother.
If you want a .asoundrc ‘default’ sample file just let us know, I or someone else could provide you with one.


I may add that the above set-up gives me audio software mixing capabilities, i.e. output sound from multiple applications simultaneously.

Just did this, logged out, still no sound. I wonder if I have PA installed correctly.

I have seen this done, but am not entirely sure how to set up the .asoundrc. Any suggestions?+

Did you uninstall anything?
Pulseaudio is installed by default, and it should be enabled by default.

So pavucontrol still cannot connect to pulseaudio?
What message do you get when you run it (pavucontrol) in a terminal window?

I have seen this done, but am not entirely sure how to set up the .asoundrc. Any suggestions?+

I guess something like this should work for you: (but I’m not sure)

pcm.!default {
    type hw
    card 1
    device 7

ctl.!default {
    type hw           
    card 1
    device 7

Or maybe replace “hw” with “plughw”, since you say plughw:1,7 works for you.

I uninstalled everything related to pulse and reinstalled just in case it was a bad install initially. Since then it still doesn’t connect. When run on the command line it says something along the lines of ‘Unable to access file ./config/path/to/some/file: Permission Denied’

When I look at those files I see that they aren’t owned by any user or group, they are just question marks(?). I tried to chown them, but to no avail.

I’ll try this when I get home.

Question marks? That would sound like an inconsistent file system.
Try to delete those files.

And maybe run fsck on the partition.

sudo fsck -f /dev/sda3

or similar.

This is strange, I get this:

media-box@linux-h9ia:~> sudo fsck -f /dev/sda3
sudo: fsck: command not found

Even though:

media-box@linux-h9ia:~> ls -la /usr/sbin/ | grep fsck*
-rwxr-xr-x 2 root root      414880 Nov 26 09:37 btrfsck
lrwxrwxrwx 1 root root           8 Nov  6 11:51 dosfsck -> fsck.fat
-rwxr-xr-x 4 root root      252800 Sep 27 13:04 e2fsck
-rwxr-xr-x 1 root root       31728 Dec 19 04:40 fsck
-rwxr-xr-x 1 root root          17 Nov 26 09:37 fsck.btrfs
-rwxr-xr-x 1 root root       18872 Dec 19 04:40 fsck.cramfs
-rwxr-xr-x 4 root root      252800 Sep 27 13:04 fsck.ext2
-rwxr-xr-x 4 root root      252800 Sep 27 13:04 fsck.ext3
-rwxr-xr-x 4 root root      252800 Sep 27 13:04 fsck.ext4
-rwxr-xr-x 1 root root       55832 Sep 27 19:43 fsck.fat
-rwxr-xr-x 1 root root       68504 Dec 19 04:40 fsck.minix
lrwxrwxrwx 1 root root           8 Nov  6 11:51 fsck.msdos -> fsck.fat
lrwxrwxrwx 1 root root           8 Nov  6 11:51 fsck.vfat -> fsck.fat

So I deleted the .config directory and ran ‘pavucontrol’ from terminal. This time it ran, but still could not connect.

Let me try using a .asoundrc file.

So I had to manually run ‘pulseaudio’ in the terminal. For some reason the owner of ‘~/.config/pulse/’ keeps getting set to root, but as soon as I set it to ‘media-box:users’ pulse audio will run and pavucontrol connects fine.

Now pavucontrol sees the onboard sound, however pavucontrol does not see the NVidia HDMI card.

1 you can’t run fsck in a mounted partition. so best to do it from a live DVD/CD

2 sudois not the same as in ubuntu and its derivatives it does not give a full root environment. so do this

su -

note the dash that will give full root environment
then run the command separately

alternativly you can give the full path wit sudo ie

sudo /sbin/command

Never log into a GUI as root that may be why the files are getting owned by root

In regard asoundrc:

pcm.!default {
    type plug
    slave.pcm "dmixer"

pcm.dmixer  {
     type dmix
     ipc_key 1024
     slave {
        pcm "hw:1,7"
        period_time 0
        period_size 1024
        buffer_size 4096
        rate 44100
    bindings {
        0 0
        1 1

ctl.dmixer {
    type hw
    card 1

This is perhaps a better start, it sets up dmix. I just copied it from the dmix session and changed the interface:device, change and/or add interfaces/devices as you wish: You can probably strip off the sample-rate, period and buffer size etc, if you wish to keep it simple to start with. As I have understood it everything not explicitly stated here will just stay as it is loaded by default (globally); so just use this file to adjust those elements important for you, e.g. set the default interface and device, and the order of these.

Still, lots to learn so you probably have to play around with it a bit.

This might also be worth reading it includes details on surround set-up, and more.

I copy and pasted this directly into my .asoundrc and it WORKS!

Thank you so much.

Well done:)