No Sound pavucontrol lists profile as off and specific settings as unvailable

I’m running Tumbleweed and sound which previously worked has stopped working. in pavucontrol, both sound cards are listed with the profile set to off. When I try and select a profile, all of them are listed as unavailable. KDE audio control lists the profile as off. My user is a member of both the audio and pulse groups.

aplay -l produces:

**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

My goal is to get sound out the headphone jack on card 1.

When I added the user to the pulse and audio groups, I only logged out and back in. The profiles were still unavailable. However, after rebooting the profiles became available. Not sure why the difference, but the issue is resolved.

Great it works, and consider this a contribution to openSUSE. Others have reported this kind of issues, on other platforms. Will ask around if pulse and/or audio group addition to the user privs helps their issues.

I’m not sure, but I think pulse keeps running after logout, and the next login resumes the existing session.

I think:

pulseaudio --kill

will kill it. Maybe if you did that just before logout, then it would have been fine at the next login

Some user on IRC reported they had added themselves to the pulse and the audio groups, rebooted and found the issue gone.

That will only work if pulseaudio is not set to respawn

https://en.opensuse.org/SDB:Pulseaudio#Disabling_Pulseaudio_autospawn

That is good to know.

I wrote too soon. I applied an update yesterday and rebooted. Now I’m back to the state where the profiles are listed as unavailable. The user is a member of the audio and pulse groups and the files under /dev/snd appear to have the proper permissions.

If you kill pulseaudio, (it should then respawn), do you then have the expected profiles present?

FWIW, here’s a similar thread…

It does not change the behavior. After running “pulseaudio -k” I get a brief pop up saying dummy output and the actual profiles remain unavailable in the pavucontrol.

Please show us the output of

fuser -v /dev/snd/*
lspci -nnk |grep -iA3 '\04'
dmesg|grep snd
USER        PID ACCESS COMMAND
/dev/snd/controlC0:  markg      5585 F.... pulseaudio
/dev/snd/controlC1:  markg      5585 F.... pulseaudio
lsci -nnk |grep -iA3 '\[04'
1c:00.1 Audio device [0403]: NVIDIA Corporation GP104 High Definition Audio Controller [10de:10f0] (rev a1)
        Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:3301]
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
--
1e:00.3 Audio device [0403]: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) HD Audio Controller [1022:1457]
        DeviceName: Realtek ALC898
        Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:fa34]
        Kernel driver in use: snd_hda_intel

dmesg|grep snd
    6.028972] snd_hda_intel 0000:1c:00.1: Disabling MSI
    6.028981] snd_hda_intel 0000:1c:00.1: Handle vga_switcheroo audio client
    6.158966] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC892: line_outs=4 (0x14/0x15/0x16/0x17/0x0) type:line
    6.158969] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
    6.158970] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
    6.158971] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
    6.158972] snd_hda_codec_realtek hdaudioC1D0:    inputs:
    6.158974] snd_hda_codec_realtek hdaudioC1D0:      Front Mic=0x19
    6.158981] snd_hda_codec_realtek hdaudioC1D0:      Rear Mic=0x18
    6.158986] snd_hda_codec_realtek hdaudioC1D0:      Line=0x1a

Does the following produce sound (card 1, device 0)?

aplay -D plughw:1,0 /usr/share/sounds/alsa/test.wav

I’m just trying to get a handle on whether sound is working at the ALSA layer at least.

It might be worth running the alsa-info.sh diagnostic script to check the audio-subsystem at the driver/interface layer…

https://en.opensuse.org/SDB:Audio_troubleshooting#Script_to_run_to_obtain_detailed_information

Allow it to upload the output to an online server, and post the link to this here.

BTW, this will show what parameters are in effect with respect to the loaded ‘snd_hda_intel’ module.

systool -m snd_hda_intel -v

If this all checks out, it could be an issue with udev/PulseAudio itself. I’ve seen a few such bug reports online, but I haven’t seen such reports from the openSUSE community.

Yes, it produces sound.

It might be worth running the alsa-info.sh diagnostic script to check the audio-subsystem at the driver/interface layer…

SDB:Audio troubleshooting - openSUSE Wiki

Allow it to upload the output to an online server, and post the link to this here.

http://alsa-project.org/db/?f=87b24824767d6404e942c06eef7e9b5d4915ea5b

BTW, this will show what parameters are in effect with respect to the loaded ‘snd_hda_intel’ module.

systool -m snd_hda_intel -v
Module = "snd_hda_intel"

  Attributes:
    coresize            = "53248"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "2"
    srcversion          = "83B05CDB680CADF58912B92"
    taint               = ""
    uevent              = <store method only>

  Parameters:
    align_buffer_size   = "-1"
    bdl_pos_adj         = "-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1"
    beep_mode           = "Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y"
    enable_msi          = "-1"
    enable              = "Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y"
    id                  = "(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)"
    index               = "-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1"
    jackpoll_ms         = "0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"
    model               = "(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)"
    patch               = "(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)"
    pm_blacklist        = "Y"
    position_fix        = "-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1"
    power_save          = "1"
    power_save_controller= "Y"
    probe_mask          = "-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1"
    probe_only          = "0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"
    single_cmd          = "-1"
    snoop               = "-1"

  Sections:


Thank you for your assistance.

The output from pa-info is available here: https://pastebin.com/WiK7WFnZ .

Good to know that the alsa command produced audible sound. Some suggestions…

  1. Try removing the existing ~/.config/pulse/ files (as regular user) with
rm -rf ~/.config/pulse
pulseaudio -k

and check if the desired profiles are then present.

  1. You could also try switching the sound card order by a manual creation/edit of /etc/modprobe.d/50-sound.conf with
sudo nano /etc/modprobe.d/50-sound.conf

using the following entries

options snd_hda_intel index=0 vid=1022 pid=1457
options snd_hda_intel index=1 vid=10de pid=10f0

Save when done and then reboot. The sound card order should now have the ‘Realtek ALC898’ as the first device. I don’t know whether this would make any difference to PulseAudio, but I did wonder if the NVIDIA device was somehow causing PA to fail.

  1. Alternatively, this might be sufficient (for making card 1 default PCM device)…
    https://alsa-project.org/wiki/Setting_the_default_device

If that doesn’t help, I’m not sure what else is left but to submit a big report.

I tried the above, but it had no effect on PulseAudio’s behavior. I’ve created a bug at: https://bugzilla.opensuse.org/show_bug.cgi?id=1152183

I did a clean install of Tumbleweed and added my user to the pulse, pulse-access, and audio groups, but the problem persisted. I had an extra space on after the user name in /etc/groups for the pulse group. After removing that and restarting to make sure the user was a member of the audio group, it still persisted. Then I ran pulseaudio -k and the problem no longer occurs. Not at all clear to me we why restarting pulseaudio worked that time and not before. The problem is no resolved for me.

Thanks for your assistance!

What a journey. Anyway, nice to read of your success with this. Thanks for the update. :slight_smile: