No sound output through HDMI

Hi, my problem is not new here, I’ve seen the other topics, still haven’t found the solution.
There is no audio output through TV speakers when the laptop is connected with HDMI.
The cable could not be broken, I’ve checked it had worked with Windows 10 on the same laptop.

I’ve installed pavucontrol, tried to change the output to HDMI, no result.
Here what ALSA says:

aleksandr@aleksandr-pc:~> aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 0: ALC3227 Analog [ALC3227 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

My video configuration is the following:


00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Carrizo [1002:9874] (rev c8)
        Subsystem: Hewlett-Packard Company Device [103c:8332]
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu

According to https://forums.opensuse.org/showthread.php/495651-How-to-Get-HDMI-Audio-Output I’ve added radeon.audio=1 optional kernel command line parameter in YAST boot loader and pressed OK. Still no results.

Change to bootloader requires q reboot to take effect

How do I do that? Press Ok in YAST, reboot my PC after? Could you please explain?

Change to the boot loader only take effect when the boot loader runs again and uses those option. the only time the boot loader runs is when you boot

So make the change and reboot

Note have no idea if that will fix the problem but but without a boot any change to the boot loader does nothing to the running system.

Sure, I’ve made the change a long time ago, rebooted many times since then. The problem still exists after all.

Perhaps show the output of the following

pacmd list sinks

and current mixer settings for your HDMI card…

amixer -c0

The first command output: aleksandr@aleksandr-pc:~> pacmd list sinksMemory blocks currently allocated: 1 - Pastebin.com

The second:


aleksandr@aleksandr-pc:~> amixer -c0
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]

That output reports that the current profile for card 0 is…

active profile: <output:hdmi-stereo>

which is a good sign at least.

You have some very good people helping you in this thread … so I am reluctant to ‘jump in’. Still, it would provide more visibility into your system if you ran a diagnostic script, such that we could understand where the problem is located ? With alsa driver ? With alsa configuration ? With pulse audio ? With a mixer ?

To help localize this, it would help me understand better (so to help you), and maybe help others on this thread, if you ran a diagnostic script, which might answer some of the above questions, such that focussed advice/recommendations can be given.

To run the script, with PC connected to the Internet, HDMI to your TV, as a regular user in an xterm, copy and paste the following to run the script :


/usr/sbin/alsa-info.sh

Select the “UPLOAD/SHARE” option. Let the script run to completion. When it is complete, you will see in the ‘xterm’ the text: "Your ALSA information is located at … < some http address > … ".

Please post that http address here.

= = =

Also, in ADDITION to the above, please try this test (I am using previous information you provided to produce this). Try as both a regular user, and as root, copying the command into an xterm :


aplay -D plughw:0,3 /usr/share/sounds/alsa/test.wav

The above is intended by me to test at the ‘alsa’ level but with pulse audio involved possibly.

If that produces no sound, try this test (which is intended to disable pulse audio for the one command):


pasuspender -- aplay -D plughw:0,3 /usr/share/sounds/alsa/test.wav

Please advise of any errors. Note in the above, I am assuming your HDMI is : hw:0,3 . Of course if that is not the HDMI device then there will be no sound.

Yes, I advise to dig deeper with the diagnostic output as requested by oldcpu.

I’m surprised not to see a master volume control. Try…

amixer scontents

The ALSA test output:http://alsa-project.org/db/?f=86170c91d46494ab27978f8787288ef3e636f44a

None of the playback test worked.

aleksandr@aleksandr-pc:~> amixer scontents
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 98304 [150%] [on]
  Front Right: Playback 98304 [150%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 16463 [25%] [on]
  Front Right: Capture 16463 [25%] [on]


Recall :

Please confirm, you tried both of those commands (playback tests) as a regular user, and both with root permissions, and not one instance gave any errors ?
.

I see no errors in the http://alsa-project.org/db/?f=86170c91d46494ab27978f8787288ef3e636f44a script output.

If it does not work with basic ‘alsa’ commands then the problem is upstream of pulse audio … and either with hardware (cable/TV/PC) , or the PC configuration on booting, or the kernel.

ie. That suggests to me problem is limited to only some locations:

  • cable to TV <<<<< you claim this is ok as it works currently with MS-Windows (I infer from your post this was VERY recent with MS-Windows and not some weeks/months ago ) …
  • TV setup <<<<< I infer this is ok as it worked with MS-Windows (and I also infer this was recent and not some weeks/months ago).
  • Graphic card with HDMI <<<<< you note this works with MS-Windows so this hardware should be good (ie this was recent with MS-Windows).
  • Alsa driver <<< perhaps recent kernel update broke the alsa driver? or maybe one needs a newer kernel (see below) <<<<< My guess this could be the cause together with amdgpu?
  • Boot configuration - In understand EVERYTIME you boot to test, you boot with the radeon.audio=1
    boot code ? Is that correct ? - AMDGPU driver <<<<< My guess this could be the cause

I note from some time back (year 2017) on a Ubuntu forum it noted:[INDENT]HDMI audio

The open source AMDGPU driver does not support (for now) the HDMI audio. To solve this problem, you can install the “hybrid” AMDGPU-Pro driver from AMD

[/INDENT]

I do not have radeon hardware, so I can not say for certain if that is up to date. Surfing I read suggestions one needs a 4.15 kernel or newer ? (for amdgpu support with HDMI audio ?). Again, I don’t have radeon hardware so I can not say for certain.

FWIW, I’m reminded of this old thread using similar AMD HDMI hardware…

https://forums.opensuse.org/showthread.php/523638-No-sound-through-HDMI?p=2815506#post2815506

Yes, that is probably the crux of it Lee.

More info here…

I have read suggestions that HDMI may work with the amdgpu-pro driver.

I don’t have radeon hardware, so I have never tried that myself.

I note this URL (in case posting it here helps): SDB:AMDGPU-PRO - Version: Leap 15.0 The AMDGPU-PRO driver provided for openSUSE Leap 15.0. Perhaps you could try installing that driver and see if it helps. It may have undesirable consequences ?? I have no experience to say one way or the other.

Sorry that I can not help more.

I’ve tried this, no sound produced through the TV:


aleksandr@aleksandr-pc:~> aplay -D plughw:0,3 /usr/share/sounds/alsa/test.wav
Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
aleksandr@aleksandr-pc:~> sudo aplay -D plughw:0,3 /usr/share/sounds/alsa/test.wav
Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
aleksandr@aleksandr-pc:~> pasuspender -- aplay -D plughw:0,3 /usr/share/sounds/alsa/test.wav
Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
aleksandr@aleksandr-pc:~> sudo pasuspender -- aplay -D plughw:0,3 /usr/share/sounds/alsa/test.wav
Connection failure: Connection refused
pa_context_connect() failed: Invalid argument

I just watched a movie on Windows 10 with my TV connected by HDMI, everything worked.

I’ve added radeon.audio=1 in bootloader options in YaST.

I’ve tried to install amdgpu-pro driver using the instructions on opensuse website, encountered a problem with the package signature. I couldn’t find the solution for the new problem anywhere in the web. Should I post the details here, or maybe create a new topic?

Thats’ only applicable when using the radeon graphics driver, and should be enabled by default anyway AFAIR.

I’ve tried to install amdgpu-pro driver using the instructions on opensuse website, encountered a problem with the package signature.

Ignore it and allow it to install.

I did ignore the rpr keys, installed the amdgpu-pro, the sound finally plays through the TV speakers, thanks!

I still have some minor issues with the HDMI, for example when I boot up with the cable attached to the TV, the OS doesn’t enable WI-FI untill the cable is removed.

Also I’m not sure how to properly set up the video output so the TV and the laptop screen have exactly the same video output, like the one I get than Windows OS is loaded.

Also since I had installed the amdgpu-pro driver the laptop shows the odd behavior during the bootup, instead of the loading screen with the Leap logo now I get something frustrating:

I’m not sure if the driver you suggested me to install is even designed for my graphics.

Great news.

hmmm …I am thinking a new thread for each may be useful.

For example, while I have some limited knowledge of sound/audio aspects, my wifi knowledge, my graphics knowledge, and my boot screen experience is not strong.

So may I suggest you start a separate help thread for each of these.

There are volunteer users on our forum who have expertise different topics, and they likely will not see these amdgpu-pro issues buried deep down on in “No sound output through HDMI” thread. But a new thread with appropriate key words in the title - such as :

  • ‘wifi with amdgpu-pro HDMI’ … and
  • ’ laptop / TV HDMI screen video lack same video output with amdgpu-pro ’ … and
  • ‘odd laptop boot up behaviour using amdgpu-pro HDMI’

Perhaps you can come up with better titles for new forum threads than myself.

I’m not sure either.