No Sound, OS11.0-KDE3.5, Audigy 2 ZS card

I was going to post in a similar thread, but I saw “oldcpu” recommended to start a new thread, so here it is.
Basic info:
openSuSE 11.0
KDE 3.5
Audigy 2 ZS Gamer kernel

I have been using SuSE since around 9.1 (same soundcard) and this is the first time I recall having any troubles with it. It always worked out of the box.

Installed 11.0-kde3.5 (i586), Kernel is pae (I’ve always used default before, I didn’t notice pae was the default till after the install, but I’m guessing this shouldn’t be the issue).

I’ve followed the Sound Troubleshooting instructions and still nothing. I used the two diagnostic scripts, here are the urls:

Script #1
Script #2

I also tried the KDE4 install, but for other reasons chose to downgrade (via fresh install) back to 11.0-KDE3.5. I am currently running 3.5.

Here is the output to the uname/grep stuff that was asked for in similar threads:

chuck@chuck-suse:~> uname -a
Linux chuck-suse #1 SMP 2008-06-07 01:55:22 +0200 i686 i686 i386 GNU/Linux
chuck@chuck-suse:~> rpm -qa | grep alsa
chuck@chuck-suse:~> rpm -qa | grep pulse
chuck@chuck-suse:~> rpm -q libasound2
chuck@chuck-suse:~> cat /etc/modprobe.d/sound
alias snd-card-0 snd-emu10k1
alias sound-slot-0 snd-emu10k1

Originally I didn’t have any pulse stuff, so I installed it (still no sound).
I also updated my alsa files to bleeding edge following the instructions from the opensuse wiki.

Still no sound. Any ideas? I just find it really really strange that I’ve never had any problem whatsoever with sound with all 9.x and 10.x versions and beautiful 11.0 for some reason can’t make my sound card work. I’m really loving 11.0 otherwise, awesome job!

By the way, all programs “think” there is sound coming out. Amarok shows the sound analyzer’s bars going up and down as I play a song, etc.

I guess it’s the same problem like I got on my Audigy 4. Just go to the mixer settings an activate the Digital/Analog Output button. I bet it is set to digital, so you can’t any analog signals.


torteya, try Gargi’s suggestion. I note from the tsalsa.txt script that you have:
amixer set ‘Audigy Analog/Digital Output Jack’,0 off

Try setting that to ON. Its also possible your pulse audio installation has caused some hiccups, but lets address that only if trying to change that mixer setting from OFF to ON doesn’t work.

I can confirm the same issue with an Audigy 2 card and Opensuse 11 with a standard install. Setting the Digital/Analog Output to ON seems to be the workaround.

It’s not really a workaround - SPDIF/Optical passthrough is something a lot of people use, including myself - it’s simply a “default setting.”

Oh Jesus, now I feel really stupid :stuck_out_tongue:

Thank you so much, I swear I had checked that, damnit!

OK, now that it’s been proven that it was really my stupidity and not a problem of 11.0 I’m confident to say the release rocks!

Thanks everyone!

This is strange … also had the same issue with my Audigy 2ZS.

Resolved by Digital/Analog Output switch … is PulseAudio responsible for this hickup!

I’m inclined to say no. I originally didn’t have Pulse (I later installed it to see if it helped) and still had no sound. So, assuming it was just the analog/digital switch all along, it was set on digital before I had installed Pulse.

Must be a funny “default” setup for that driver.