No sound - OS 11.0 64bit

Banshee cannot play any mp3s. Besides the lack of sound, there is no progress on the meter and it always says “idle”.

See the info below.

Thanks!!
WT

Tesla:/home/wjtaylor # uname -a
Linux Tesla 2.6.25.20-0.5-default #1 SMP 2009-08-14 01:48:11 +0200 x86_64 x86_64 x86_64 GNU/Linux

Tesla:/home/wjtaylor # lspci | grep Audio
00:1b.0 Audio device: Intel Corporation ICH10 HD Audio Controller

Tesla:/home/wjtaylor # rpm -qa | grep alsa
alsa-1.0.16-39.1
alsa-plugins-pulse-1.0.16-57.1
alsa-firmware-1.0.16-24.1
alsa-oss-32bit-1.0.15-48.1
alsa-utils-1.0.16-35.1
alsa-plugins-1.0.16-57.1
alsa-oss-1.0.15-48.1

Tesla:/home/wjtaylor # rpm -qa | grep pulse
pulseaudio-module-zeroconf-0.9.11-27.1
libpulse0-0.9.11-27.1
libpulsecore4-0.9.11-27.1
pulseaudio-module-gconf-0.9.11-27.1
alsa-plugins-pulse-1.0.16-57.1
libpulse-mainloop-glib0-0.9.11-27.1
pulseaudio-0.9.11-27.1
pulseaudio-module-lirc-0.9.11-27.1
libpulse-browse0-0.9.11-27.1
pulseaudio-module-x11-0.9.11-27.1
pulseaudio-esound-compat-0.9.11-27.1
pulseaudio-utils-0.9.11-27.1
pulseaudio-module-bluetooth-0.9.11-27.1
gstreamer-0_10-pulse-0.9.7-42.pm.1

Tesla:/home/wjtaylor # rpm -q libasound2
libasound2-1.0.16-39.1

Tesla:/home/wjtaylor # cat /etc/modprobe.d/sound
options snd slots=snd-hda-intel

u1Nb.d+x9W4UhE78:ICH10 HD Audio Controller

alias snd-card-0 snd-hda-intel

Tesla:/home/wjtaylor # cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xe9300000 irq 22

Is your only problem Banshee won’t play mp3?

Can you get sound else where?

If you can not get ANY sound anywhere, then plus copy and paste the following into a terminal and execute the line (with your PC connected to the internet). Select UPLOAD/SHARE option. When it finished it will give you a URL. Please paste the URL here:

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh

Note, for testing your audio for sound, I recommend you use the speaker tests annotated here:
SDB:AudioTroubleshooting - openSUSE

Please advise if ANY of those tests give sound.

If this is ONLY a banshee mp3 problem and other sound works, then I can not help. I do not use banshee,

Nope, no sound at all…

The script said pulseadio, esound, and jack were not running, but I don’t see a daemon to start in yast. Could this be due to a missing/incorrect codec?

Thanks,
WT

Tesla:/home/wjtaylor # speaker-test -Dplug: front -c2 -l5 -twave

speaker-test 1.0.16

Playback device is plug:
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib pcm.c:6632: (snd_pcm_slave_conf) missing field pcm
Playback open error: -22,Invalid argument
ALSA lib pcm.c:6632: (snd_pcm_slave_conf) missing field pcm
Playback open error: -22,Invalid argument
ALSA lib pcm.c:6632: (snd_pcm_slave_conf) missing field pcm
Playback open error: -22,Invalid argument
^C

Tesla:/home/wjtaylor # speaker-test -c2 -l5 -twave

speaker-test 1.0.16

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
*** PULSEAUDIO: Unable to connect: Connection refused
Playback open error: -111,Connection refused
*** PULSEAUDIO: Unable to connect: Connection refused
Playback open error: -111,Connection refused
^C

Your ALSA information is located at http://www.alsa-project.org/db/?f=f11607ae42f4f8d4496ec0883bbd61735b1398a1

I ran pulseaudio manually and I can complete the basic speaker test, but still not the -Dplug front test.

*** There is no sound when this test runs ***

wjtaylor@Tesla:~> /usr/bin/pulseaudio
W: main.c: High-priority scheduling enabled in configuration but not allowed by policy.
W: core-util.c: setpriority(): Permission denied
W: pid.c: Stale PID file, overwriting.
W: control.c: Invalid CTL front:0
W: control.c: Invalid CTL front:0
W: pcm_hw.c: SNDRV_PCM_IOCTL_DRAIN failed
N: module-alsa-sink.c: Increasing wakeup watermark to 40.00 ms
W: pcm_hw.c: SNDRV_PCM_IOCTL_DRAIN failed
W: pcm_hw.c: SNDRV_PCM_IOCTL_DRAIN failed
W: pcm_hw.c: SNDRV_PCM_IOCTL_DRAIN failed

*** In another terminal window ***

Tesla:/home/wjtaylor # speaker-test -c2 -l5 -twav

speaker-test 1.0.16

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 128 to 1048576
Period size range from 64 to 262144
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
0 - Front Left
1 - Front Right
Time per period = 3.902148
0 - Front Left
1 - Front Right
Time per period = 3.650370
0 - Front Left
1 - Front Right
Time per period = 3.659939
0 - Front Left
1 - Front Right
Time per period = 3.659862
0 - Front Left
1 - Front Right
Time per period = 3.991352
Tesla:/home/wjtaylor # speaker-test -Dplug front -c2 -l5 -twav

speaker-test 1.0.16

Playback device is plug
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib pcm.c:6632: (snd_pcm_slave_conf) missing field pcm
Playback open error: -22,Invalid argument
ALSA lib pcm.c:6632: (snd_pcm_slave_conf) missing field pcm
Playback open error: -22,Invalid argument
ALSA lib pcm.c:6632: (snd_pcm_slave_conf) missing field pcm
Playback open error: -22,Invalid argument
^C

OK, thanks for that. I note a Gigabyte EP45-UD3R running the 2.6.25.20-0.5-default kernel on openSUSE-11.0, with 1.0.16 of alsa, where the Gibabyte’s hardware audio codec is an ALC882 or 885.

I checked your mixer settings and noted they appeared to be ok for playing audio, although the master volume at 69% could be moved up to 95% for testing, and then backed off once sound is established.

I checked the alsa web site for updates for the ALC885: Search results ALC885 - AlsaProject and for the ALC882: Search results ALC882 - AlsaProject and since 1.0.16 of alsa there were not many for the ALC885 but there were some for the ALC882.

Still, its possible we can get this to work without updating alsa.

My speculation is that the auto probe of alsa upon booting, failed to properly configure your alsa sound driver. So I recommend you try iteratively forcing different model configurations, to see if one of those will give you sound. You can do that by editing your /etc/modprobe.d/sound file as I will describe below.

Note to edit this file requires root permissions. You can edit it:

  • in Gnome by typing: gnomesu gedit /etc/modprobe.d/sound
  • in KDE by typing: kdesu ‘kwrite /etc/modprobe.d/sound’
    and enter root permissions when prompted.

When editing the file, we are going to chose an option from the following list from the 1.0.16 alsa-configuration.txt file:

	ALC882/885
	  3stack-dig	3-jack with SPDIF I/O
	  6stack-dig	6-jack digital with SPDIF I/O
	  arima		Arima W820Di1
	  targa		Targa T8, MSI-1049 T8
	  asus-a7j	ASUS A7J
	  asus-a7m	ASUS A7M
	  macpro	MacPro support
	  mbp3		Macbook Pro rev3
	  imac24	iMac 24'' with jack detection
	  w2jc		ASUS W2JC
	  auto		auto-config reading BIOS (default)

Lets start with “3stack-dig”, test, and if that does not work we will then replace that with the next item in the list, test it, and if that does not work, keep working our way thru the list.

So, as described above, to test “3stack-dig”, open the /etc/modprobe.d/sound file with root permissions with the edit, and add a line AT THE START of the file, so that the file now looks like:

options snd-hda-intel model=3stack-dig
options snd slots=snd-hda-intel
# u1Nb.d+x9W4UhE78:ICH10 HD Audio Controller
alias snd-card-0 snd-hda-intel

save that change.

Then in a terminal restart your alsa sound driver with the command su -c ‘rcalsasound restart’ and enter root password when prompted, and restart your mixer (kmix on KDE and alsamixer on Gnome) and then run the 3 speaker tests that are noted in the audio troubleshooting guide (you tried 2 of them before). Test your sound. Do you get sound?

If not, then in the /etc/modprobe.d/sound file, replace “3stack-dig” with “6stack-dig” , save the change, and again, in a terminal restart your alsa sound driver with the command su -c ‘rcalsasound restart’ and enter root password when prompted, and restart your mixer (kmix on KDE and alsamixer on Gnome) and then run the 3 speaker tests that are noted in the audio troubleshooting guide (you tried 2 of them before). Test your sound. Do you get sound?

Keep trying each item in the list until you get sound or until you exhaust the list.

The first test below produces sound. The second still gives an error message.

Thanks!
WT

Tesla:/home/wjtaylor # speaker-test -c2 -l5 -twav

speaker-test 1.0.16

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 128 to 1048576
Period size range from 64 to 262144
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
0 - Front Left
1 - Front Right
Time per period = 3.902148
0 - Front Left
1 - Front Right
Time per period = 3.650370
0 - Front Left
1 - Front Right
Time per period = 3.659939
0 - Front Left
1 - Front Right
Time per period = 3.659862
0 - Front Left
1 - Front Right
Time per period = 3.991352

Tesla:/home/wjtaylor # speaker-test -Dplug front -c2 -l5 -twav

speaker-test 1.0.16

Playback device is plug
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib pcm.c:6632: (snd_pcm_slave_conf) missing field pcm
Playback open error: -22,Invalid argument
ALSA lib pcm.c:6632: (snd_pcm_slave_conf) missing field pcm
Playback open error: -22,Invalid argument
ALSA lib pcm.c:6632: (snd_pcm_slave_conf) missing field pcm
Playback open error: -22,Invalid argument
^C