No sound opensuse 13.1

I have a Sony Vaio VPCZ1190X which uses ALC889 codec on the intel audio.
Ever since I upgraded to opensuse 13.1 there was no sound.

The more specific symptom was that I was getting sound through the headphones but not through the speaker.
I resolved this by upgraded to 3.12 kernel version from the following repository
Index of /repositories/Kernel:/stable/standard

Please read my blog on PulseAudio in case its a setup issue for pulse: PulseAudio and Selecting the Proper Sound Card Configuration - Blogs - openSUSE Forums

For kernel version upgrades, please read here: openSUSE and Installing New Linux Kernel Versions - Blogs - openSUSE Forums

Thank You,

Thanks James for me upgrading the Kernel worked.

Good to hear of your success. I was happy to help.

Thank You,

I have a Dell Precision M4600 with i7-2760QM, 16GB ram, nVidia K2000 and intel audio with Codec: IDT 92HD90BXX

First I had a problem with Skype no sound at all in openSuSE 13.1. It was reporting the following line:

ALSA lib dlmisc.c:252:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/alsa-lib/

Then I have tried to follow SDB:Skype - openSUSE , -Preparation and input

su -c 'zypper install libqt4-32bit libqt4-x11-32bit libpng12-0-32bit libQtWebKit4-32bit xorg-x11-libs libXss1-32bit libpng12-0'

Since other packages are included, it only installed libpng12-0-32bit, Since then I don´t have sound at all, only beeper.
I have uninstalled this package to see if it will go back to previous state, but still there is no sound at all. I have also followed kernel update as proposed in above part and update kernel to the stable release. Still no sound at all.

I have also tried to disable pulse audio, but it was without any effect. Can you please help me to solve these issues with audio?

linux-precise:~ # cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version k3.11.6-4-desktop.
linux-precise:~ # cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_hda_intel
 2 snd_usb_audio
linux-precise:~ # cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xe1e60000 irq 53
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xe0080000 irq 17
 2 [Exchange       ]: USB-Audio - Hercules Dualpix Exchange
                      Guillemot Corporation Hercules Dualpix Exchange at usb-0000:00:1a.0-, hi

I’ve managed to solve the problem. First by installing Alsa firmware and PulseAudio control.

zypper install alsa-firmware
zypper in pavucontrol

This put back my sound again but remain with the same error in Skype with addition that there was no more intel audio codec in the Skype sound setup but only nVidia HDMI.
Therefore, I completely uninstalled skype and all adjoining skype libraries. Reboot and installed skype again and now everything works.

I found this post very helpful and it worked:

After I installed OpenSuse 13.1, I had no sound. I’ve been an OpenSuse user for years and most recently running 12.2 without any sound problems.

I ran pvuconfig and went to output devices tab. I changed “Built-in Audio Stereo” port from headphones to lineout. **Sound started working! ** However, as soon as I plug in headphones, it automatically switches back to headphones and won’t go back unless I make the change manually.

Also, prior to that I disabled and then re-enabled Pulse Audio. I’m not sure if that did anything but I did this through Yast Control Center -> Sound -> Other (drop down) -> PulseAudio Configuration.