No Sound - OpenSuse 11.2 - Dell Precision 380


Just installed OpenSuse 11.2 on my Dell Precision 380 where I had till yet the 11.1 (new install not update).

Now I can’t get my speakers work even if they worked well under 11.1.

That should bring some happiness to oldcpu who loves working with sound problems lol!

/usr/sbin/ ](

rpm -qa 'alsa


rpm -qa 'pulse


rpm -q libasound2


uname -a

Linux PC-Office #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel,snd-emu10k1
# u1Nb.oOx2gup68RF:82801G (ICH7 Family) High Definition Audio Controller
alias snd-card-0 snd-hda-intel
# NrnX.QwBw58LB0qF:SB Audigy
alias snd-card-1 snd-emu10k1

So… I hope oldcpu will enjoy this :wink:



oups, the link to the desapered…:


I note 3 sound devices. Which one are you trying to get sound out of?

Please take a look at this guide re: your audigy: [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA - openSUSE Forums]( Its old, but still IMHO relevant with respect to mixer settings (the ‘Audigy Analog/Digital Output Jack’ and ‘External Amplifier’ settings are critical in blocking or not-blocking your sound).

Please also take a look at this “step-9” update to the troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE - step 9 - multiple sound devices

Also, when testing your sound, please use the two speaker tests, and the one alsa web site, referenced here: SDB:AudioTroubleshooting - openSUSE - step-1 how to test your sound if ANY one of those 3 tests give sound, then your problem lies somewhere other than with the alsa sound driver.

Hello oldcpu,

Thanks for your help… I did not found the solution in the links you gave me, but they brang me to the solution :stuck_out_tongue:

I had to go to System configuration (the one you find in the Suse launcher as default in the favorit, not YAST) -> Multimedia and there I had to change the order the devices are choosed.

The device I wanted to make run is SB Audigy

Thanks again



Interesting . … Glad to read you got it working … I’m puzzling why that actually blocked your sound, and asking myself if this is a bug that you had to go through this. … This presumably could impact users with multiple sound devices, … I don’t know enough about this to judge …

But glad again to read it works now.

Glad too :slight_smile:

Waht is strange, is that before 11.2, 11.1 was installed and I had no sound problems…

Regards and good luck


Fortunately, user Puregore was kind enough to update the troubleshooting guide for sound, adding STEP-9:

SDB:AudioTroubleshooting - openSUSE - Step-9 : determine the order of sound devices