No Sound; OpenSuse 11.1; Satellite 64-bit; Radeon

I have read a few posts, and I have checked with YaST control center. I have removed, & reinstalled the driver. I have rebooted the computer. I do not know how to enter the Terminal.

I am hoping that someone else has had good luck in solving this issue.

Thank you for any type of help you can offer.


In the Sound Configuration I have:

82801H (ICH8 Family) HD Audio Controller
• Configured as sound card number 0
• Driver snd-hda-intel
RV620 Audio device [Radeon HD 34xx Series]
• Configured as sound card number 1
• Driver snd-hda-intel

If running kde, just press <alt><f2> and type: konsole

You can also go to your “K Menu” (on kde) or your gnome equivalent and find the terminal/konsole that way.

I am running the Gnome version. BTW, I have switched over to the Windows Vista side of the drive, and the sound is working fine. I’m listening to some pretty cool music. I wanted to double-check that the sound was working.

Thanks for the quick reply.

I don’t use gnome. Some one else will need to teach you the basics on finding a terminal with gnome, … although frankly, I’m surprised you can’t find it. Just navigate your gnome menu’s and you will find it. :open_mouth:

Once you sort out your difficulty in launching a terminal, you can work your way through the openSUSE audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

I found the terminal mode. I had selected More Applications, and there it was.

You should probably run through the trouble shooting guide that oldcpu posted first, he is very helpful.

I had the same problem with an asus 3450 card and it’s HDMI output. I installed the ATI driver for X from the ati repository and then noticed that dmesg was showing an error. When I get home I’ll check to see what I had to do about the error. There was some module setting that needed to be increased.


Originally Posted by David2009 View Post
I am using Gnome & version 11.1, and I cannot hear any sound from my speakers.
David2009, please start a new thread with your sound help requests.

Please also, when you do that, provide the proper output of “rpm -qa | grep alsa” (as you are missing an alsa app from what you posted), and also post in that same thread the output URL provided from successfully running the script (with root permissions):


Reply With Quote Quick reply to this message
View Public Profile
Send a private message to oldcpu
Visit oldcpu’s homepage!
Find all posts by oldcpu
Add oldcpu to Your Contacts
#45 (permalink) Add to David2009’s Reputation Report Post
Old Today, 20:24
David2009 David2009 is online now
Puzzled Penguin

Join Date: Jan 2009
Posts: 8
David2009 is on a distinguished road
Default Re: no sound on new Suse 11.1 ?
My computer’s sound card is not working with 11.1 either. It is a Toshiba Satellite A300 series, 64-bit with a Radeon sound card.

Following the scripts I saw online here is the information I received:

speaker-test -Dplug:front -c2 -l5 -twav

speaker-test 1.0.18

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 16384
Period size range from 32 to 8192
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
0 - Front Left

david@linux-t3i4:~> speaker-test -c2 -l5 -twav

speaker-test 1.0.18

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
0 - Front Left
1 - Front Right
Time per period = 3.892592
0 - Front Left
1 - Front Right
Time per period = 3.740305
0 - Front Left
1 - Front Right
Time per period = 3.740989
0 - Front Left
1 - Front Right
Time per period = 3.734856
0 - Front Left
1 - Front Right
Time per period = 3.743783

I tried to enter the /usr/sbin/ into my terminal, and it didn’t work.

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.17.

cat /proc/asound/modules
0 snd_hda_intel
1 snd_hda_intel

cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xce400000 irq 22
HDA ATI HDMI at 0xce310000 irq 17

And, I ran the USR script with GEdit, and I got pages of code. I don’t know what to do with this information, so I’ll share a few lines, and quit the program.

#The script was written for 2 main reasons:

1. Remove the need for the devs/helpers to ask several questions before we can easily help the user.

2. Allow newer/inexperienced ALSA users to give us all the info we need to help them.

#Change the PATH variable, so we can run lspci (needed for some distros)

I was getting no sound from my 3450 HDMI connection but was seeing errors about bdl_pos_adj being to low in dmesg. One I added the option line below it started working fine for me. Rebooting is probably easier then reloading the modules.

from /etc/modprobe.d/sound

options snd slots=snd-hda-intel,snd-hda-intel
options snd-hda-intel bdl_pos_adj=256

NXNs.K1zXe4yWCp3:RV620 Audio device [Radeon HD 34xx Series]

alias snd-card-0 snd-hda-intel

u1Nb.q5IQ1HohpkC:82801H (ICH8 Family) HD Audio Controller

alias snd-card-1 snd-hda-intel

Now, I’ll have to begin again. I thought I was adding KDE to my Linux lineup. I overwrote the Gnome and now have KDE.

A difference; I can hear a WAV file in Amarok. It is very quiet & scratchy, but there is a man talking. I have everything up to the max, and it is still faint. More tomorrow…it’s late.

If you can hear the .wav file in amarok, then likely your sound works. Typically I recommend users, to test their sound, copy and paste the following line into a gnome-terminal or a kde konsole:speaker-test -c2 -l5 -twav One should hear a lady’s voice saying ‘FRONT LEFT’,‘FRONT RIGHT’ five times.

If the volume is too low, then go to YaST > Hardware > Sound > Other > Volume and move the Master and PCM volume controls there up very very high. Close YaST. Then start one’s mixer. And in one’s mixer control the Master and PCM volume controls such that the volume is at a good volume level, without distorting the sound.

Now, reference proprietary video and audio codecs, most media players (as packaged by Novell/SuSE GmbH) will not play proprietary video and audio codecs due to the Novell/SuSE GmbH implementation of the open source free software philosophy. The vast majority of video and audio codecs available are proprietary, and hence to play those one typically has to update both their multimedia players with 3rd party packaged players, and also install 3rd party packaged codecs. To do that, the best thing is first ensure one’s PC has internet access. Then one should update the repositories in one’s Software Package Manager with 4 repositories (repos) where a repository is in essence a file server on the internet with applications for (openSUSE) Linux stored. The 4 repos to setup are OSS, Non-OSS, Update and Packman. Just those 4. No others. None. ONLY add others after one understands the risks, how to identify and fix problems that come up by adding others. Typically that means newbies should not add others and average users need to be very cautious. There is guidance for adding the 4 repos here: Repositories/11.1 - openSUSE-Community

again, add only OSS, Non-OSS, Update and Packman. Specifically do NOT add videolan as its codecs/multimedia are known to be incompatible with Packman’s in various ways.

Once those 4 are added, one can go to YaST > Software > Software Management and change the “filter” to “search” and search for and install replacements for the Novell/SuSE-Gmbh packaged apps with the following Packman packaged apps (one can tell its packman packaged by the “pm” in the version number): amarok, libxine1, amarok-xine, amarok-packman, smplayer, mplayerplug-in, vlc, libffmpeg0, w32codec-all. That small number of apps will packup others as a dependency, and should sort most problems. In the case of amarok one should next go to its configuration menu and change its audio engine to xine.

Good luck.

I continue to try to find more data about my computer in the hope that someone will know how to activate my sound card.

I ran an ALSA script, and here is its website:

When I loaded up Amarok last night, I heard Matthias’ voice. My mixer is set to 100%, and the Amarok was at 80%. But, it wasn’t loud.

One more point, as I closed down the computer last night there was a quick message…that I wasn’t able to read a lot of…that said my sound card has not been installed, and it was using … That is where I could not read fast enough.

Thanks for any help.


Thank you for the left & right test. It worked. I went to the repository link, but did not find the files. I did find Packman, but not one for Main Update, OSS, and Non-OSS. I found a Main (Sources) and a Main (DEBUG). The struggle continues. But, today I have some sound!

From openSUSE-Community

Just head over to YaST → Software → Software Management. Then, in the menu: Configuration → Repositories… Now hit the Add → Community Repositories, and select:

* Main Repository (OSS)
* Main Repository (Non-OSS)
* Packman Repository
* Main Update Repository 

…from there. Easy. :slight_smile:

To install a popular list of codecs, see Multimedia.

Thank you for the script output. That is useful. Normally within minutes of any sound problem, I have run that script to help me. Within minutes. … minutes … It took you days. … so there is a big learning curve here with you, … a curve that we all have gone through, so don’t despair, as you will eventually get over the curve.

Now, it may help after you confirm some fundamental things.

You have not told me your success of failure wrt my recommendations, and I am reluctant to provide more unless you answer the specific recommendations I made.

I can’t see over your shoulder to see if things fail, or if they work. Now I recommended you try a speaker-test, and I gave you the specific command to use. Did it work? I don’t know. You did not say.

I recommended you go to YaST > HARDWARE > SOUND > OTHER > VOLUME and move up your volume there. Did you do that? Did it work? I don’t know. You did not say.

My recommending any other things, is A WASTE OF YOUR TIME as it may not be necessary. Unless you PROVIDE FEED BACK as to what suggestion works, and what suggestion does not work, when someone provides a recommendation, then the recommendations may be a waste of time.

Good luck with your efforts, but please, try provide feed back wrt SPECIFIC suggestions that you have been given.

OK, thank you.

As you can see from my previous post, I was very curious as to the result.

And ??? result of this??

They are there. You just need to look carefully.

Sometimes they are installed by default. Sometimes not.

You can find out what repos you have installed, by typing in a gnome terminal or a kde konsole: zypper lr

I did follow the instructions for the YaST, > HARDWARE > SOUND > OTHER > VOLUME and move up your volume. The Master is at 90%, the PCM at 100%. No success. The HDA Intel sound mixer is set to 100%. No success.

zypper lr

| Alias | Name | Enabled | Refresh

1 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No
2 | repo-debug | openSUSE-11.1-Debug | No | Yes
3 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes
4 | repo-oss | openSUSE-11.1-Oss | Yes | Yes
5 | repo-source | openSUSE-11.1-Source | No | Yes
6 | repo-update | openSUSE-11.1-Update | Yes | Yes

Thank you for your patience.

From reading the zipper script, I am thinking that the modules I cannot seem to find on the YaST, etc are already on my system. So, I added the Packman Repository. Now, I run zipper, and get:

| Alias | Name | Enabled | Refresh

1 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No
2 | repo | Packman Repository | Yes | Yes
3 | repo-debug | openSUSE-11.1-Debug | No | Yes
4 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes
5 | repo-oss | openSUSE-11.1-Oss | Yes | Yes
6 | repo-source | openSUSE-11.1-Source | No | Yes
7 | repo-update | openSUSE-11.1-Update | Yes | Yes

By way of feedback, I get some nice closing notes when I exit OpenSuse. The computer continues to remind me that my sound card has failed to be installed, and the unit is falling back on a default. HDI something.