No sound, openSUSE 11.1 on HP dv5-1030en

No sound after update to openSuse 11.1
I have tried one hint (No sound through laptop speakers, headphones work fine - openSUSE Forums) - didn’t help for my HP Pavilion dv5-1030en

# cat /etc/modprobe.d/sound
options snd-hda-intel model=hp-m4 enable_msi=1
options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.DVex+nmP8+5:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
# NXNs.HS4OKn_IlZ0:RV620 Audio device [Radeon HD 34xx Series]
alias snd-card-1 snd-hda-intel

dmesg:

Code:

ALSA sound/pci/hda/hda_codec.c:2334: hda_codec: model 'hp-m4' is selected
ALSA sound/pci/hda/hda_codec.c:3047: autoconfig: line_outs=1 (0xd/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3051:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3055:    hp_outs=1 (0xa/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3056:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3064:    inputs: mic=0xb, fmic=0x0, line=0xe, fline=0x0, cd=0x0, aux=0x0

Still no sound :confused:

If someone had experience configuring such notebook to work, please let me know

I note your original request for help was on a different thread, and that I replied here:

no sound on new Suse 11.1 ? - openSUSE Forums

With that /etc/modprobe.d/sound file in place, how about running a diagnostic script, with your PC connected to the Internet:/usr/sbin/alsa-info.shand post here the URL provided.

What are you doing for a speaker test?

Also, did you try those other model options in your /etc/modprobe.d/sound file, that I suggested in my quoted post above?

Yeah, sorry I forgot to copy-paste the link from that thread.
Here he is:

http://www.alsa-project.org/db/?f=a50217c981aab5c997fa1459ce42477c69c4219f

# rpm -qa | grep alsa
alsa-firmware-1.0.17-1.42
alsa-oss-1.0.17-1.37
alsa-plugins-1.0.18-6.12
alsa-plugins-pulse-1.0.18-6.12
alsa-utils-1.0.18-6.4
alsa-1.0.18-8.7

I have tried plaing flash from yuotube, vlc net radio
Also this tool:

 # speaker-test -c2 -l5 -twav

speaker-test 1.0.18

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 8192
Period size range from 1024 to 1024
Using max buffer size 8192
Periods = 4
was set period_size = 1024
was set buffer_size = 8192
 0 - Front Left
 1 - Front Right
Time per period = 2.860973
 0 - Front Left
 1 - Front Right
Time per period = 3.028913
 0 - Front Left
 1 - Front Right
Time per period = 2.986466
 0 - Front Left
 1 - Front Right
Time per period = 3.008194
 0 - Front Left
 1 - Front Right
Time per period = 3.007890

I will try this list and post the results in some minutes

tried 3 models: hp-m4, dell-m4-1 and dell-m4-2
no effect :confused:

ALSA sound/pci/hda/hda_codec.c:2334: hda_codec: model 'dell-m4-1' is selected
ALSA sound/pci/hda/hda_codec.c:3047: autoconfig: line_outs=1 (0xf/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3051:    speaker_outs=1 (0xd/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3055:    hp_outs=1 (0xa/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3056:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3064:    inputs: mic=0xb, fmic=0xe, line=0x0, fline=0x0, cd=0x0, aux=0x0

ALSA sound/pci/hda/hda_codec.c:2334: hda_codec: model 'dell-m4-2' is selected
ALSA sound/pci/hda/hda_codec.c:3047: autoconfig: line_outs=1 (0xf/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3051:    speaker_outs=1 (0xd/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3055:    hp_outs=1 (0xa/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3056:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3064:    inputs: mic=0xb, fmic=0xc, line=0x0, fline=0x0, cd=0x0, aux=0x0

ALSA sound/pci/hda/hda_codec.c:2334: hda_codec: model 'hp-m4' is selected
ALSA sound/pci/hda/hda_codec.c:3047: autoconfig: line_outs=1 (0xd/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3051:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3055:    hp_outs=1 (0xa/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3056:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3064:    inputs: mic=0xb, fmic=0x0, line=0xe, fline=0x0, cd=0x0, aux=0x0

so you restarted your PC after each of those, when testing?

When I look at the script out put, you do not have any model options, nor the enable_msi=1 applied, and hence I have a degree of skeptism that you applied those settings correctly. Please apply the model=hp-m4 and enable_msi=1 option, restart your PC, and then run the script. I want to see those settings applied in the script, to give me confidence you applied them correctly.

Reference your speaker test don’t use youtube as a speaker test. When testing for basic audio, that is a very poor test, as it tests more than just audio, and what is important here is to localize where the problem is occuring. Please stick with the "speaker-test -c2 -l5 -twav
" as a test.

Reference your mixer, I note:
!!Amixer output
!!-------------
!!-------Mixer controls for card 0 [SB]
Card hw:0 ‘SB’/‘HDA ATI SB at 0xd2400000 irq 16’
Mixer name : ‘IDT 92HD71B7X’
Components : ‘HDA:111d76b2’
Simple mixer control ‘Master’,0
Mono: Playback 63 [50%] -48.00dB] [on]
Simple mixer control ‘IEC958’,0
Mono: Playback [off]
Simple mixer control ‘IEC958 Default PCM’,0
Mono: Playback [on]
Simple mixer control ‘IEC958 Playback Source’,0
Items: ‘Digital Playback’ ‘Analog Mux 1’ ‘Analog Mux 2’
Item0: ‘Digital Playback’
Simple mixer control ‘IEC958 Playback Source’,1
Items: ‘Digital Playback’ ‘Analog Mux 1’ ‘Analog Mux 2’
Item0: ‘Digital Playback’
From what I have read, 50% is way too low for the master volume for this laptop. Jack it up to 95% for these tests. Once you have sound, you can lower it to a non-distortion regin. Also, have you tried different IEC958 settings?

Yes I did. After each restart I looked into dmesg to see if there was any error

You are right. I ran the script only once - on the original “sound” file, before model modifications. That’s my fault. Here is the script’s results with hp-m4 model set:
http://www.alsa-project.org/db/?f=25904e5ce9f4989eec67f1e2e048e1bfb23084dd

What IEC958 settings do you mean?

I have tried Mandriva 2009 LiveCD
By default voume level was set too low, so I thought there is the same issue. But after setting all to 100% I can hear music plaing.

Here is alsa-info output fro Mandriva:http://www.alsa-project.org/db/?f=6cbe80d4506b15100aee28019d18eb3423860e1f

The ones available on your mixer.

If your sound still does not work on openSUSE, then I see your choices are to either:

a. update to a cutting edge version of alsa Alsa-update - openSUSE

and/or

b. write a bug report on openSUSE: Submitting Bug Reports - openSUSE

You could include reference to the functionality in mandriva in the bug report. I did a computer comparison between the mandriva script output and the openSUSE script output, but I do not know enough to draw any positive conclusions. I did note mandriva appear to be applying an option “power_save=1” . I also noted mandriva end up with different pin assignments.

**
That helped!**

I have reverted all modified config files to default ones were after clear install and tried to play with mixer settings.

That what I have had by default:

http://photofile.ru/photo/tos4/3659948/small/81920118.jpg](http://photofile.ru/photo/tos4/3659948/81920118.jpg)

After trying all possible combinations I finally found the one working.
And oh God, I forgot I had all volumes set to 100%, can you imagine how was I frightened? lol! “Front left! Front right!” >:)

Here are final worked setting (only 2 buttons altered):

http://photofile.ru/photo/tos4/3659948/small/81920120.jpg](http://photofile.ru/photo/tos4/3659948/81920120.jpg)

It’s clear the default settings are incorrect
What do you think, is it a bug? Should I file a Bug?

And thank you very much for pointing me to correct solution!
You help was very appreciated!

Works only external speakers connected to head-phones jack
Internal speakers doesn’t work as well as volume buttons (soft keys).

What settings are responsible for integrated speakers?

Congratulations on the progress you have made.

Did you try again the edits to your /etc/modprobe.d/sound file? In particular:
“options snd-hda-intel model=hp-m4 enable_msi=1” ? Remember to restart, and then carefully adjust your mixer (it may help to do various screen dumps or take notes). Good luck.

If nothing else, it means next time I look at the script output, and I see this:Simple mixer control ‘Analog Loopback’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control ‘Analog Loopback’,1
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on] I can then tell the user to try switching those off . :slight_smile:

Play a bit more with your mixer settings and the boot codes. Then if you make no further progress, write a bug report.

There is also the microphone aspect that probably needs to be investigated at some time.

I hope you do get this working fully, … I like the specs of this laptop (the HP DV5) and I’ve been recommending it to friends.

What puzzles me is on your mandriva, those are also switched ON, yet your sound works there.

I tried hp-m4 option.
No effect. I mean, sound still goes well through the external speakers, but no sound out of the integrated speakers.
The only one difference - some options disappeared from the Mixer:

http://photofile.ru/photo/tos4/3659948/small/81934095.jpg](http://photofile.ru/photo/tos4/3659948/81934095.jpg)

And here is the Mixer of Mandriva:

http://photofile.ru/photo/tos4/3659948/small/81934096.jpg](http://photofile.ru/photo/tos4/3659948/81934096.jpg)

Notice here two “Analog loopback” - muting/unmuting has no effect. But I found there is no sound through the integrated speakers in Mandriva too. Only external works.

I tried many combinations of Mixer in openSuse, in Mandriva - nothing. Integrated speakers are quite as a dead fish

After using dell-m4-1 option integrated speakers are working!

Here is final sound file:

options snd-hda-intel model=dell-m4-1 enable_msi=1
options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.DVex+nmP8+5:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
# NXNs.HS4OKn_IlZ0:RV620 Audio device [Radeon HD 34xx Series]
alias snd-card-1 snd-hda-intel

Here is mixer screenshot:

http://photofile.ru/photo/tos4/3659948/small/81934299.jpg](http://photofile.ru/photo/tos4/3659948/81934299.jpg)

And alsa-info: http://www.alsa-project.org/db/?f=10e7d327a52c1748df9f773f78f7915b93313aa2

Great! rotfl!

Congratulations, and thank you for sharing your solution.

oldcpu, thanks for you help!

A little bit offtop
What could make me fully happy is volume soft buttons.
All soft buttons (from wireless to Sleep) works fine except Volume and Mute.

Could you point me again where to dig to make them work?

I recommend you start a new thread on this.