No sound / only dummy output

I’ve restarted my laptop after a few weeks and I can’t play any sound (it has worked before the restart).
If I go to system settings > multemedia, it shows only dummy output for sound. I can’t even play test sound via YaST.

Output from

I have 13.1, KDE 4.11.5
alsa and pulse should be installed:

jaa@suse:~> rpm -qa | grep alsa
jaa@suse:~> rpm -qa | grep pulse

Any idea what could be wrong? Thanks for any help!

I get something similar on my work desktop. I’m pretty sure that’s because there is no sound card installed. A dummy sound device is created.

Is it possible that you have a hardware failure?

No, I also have windows installed and sound works OK.

I can’t see anything that explains only the dummy output for sound in your post, but I note from that script you have the speakers switched OFF on your PC’s openSUSE:

**Simple mixer control 'Speaker',0**

  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 74

  Front Left: Playback 0 **[0%]** -74.00dB] **[off]**

  Front Right: Playback 0 **[0%]** -74.00dB] **[off]**

Well I don’t know, how to turn it on… All the usual volume controls are on 100% (alsamixer, yast,…). But I gues the dummy output is the real problem…

Install pavucontrol from the Packman repo. That gives you the IMHO best tool to analyze and fix your audio issue. Like oldcpu states, it’s clear that the speaker volume is at 0.

I did, but it also shows only dummy output.
OK, so I’ve noticed that speakers were actually muted in alsamixer (I don’t know how I’ve missed it before), so I turned it on. It still doesn’t work with pulseaudio, but if I disable pulseaudio in YaST, the sound works (it shows default instead of dummy device in system settings)…

I would still like to get pulseaudio working, but at least I have sound now…

One thing that could cause only a dummy output to appear is when you have timidity running as system daemon, as it blocks the sound card for PulseAudio.
Did you enable this maybe? Check in YaST->System->Services Manager.

There may be other stuff that could block the sound card, so maybe try to disable other things as well that might have to do with sound, like speech-dispatcher or festival f.e.
When they start up at boot, no PulseAudio is running yet, so they might use Alsa directly instead of PA which would cause PA to not be able to grab the sound card.

You could also try to disable PulseAudio as a test in YaST->Hardware->Sound->Other->PulseAudio Configuration. Does the sound work then after a reboot?

hmmmm … I can’t see your alsamixer output, but that statement I quote is difficult for me to accept. alsamixer is nominally very good. Possibly there is an additional alsamixer menu you need to bring up ?

As a different approach, did you try the ‘amixer’ command to turn on the ‘speaker’ ? ie something like:

amixer -c 0 -- sset 'Speaker' on 90% 

where I am guessing at the syntax. Note where I have spaces and dashes is critical. Don’t deviate from my syntax (assuming I have it correct).

Then if that is successful, try testing the audio with:

speaker-test -c2 -D hw:0,0  -l2 -twav

I’m guessing 2 channel with the -c2 and also guessing you have this setup to send sound not to your HMDI device but to your speakers.

I can’t see anything in the script to support that. Please, can you provide a screen print or something, that can help us understand that assessment ?

Did you try tuning pulse audio ?

There is guidance here in a couple of blogs:

ok , … I missed this edit.

Well done !!

I don’t use timidity, nothig seems to bock the card:

# fuser -v /dev/snd/*
                     USER        PID ACCESS COMMAND
/dev/snd/controlC0:  jaa        4699 F.... pulseaudio
/dev/snd/pcmC0D0p:   jaa        4699 F...m pulseaudio

Yes, if I disable pulseaudio, sound works. I also have speakers muted in alsamixer after each reboot - but if I turn it on, it works (without pulseaudio).

np, thanks for help:) I would still like to get pulseaudio working though…

Hm, do you get any error message when you run pavucontrol in a terminal window?

Try to remove the directory /run/user/1000/pulse/ (replace 1000 with your actual user id), f.e. like this:

sudo rm -r /run/user/`id -u`/pulse/

There was an issue that this directory could be owned by root when you use sudo, which would prevent user applications from accessing it and connecting to PA therefore.
Although this should fix itself when you reboot, since /run is only a tmpfs.

You could also try to add your user to the “audio” group, but that shouldn’t be necessary.

No errors.

Tried, still no change.

I’ve already tried this, doesn’t help…

Since you said it was working a few weeks ago:
So maybe some update caused your problem?

Try to boot the older kernel under “Advanced Options” in the boot menu.
Does it work then maybe?

Thank you so much!!! I don’t how long it would have taken me to figure this out on my own. The other day I was playing around with Rosegarden and Timidity (got Rosegarden working, but never got Timidity working) and I enabled Timidity as a service.

I was seeing the same symptoms as the OP, which led me here.


See the file /usr/share/doc/packages/timidity/README.SUSE for how to use/start timidity when using pulseaudio. Or disable pulseaudio in YaST->Hardware->Sound->Other->PulseAudio Configuration if you want to start timidity as system service.

I was seeing the same symptoms as the OP, which led me here.

Ok, but the OP didn’t use timidity at all… :wink: